Scripts for docker-machine to install a particular docker version
Branch: master
Clone or download
Pull request Compare This branch is 3 commits ahead, 39 commits behind rancher:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
1.10.3.sh
1.10.sh
1.11.2.sh
1.11.sh
1.12.1.sh
1.12.2.sh
1.12.3.sh
1.12.4.sh
1.12.5.sh
1.12.6.sh
1.12.sh
1.13.0.sh
1.13.1.sh
1.13.sh
17.03.0.sh
17.03.1.sh
17.03.sh
17.04.0.sh
17.04.sh
README.md
sync.sh

README.md

Description

These scripts are originated from get.docker.com and are meant for quick & easy docker installation in different versions. They use mirrors in China(Thanks to USTC) to help relief network problem to get docker in China environment.

Usage

curl -sSL https://github.com/gitlawr/install-docker/blob/1.0/<docker-version-you-want>.sh?raw=true | sh

or:

wget -qO- https://github.com/gitlawr/install-docker/blob/1.0/<docker-version-you-want>.sh?raw=true | sh 

Supported Docker Version

Might slightly different among Linux distributions, for example no 1.10.3 for Ubuntu 16.04.

  • 1.10.3
  • 1.11.2
  • 1.12.1
  • 1.12.2
  • 1.12.3
  • 1.12.4
  • 1.12.5
  • 1.12.6
  • 1.13.0
  • 1.13.1
  • 17.03.0
  • 17.03.1
  • 17.04.0

Notes

The scripts are tested on Ubuntu_Xenial,CentOS7 and Debian_Jessie. If you encounter any problem using these scripts, feel free to change them yourself, bring up an issue or send me an email.