New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Change language? #79

Closed
JanLoebel opened this Issue Jun 6, 2017 · 25 comments

Comments

Projects
None yet
@JanLoebel
Copy link

JanLoebel commented Jun 6, 2017

Hi there,

I just wanted to ask if it is possible to change the language the Google assistant is using. The hot word detection can be done with "American English", but the question itself should be recognized for example in German, and the assistant, of course, should response in German. Is this currently possible?

Best regards and many thanks!

@Simonx22

This comment has been minimized.

Copy link

Simonx22 commented Jun 6, 2017

The Google Assistant for Google Home is only available in English right now. Other languages will come later in this Summer. So you can propably expect that other languages will come to the SDK later this year.

@proppy proppy added the question label Jun 6, 2017

@proppy

This comment has been minimized.

Copy link
Collaborator

proppy commented Jun 8, 2017

@JanLoebel I also encourage you to discuss this topic w/ the product team on the Google+ community.

@Robomate

This comment has been minimized.

Copy link

Robomate commented Sep 11, 2017

Other languages will come later in this Summer . Ok Summer is over , where are the other languages?

Any Update for German and French??

@vettorazi

This comment has been minimized.

Copy link

vettorazi commented Sep 16, 2017

nothing...

@Netfreak25

This comment has been minimized.

Copy link

Netfreak25 commented Sep 28, 2017

I would really love to get german support!

@martinklein

This comment has been minimized.

Copy link

martinklein commented Nov 18, 2017

Please implement the "German" support !!

@Fleker

This comment has been minimized.

Copy link
Collaborator

Fleker commented Nov 18, 2017

Thanks for your feedback. As others have said, currently the SDK only supports the en-US locale right now. We do want to make it easier for other locales to use the SDK as well. Thank you for your patience.

@Enzoinventor

This comment has been minimized.

Copy link

Enzoinventor commented Dec 19, 2017

Hello, when could we also have the Italian language?
I also asked myself:
since this API is back to work: http://translate.google.com/translate_tts?ie=UTF-8&client=tw-ob&q=$NEXTURL&tl=It-it
can not be replaced with tts integrated into the AiY image which for tts uses pico which is (horrible)?
thanks

@Fleker

This comment has been minimized.

Copy link
Collaborator

Fleker commented Dec 20, 2017

You can now manually set the locale in the gRPC request. This allows developers to use it in German, French, and all other Assistant-supported locales.

It can also be changed in the Assistant settings for a particular device.

@Fleker Fleker closed this Dec 20, 2017

@Enzoinventor

This comment has been minimized.

Copy link

Enzoinventor commented Dec 20, 2017

thanks for the reply, but I did not understand in which file do you have to intervene exactly? you're not referring to the i18n.py file, right?

@Fleker

This comment has been minimized.

Copy link
Collaborator

Fleker commented Dec 20, 2017

You can do it directly in the command line for pushtotalk.py with the --lang en-US flag or set the language_code in the DialogStateIn

https://github.com/googlesamples/assistant-sdk-python/blob/master/google-assistant-sdk/googlesamples/assistant/grpc/pushtotalk.py#L175

@Enzoinventor

This comment has been minimized.

Copy link

Enzoinventor commented Dec 20, 2017

thanks for the reply, on my rpi3 I installed the image aiyprojects-2017-09-11.img and the file you linked me contains different information. just edit the pushtotalk.py file or do I have to copy all the code you've linked to the RPI3?
thank you so much

@Fleker

This comment has been minimized.

Copy link
Collaborator

Fleker commented Dec 20, 2017

You may need to update the pushtotalk sample and make sure you're using the latest version of the gRPC version.

@Enzoinventor

This comment has been minimized.

Copy link

Enzoinventor commented Dec 21, 2017

hello, sorry again, I tried to update from the link you gave me with sudo pip install --upgrade google-assistant-library. although the rpi3 has done everything, the library does not contain updated new files like pushtotalk.py.
do I forget something?
thank you

@JulianMined

This comment has been minimized.

Copy link

JulianMined commented Dec 21, 2017

Is there a way to change the language for the Hotword sample?
If i change it in the Assistant App, it hat no effect

@zhengpenghu

This comment has been minimized.

Copy link

zhengpenghu commented Dec 28, 2017

Hi @JulianMined, we fixed the issue with a new release https://pypi.python.org/pypi/google-assistant-sdk/0.4.1 See proppy's comment in #146 for detailed instruction.

@zhengpenghu

This comment has been minimized.

Copy link

zhengpenghu commented Dec 28, 2017

@Enzoinventor Assistant SDK library only supports changing language from Assistant App. If you want more flexibility in selecting language, you can try SDK service API.

@Enzoinventor

This comment has been minimized.

Copy link

Enzoinventor commented Dec 28, 2017

@zhengpenghu Thanks for the info. even if I do not find it correct to exclude several users who do not have at least android 6.0 to install the app assistant and change the language. what do you mean as api sdk?

@martinklein

This comment has been minimized.

Copy link

martinklein commented Dec 28, 2017

Many thanks for this guidance. However I am sure most of us entered this road with "The MagPi Essentials AIY Projects" that could be ordered from the Magpi Magazine as a nice and easy cardboard package.
Your guidance has little in common with the instructions in the booklet of this package.
For me the question is now if I have to restart from scratch or if I can upgrade the code that came with this package. In the booklet it states that it is based on the github.com/google/aiyprojects-raspian/tree/voicekit
The essential test of the Cloud Speech API is done with the "cloudspeech_demo.py" and this is propably what needs to be updated for additional languages besides the update of the installed sdk.

Many thanks for any help on this
Martin Klein

@zhengpenghu

This comment has been minimized.

Copy link

zhengpenghu commented Jan 5, 2018

This is a new version of Assistant SDK and some fields get changed, together with some new fields. The github link you give doesn't work, but I know that project. Assistant SDK is not built on top of Cloud Speech API, and it supports multi language by itself now, without cloud speech API support.
What I can suggest now, is either start from a scratch by yourself, or probably wait for an official migration guide.

@Mr-Pioupiou

This comment has been minimized.

Copy link

Mr-Pioupiou commented Jan 24, 2018

Hello, any new information regarding the language selection ?

@pvklink

This comment has been minimized.

Copy link

pvklink commented Sep 26, 2018

Hi,
When i try
googlesamples-assistant-pushtotalk --device-id --lang it-IT it works, it speaks Italian!

But
googlesamples-assistant-pushtotalk --device-id --lang nl-NL it DOES NOT work!
Strange because my google assistant app on my tablet does speak Dutch!
Somebody an idea ?

@Fleker

This comment has been minimized.

Copy link
Collaborator

Fleker commented Sep 26, 2018

For which spoken languages are supported in the service, you can visit this reference page.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment