New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add binding for libpeas & libpeas-gtk #152

Closed
WebFreak001 opened this Issue Apr 19, 2016 · 5 comments

Comments

Projects
None yet
2 participants
@WebFreak001

WebFreak001 commented Apr 19, 2016

libpeas is the plugin management system by gnome. They use it basically in all their software to allow extending it.

Adding the package to GtkD (because it relies on glib) would allow people to extend other projects using libpeas but also include a default GTK plugin manager & view using libpeas-gtk.

General project docs: https://developer.gnome.org/libpeas/stable/

MikeWey added a commit that referenced this issue Apr 20, 2016

@MikeWey

This comment has been minimized.

Member

MikeWey commented Apr 20, 2016

I've added the peas binding, may need some testing.

@WebFreak001

This comment has been minimized.

WebFreak001 commented Apr 20, 2016

omg that was so quick! gonna test it soon

@WebFreak001

This comment has been minimized.

WebFreak001 commented May 1, 2016

it still needs a sub-configuration in the dub.json

MikeWey added a commit that referenced this issue May 1, 2016

@MikeWey

This comment has been minimized.

Member

MikeWey commented May 1, 2016

Added the dub configuration.

@MikeWey

This comment has been minimized.

Member

MikeWey commented Jan 1, 2017

In release 3.4.0

@MikeWey MikeWey closed this Jan 1, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment