Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Why jwt depends on json < 2.0 ? #179

Closed
GoodMirek opened this issue Nov 30, 2016 · 7 comments
Closed

Why jwt depends on json < 2.0 ? #179

GoodMirek opened this issue Nov 30, 2016 · 7 comments
Assignees
Milestone

Comments

@GoodMirek
Copy link

@GoodMirek GoodMirek commented Nov 30, 2016

The latest versions 1.5.5 and 1.5.6 introduced a new dependency "json < 2.0". It causes conflict with our other gems, which use json 2.0.2.
What is the reason to depend on json version below 2.0 ?

@excpt
Copy link
Member

@excpt excpt commented Nov 30, 2016

It is currently compatible with older versions of ruby like 1.9.
Support will be dropped for the older versions by the end of this year.

With that the json version will be updated, too.

@GoodMirek
Copy link
Author

@GoodMirek GoodMirek commented Nov 30, 2016

@excpt Thanks for your quick response.
If the constraint was json > 0, would not that be compatible with both 1.9 (e.g. using json 1.8.3) and 2.x (using json 2.0.2) ?

@excpt
Copy link
Member

@excpt excpt commented Nov 30, 2016

I'll try that. Thanks for the hint.

@excpt
Copy link
Member

@excpt excpt commented Nov 30, 2016

I tried that but it will always try to install the latest gem version. This will have to wait until the support ends for older versions of ruby.

@excpt excpt closed this Nov 30, 2016
@partydrone
Copy link

@partydrone partydrone commented Dec 6, 2018

Two years later and this is still a dependency. I am putting my app in a Docker image with the latest version of Ruby (2.5). The base image for Ruby comes with json 2.1.0 already installed as a default gem, and this is causing errors to show up in my app now: you have already activated json-2.x but your Gemfile requires 1.8.x.

Any plans to update this? I'd rather update all my gem dependencies to support that latest version of json if I can.

@excpt
Copy link
Member

@excpt excpt commented Dec 7, 2018

@partydrone, you're right. The ticket was closed and in that it was simply forgotten to update the gemspecs file. Ruby 2.1 and Ruby 2.2 reached the EOL and 2.3 will reach EOL in march 2019.

I think it's now safe to update the version dependency in jwt.

@excpt excpt reopened this Dec 7, 2018
@excpt excpt self-assigned this Dec 7, 2018
@excpt excpt added this to the Version 2.2.0 milestone Dec 7, 2018
@excpt excpt modified the milestones: Version 2.2.0, Version 2.3.0 Sep 16, 2019
@jamesstonehill
Copy link
Contributor

@jamesstonehill jamesstonehill commented Dec 30, 2019

This can be closed. This has been done here:
eba7cd1#diff-c5e5abace3ae80accf5b0d5f988fe099

@anakinj anakinj closed this Dec 1, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
5 participants