Skip to content
Haskell bindings to LevelDB (https://github.com/google/leveldb)
Haskell Makefile
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
examples
src
test
.gitignore
.travis.yml
AUTHORS
CHANGELOG
LICENSE
Makefile
Readme.md
Setup.hs
leveldb-haskell.cabal
stack.yaml

Readme.md

This library provides Haskell bindings to LevelDB

Build Status

Installation

Prerequisites:

Note: as of version 1.3, LevelDB can be built as a shared library. Thus, as of version 0.1.0 of this library, LevelDB is no longer bundled and must be installed on the target system. On many systems / distributions, the LevelDB library is available via the native package manager. On Windows, you may want to follow these instructions.

To install the latest version from hackage:

$ cabal install leveldb-haskell

To install from checked-out source:

$ cabal install

Notes

This library is in very early stage and has seen very limited testing. Comments and contributions are welcome.

Bugs and Contributing

Please report issues via http://github.com/kim/leveldb-haskell/issues.
Patches are best submitted as pull requests, or via email (kim.altintop@gmail.com).

License

BSD 3, see LICENSE file.

You can’t perform that action at this time.