Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Server automation framework and application
Ruby Puppet Shell Emacs Lisp VimL Python
branch: master

This branch is 10909 commits behind puppetlabs:master

Merge pull request #589 from jeffweiss/ticket/master/13296_unless_in_…

…exec_causes_syntax_error

(#13296) 'unless' as a parameter inside a resource causes syntax error
latest commit 1d09389a06
@nicklewis nicklewis authored
Failed to load latest commit information.
acceptance (#7749) Improvements to handling settings, bootstrapping puppet
autotest
bin [#4196] Move the docs into the source directory structure
conf Merge branch '2.7.x'
examples
ext (#7749) Parse command line args and config file before loading app/face
lib
man
sbin [#4196] Move the docs into the source directory structure
spec Merge pull request #589 from jeffweiss/ticket/master/13296_unless_in_…
tasks/rake Merge remote-tracking branch 'origin/2.7.x'
test (#7749) doc / tests cleanup
.gitignore Revert "Merge pull request #396 from jeffmccune/feature/2.7.x/12088_w…
.testseries Updated test series
CHANGELOG
CONTRIBUTING.md Add document outlining preferred contribution methods
LICENSE Fixed #5684 - Move to Apache 2.0 license
README.md
README_DEVELOPER.md
Rakefile Revert "Merge branch 'ticket/10081' of git://github.com/jgrocho/puppet"
install.rb Merge remote-tracking branch 'origin/2.7.x'

README.md

Puppet

Puppet, an automated administrative engine for your Linux and Unix systems, performs administrative tasks (such as adding users, installing packages, and updating server configurations) based on a centralized specification.

Documentation (and detailed installation instructions) can be found online at the Puppet Docs site.

Installation

Generally, you need the following things installed:

  • A supported Ruby version. Ruby 1.8.5, 1.8.7, and 1.9.2 are fully supported (with a handful of known issues under 1.9.2); Ruby 1.8.1 is supported on a best-effort basis for agent use only. Other versions of Ruby are used at your own risk, and Ruby 1.8.6, 1.9.0, and 1.9.1 are not recommended for compatibility reasons.

  • The Ruby OpenSSL library. For some reason, this often isn't included in the main ruby distributions. You can test for it by running 'ruby -ropenssl -e "puts :yep"'. If that errors out, you're missing the library.

    If your distribution doesn't come with the necessary library (e.g., on Debian and Ubuntu you need to install libopenssl-ruby), then you'll probably have to compile Ruby yourself, since it's part of the standard library and not available separately. You could probably just compile and install that one library, though.

  • Facter => 1.5.1 (available via your package manager or from the Facter site).

License

See LICENSE file.

Support

Please log tickets and issues at our Projects site

Something went wrong with that request. Please try again.