New doc build failure #1953

Merged
merged 1 commit into from May 13, 2013

Conversation

Projects
None yet
3 participants
Owner

mdboom commented May 10, 2013

Latex problems again. Doc pull requests merged in the last day are #1924 and #1918, by the looks of it.

There's a lot of warnings, ending in:

LaTeX Warning: Hyper reference `mpl_toolkits/mplot3d/index:toolkit-mplot3d-inde
x' on page 521 undefined on input line 29783.


LaTeX Warning: File `_images/contourf3d_demo21.png' not found on input line 297
88.


! Package pdftex.def Error: File `_images/contourf3d_demo21.png' not found.

See the pdftex.def package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.29788 ...graphics{_images/contourf3d_demo21.png}

? 
! Emergency stop.
 ...                                              

l.29788 ...graphics{_images/contourf3d_demo21.png}

!  ==> Fatal error occurred, no output PDF file produced!

Build log

Contributor

takluyver commented May 9, 2013

I've once again disabled the daily builds, so please ping me when you think that this has been fixed.

Use a plot directive rather than a link to a file in the _image direc…
…tory, since the latter doesn't work with the latex build
Owner

mdboom commented May 10, 2013

It seems to go back to @pelson's 401e907, which introduced an image linked to the _image directory. The _image directory is created only for the HTML build, so LaTeX can't see it. Changing this to a plot directive resolves the issue [see attached], and I'm able to complete the doc build, at least on my local machine.

Member

pelson commented May 13, 2013

Thanks @mdboom. I'm going to merge, as this is a better solution. @takluyver - does this fix the PDF build?

pelson added a commit that referenced this pull request May 13, 2013

Merge pull request #1953 from mdboom/fix-doc-build
Fixed use of generated image in documentation build.

@pelson pelson merged commit 301d6df into matplotlib:master May 13, 2013

1 check passed

default The Travis CI build passed
Details
Contributor

takluyver commented May 13, 2013

Yep, it seems to be working again. Thanks!

@mdboom mdboom deleted the mdboom:fix-doc-build branch Aug 7, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment