Repository navigation
Compatibility
- Fix #43: upgrade the bundled analyzer toolchain to analyzer 14.4.0, analysis_server_plugin 0.3.23, and analyzer_plugin 0.14.17. Oref now resolves with current Drift, build_runner, and Retrofit generators without dependency overrides.
- Keep the existing Oref package, state management API, and
plugins: orefconfiguration. - Require Flutter 3.47+ / Dart 3.13+. Older Flutter SDKs pin
metabelow the new analyzer's minimum. - Upgrade alien_signals to 2.3.2, including computed getter error caching.
- Upgrade DevTools dependencies and rebuild the extension for 2.10.0.
Validation
227 runtime tests, 27 analyzer tests, and 7 example tests pass. Real Drift/Retrofit generation, plugin diagnostics and ignore syntax, DevTools build/validation, and pub publish dry-run pass.
Install or update with flutter pub add oref:^2.10.0.