Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

mGBA Switch: Issue when using X to exit the emulator #1283

Closed
HowManyNames opened this issue Jan 29, 2019 · 1 comment
Labels
Milestone

Comments

@HowManyNames
Copy link

@HowManyNames HowManyNames commented Jan 29, 2019

Upon pressing X in the emulator's GUI to exit, the screen will flash, and then it'll otherwise exit normally. However if you try to relaunch mGBA after closing it, the Switch will hang for a few seconds at a black screen and the Switch will eventually bring up an error message. This happens on both 0.7.0 stable and the latest Switch nightly as of 8:42 AM Jan 29th (switch-5434-2d303cdda314c48a9534fef04782f8ad2bf2ca6a)

Tested on Atmosphere 0.8.3, latest HBL loader, latest homebrew menu, using NSP HBL override.

Thanks for the emulator!

@endrift

This comment has been minimized.

Copy link
Member

@endrift endrift commented Jan 29, 2019

It looks like it's running out of memory when it tries to compile a shader. But only the second time you launch.

@endrift endrift added the os:Switch label Jan 29, 2019
@endrift endrift closed this in 0eaa9e4 Jan 29, 2019
endrift added a commit that referenced this issue Jan 29, 2019
@endrift endrift added this to the mGBA 0.7.1 milestone Jan 29, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.