Skip to content
Permalink
Browse files

build: fix version checks in configure.py

Fixes: #29927
Refs: #29931

PR-URL: #29965
Reviewed-By: Richard Lau <riclau@uk.ibm.com>
Reviewed-By: David Carlier <devnexen@gmail.com>
Reviewed-By: Luigi Pinca <luigipinca@gmail.com>
Reviewed-By: Ben Noordhuis <info@bnoordhuis.nl>
  • Loading branch information
targos committed Oct 14, 2019
1 parent a1adce1 commit 02f6e5cc403fe546e9074b99019ed4ff505a4b73
Showing with 5 additions and 4 deletions.
  1. +5 −4 configure.py
@@ -12,6 +12,7 @@
import subprocess
import shutil
from distutils.spawn import find_executable as which
from distutils.version import StrictVersion

# If not run from node/, cd to node/.
os.chdir(os.path.dirname(__file__) or '.')
@@ -1229,10 +1230,10 @@ def without_ssl_error(option):
# supported asm compiler for AVX2. See https://github.com/openssl/openssl/
# blob/OpenSSL_1_1_0-stable/crypto/modes/asm/aesni-gcm-x86_64.pl#L52-L69
openssl110_asm_supported = \
('gas_version' in variables and float(variables['gas_version']) >= 2.23) or \
('xcode_version' in variables and float(variables['xcode_version']) >= 5.0) or \
('llvm_version' in variables and float(variables['llvm_version']) >= 3.3) or \
('nasm_version' in variables and float(variables['nasm_version']) >= 2.10)
('gas_version' in variables and StrictVersion(variables['gas_version']) >= StrictVersion('2.23')) or \
('xcode_version' in variables and StrictVersion(variables['xcode_version']) >= StrictVersion('5.0')) or \
('llvm_version' in variables and StrictVersion(variables['llvm_version']) >= StrictVersion('3.3')) or \
('nasm_version' in variables and StrictVersion(variables['nasm_version']) >= StrictVersion('2.10'))

if is_x86 and not openssl110_asm_supported:
error('''Did not find a new enough assembler, install one or build with

0 comments on commit 02f6e5c

Please sign in to comment.
You can’t perform that action at this time.