Skip to content
Permalink
Browse files

doc: upgrade Clang requirement to 3.4.2

Clang 3.4.1 has a bug that prevents compilation of V8.
As of Node.js 8.0.0 we stopped floating a workaround for this issue.

PR-URL: #12388
Reviewed-By: Ben Noordhuis <info@bnoordhuis.nl>
Reviewed-By: Colin Ihrig <cjihrig@gmail.com>
Reviewed-By: Benjamin Gruenbaum <benjamingr@gmail.com>
Reviewed-By: James M Snell <jasnell@gmail.com>
Reviewed-By: Gibson Fahnestock <gibfahn@gmail.com>
  • Loading branch information...
targos authored and jasnell committed Apr 13, 2017
1 parent eaa0542 commit b4f59a7460150bd2e5e5858fb93161547d799633
Showing with 4 additions and 4 deletions.
  1. +2 −2 BUILDING.md
  2. +2 −2 configure
@@ -62,7 +62,7 @@ Depending on host platform, the selection of toolchains may vary.
#### Unix

* GCC 4.8.5 or newer
* Clang 3.4.1 or newer
* Clang 3.4.2 or newer

#### Windows

@@ -77,7 +77,7 @@ Depending on host platform, the selection of toolchains may vary.
Prerequisites:

* `gcc` and `g++` 4.8.5 or newer, or
* `clang` and `clang++` 3.4.1 or newer
* `clang` and `clang++` 3.4.2 or newer
* Python 2.6 or 2.7
* GNU Make 3.81 or newer

@@ -617,8 +617,8 @@ def check_compiler(o):
ok, is_clang, clang_version, gcc_version = try_check_compiler(CXX, 'c++')
if not ok:
warn('failed to autodetect C++ compiler version (CXX=%s)' % CXX)
elif clang_version < '3.4.0' if is_clang else gcc_version < '4.8.0':
warn('C++ compiler too old, need g++ 4.8 or clang++ 3.4 (CXX=%s)' % CXX)
elif clang_version < '3.4.2' if is_clang else gcc_version < '4.8.0':
warn('C++ compiler too old, need g++ 4.8 or clang++ 3.4.2 (CXX=%s)' % CXX)

ok, is_clang, clang_version, gcc_version = try_check_compiler(CC, 'c')
if not ok:

0 comments on commit b4f59a7

Please sign in to comment.
You can’t perform that action at this time.