Permalink
Browse files

src: update NODE_MODULE_VERSION to 57

Node.js 8.0.0 is API/ABI forward-compatible with V8 6.0.
The current module version is 55 and corresponds to V8 5.8. This
increments the number by two to prevent incompatibility with modules
compiled from Node master.

PR-URL: #12995
Reviewed-By: Ali Ijaz Sheikh <ofrobots@google.com>
Reviewed-By: Anna Henningsen <anna@addaleax.net>
Reviewed-By: Gibson Fahnestock <gibfahn@gmail.com>
Reviewed-By: James M Snell <jasnell@gmail.com>
Reviewed-By: Michael Dawson <michael_dawson@ca.ibm.com>
  • Loading branch information...
targos authored and jasnell committed May 12, 2017
1 parent a6023ee commit ec7cbaf266d892f4a969628476a493f2824e2d1e
Showing with 1 addition and 1 deletion.
  1. +1 −1 src/node_version.h
View
@@ -73,6 +73,6 @@
* an API is broken in the C++ side, including in v8 or
* other dependencies.
*/
#define NODE_MODULE_VERSION 55 /* Node.js v8.0.0 */
#define NODE_MODULE_VERSION 57 /* Node.js v8.0.0 */
#endif // SRC_NODE_VERSION_H_

0 comments on commit ec7cbaf

Please sign in to comment.