Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
This project is cancelled in favour of dm-mongo-adapter.
Ruby
Branch: master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
lib
spec
.document
.gitignore
FIXME
LICENSE
README.rdoc
Rakefile
VERSION
mongodb_adapter.gemspec

README.rdoc

mongodb_adapter

A mostly functional DataMapper adapter for MongoDB.

4 specs are not passing, to do with OR conditions or negated regular expressions.

Updating on Serial is also broken when Serial field is not called '_id'. So call Serial field '_id', OK?

Installation

gem install mongodb_adapter

Usage

adapter: mongodb database: databasename host: hostname # defaults to 'localhost' port: portnum # defaults to 27017

Notes

Uses the 'mongo' gem. For extra performance you should install the 'mongo_ext' gem which adds native compiled components.

Something went wrong with that request. Please try again.