Feature Request: Lua 5.2 Support #204

Closed
chrislovecnm opened this Issue Jan 27, 2013 · 2 comments

Comments

Projects
None yet
2 participants

Hi all

What are the plans for 5.2 support? Since LuaJIT is now supporting 5.2 when can we plan to have 5.2 support with this module?

Thanks in advance, your work is appreciated!!

Chris

Owner

agentzh commented Jan 27, 2013

ngx_lua has already been working with LuaJIT 2.0 compiled with its Lua 5.2 compatibility mode.

It should be made clear that LuaJIT 2.0 only supports some new Lua 5.2 features on the Lua language level while it is still strictly following the Lua 5.1 ABI.

Making ngx_lua compatible with the Lua 5.2 ABI is a lot of work because it means forking the code base in a lot of places. But anyway it has been on our TODO list :)

Owner

agentzh commented Aug 8, 2014

This is a duplicate ticket to #343. Because there's no plan to support the full incompatible Lua 5.2 language and ABI or even beyond (like 5.3), I'm closing this.

@agentzh agentzh closed this Aug 8, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment