Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Install 2.6.1 failed #594

Closed
hankuksui opened this issue Sep 21, 2017 · 11 comments
Closed

Install 2.6.1 failed #594

hankuksui opened this issue Sep 21, 2017 · 11 comments

Comments

@hankuksui
Copy link

@hankuksui hankuksui commented Sep 21, 2017

pip install psycopg2==2.6.1

Collecting psycopg2==2.6.1
Using cached psycopg2-2.6.1.tar.gz
Complete output from command python setup.py egg_info:
running egg_info
creating pip-egg-info/psycopg2.egg-info
writing pip-egg-info/psycopg2.egg-info/PKG-INFO
writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt
writing dependency_links to pip-egg-info/psycopg2.egg-info/dependency_links.txt
writing manifest file 'pip-egg-info/psycopg2.egg-info/SOURCES.txt'
Error: could not determine PostgreSQL version from '10beta4'
----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-_0gGZg/psycopg2/

pip install psycopg2 success and installed version 2.7.3.1
but I want version 2.6.1

@dvarrazzo
Copy link
Member

@dvarrazzo dvarrazzo commented Sep 21, 2017

The problem was fixed in #489 released in psycopg 2.7. We don't have plans to backport the fix to 2.6.

Use a pg_config from a production version of Postgres not from 10 beta 4.

@dvarrazzo dvarrazzo closed this Sep 21, 2017
ruiztulio added a commit to vauxoo-dev/docker-odoo-image that referenced this issue Oct 11, 2017
We need to install postgresql-server-dev so the pg_config commands shows the proper version, at the moment it shows 10.0 even when only the 9.6 is installed. This issue was fixed in pycopg 2.7, but not in the previous versions: psycopg/psycopg2#594

This patch only apply for the images that uses older pycopg versions, that is 8.0 and 9.0 because 10 and 11 use 2.7.
raylu added a commit to raylu/openstudyroom that referenced this issue Oct 30, 2017
raylu added a commit to raylu/openstudyroom that referenced this issue Oct 30, 2017
mybits added a commit to womenhackfornonprofits/ocdaction that referenced this issue Nov 3, 2017
joe4dev added a commit to probr-uzh/probr-core that referenced this issue Nov 9, 2017
@jsj14
Copy link

@jsj14 jsj14 commented Nov 22, 2017

i get the same error with 10.1
Error: could not determine PostgreSQL version from '10.1'

@jsj14
Copy link

@jsj14 jsj14 commented Nov 23, 2017

This worked https://oshanebailey.jamaicandevelopers.com/python/error-could-not-determine-postgresql-version-10-0/

I changed it to psycopg2==2.7.1

ryankanno added a commit to CodeforHawaii/uipa_org that referenced this issue Nov 24, 2017
mohamed-aziz added a commit to gothinkster/flask-realworld-example-app that referenced this issue Nov 28, 2017
This version does not work with Postgres 10.
As per psycopg/psycopg2#594
johnbradley added a commit to Duke-GCB/bespin-api that referenced this issue Dec 4, 2017
Installing psycopg2 failes on circle due to postgres 10.0 version installed there.
```
Downloading psycopg2-2.6.2.tar.gz (376kB)
...
Error: could not determine PostgreSQL version from '10.0'
```
Bug Details: psycopg/psycopg2#594
We had this issue with iMADS already: Duke-GCB/iMADS#137
sargunv added a commit to PokeAPI/pokeapi that referenced this issue Sep 16, 2018
Versions below 2.7 no longer work on recent version of Ubuntu.
See psycopg/psycopg2#594.
perlun added a commit to hiboxsystems/trac-to-gitlab that referenced this issue Sep 18, 2018
See psycopg/psycopg2#594. The previous version did not support PG 10.5
kristinyim added a commit to noahpresler/semesterly that referenced this issue Oct 7, 2018
* fix build

* amend

* Bump psycopg2 version

Bug (psycopg/psycopg2#594) which fixed in
2.7.1

* use python image instead of node image

* don't use --user inside virtualenv

* fix javascript linting

* fix js tests

* silence messages for testing

* fix exams test

* fix travis config

* move babel preset to prod dependencies

* fix docs build

* add delete student endpoint
danielhers added a commit to danielhers/UCCA-App that referenced this issue Oct 21, 2018
danielhers added a commit to danielhers/UCCA-App that referenced this issue Oct 22, 2018
davidxia added a commit to davidxia/courtlistener that referenced this issue Oct 23, 2018
to fix this error on travis-ci.com that occurred when pip installing reqs.
See psycopg/psycopg2#594 (comment).

```
Collecting psycopg2==2.6.1 (from -r requirements.txt (line 58))
  Downloading https://files.pythonhosted.org/packages/86/fd/cc8315be63a41fe000cce20482a917e874cdc1151e62cb0141f5e55f711e/psycopg2-2.6.1.tar.gz (371kB)
    100% |████████████████████████████████| 378kB 3.6MB/s
    Complete output from command python setup.py egg_info:
    running egg_info
    creating pip-egg-info/psycopg2.egg-info
    writing pip-egg-info/psycopg2.egg-info/PKG-INFO
    writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt
    writing dependency_links to pip-egg-info/psycopg2.egg-info/dependency_links.txt
    writing manifest file 'pip-egg-info/psycopg2.egg-info/SOURCES.txt'
    Error: could not determine PostgreSQL version from '10.1'

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-NRfbIi/psycopg2/
The command "pip install -U -r requirements.txt" failed and exited with 1 during .
```
davidxia added a commit to davidxia/courtlistener that referenced this issue Oct 23, 2018
to fix this error on travis-ci.com that occurred when pip installing reqs.
See psycopg/psycopg2#594 (comment).

```
Collecting psycopg2==2.6.1 (from -r requirements.txt (line 58))
  Downloading https://files.pythonhosted.org/packages/86/fd/cc8315be63a41fe000cce20482a917e874cdc1151e62cb0141f5e55f711e/psycopg2-2.6.1.tar.gz (371kB)
    100% |████████████████████████████████| 378kB 3.6MB/s
    Complete output from command python setup.py egg_info:
    running egg_info
    creating pip-egg-info/psycopg2.egg-info
    writing pip-egg-info/psycopg2.egg-info/PKG-INFO
    writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt
    writing dependency_links to pip-egg-info/psycopg2.egg-info/dependency_links.txt
    writing manifest file 'pip-egg-info/psycopg2.egg-info/SOURCES.txt'
    Error: could not determine PostgreSQL version from '10.1'

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-NRfbIi/psycopg2/
The command "pip install -U -r requirements.txt" failed and exited with 1 during .
```
davidxia added a commit to davidxia/courtlistener that referenced this issue Oct 24, 2018
to fix this error on travis-ci.com that occurred when pip installing reqs.
See psycopg/psycopg2#594 (comment).

```
Collecting psycopg2==2.6.1 (from -r requirements.txt (line 58))
  Downloading https://files.pythonhosted.org/packages/86/fd/cc8315be63a41fe000cce20482a917e874cdc1151e62cb0141f5e55f711e/psycopg2-2.6.1.tar.gz (371kB)
    100% |████████████████████████████████| 378kB 3.6MB/s
    Complete output from command python setup.py egg_info:
    running egg_info
    creating pip-egg-info/psycopg2.egg-info
    writing pip-egg-info/psycopg2.egg-info/PKG-INFO
    writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt
    writing dependency_links to pip-egg-info/psycopg2.egg-info/dependency_links.txt
    writing manifest file 'pip-egg-info/psycopg2.egg-info/SOURCES.txt'
    Error: could not determine PostgreSQL version from '10.1'

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-NRfbIi/psycopg2/
The command "pip install -U -r requirements.txt" failed and exited with 1 during .
```
davidxia added a commit to davidxia/courtlistener that referenced this issue Oct 24, 2018
to fix this error on travis-ci.com that occurred when pip installing reqs.
See psycopg/psycopg2#594 (comment).

```
Collecting psycopg2==2.6.1 (from -r requirements.txt (line 58))
  Downloading https://files.pythonhosted.org/packages/86/fd/cc8315be63a41fe000cce20482a917e874cdc1151e62cb0141f5e55f711e/psycopg2-2.6.1.tar.gz (371kB)
    100% |████████████████████████████████| 378kB 3.6MB/s
    Complete output from command python setup.py egg_info:
    running egg_info
    creating pip-egg-info/psycopg2.egg-info
    writing pip-egg-info/psycopg2.egg-info/PKG-INFO
    writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt
    writing dependency_links to pip-egg-info/psycopg2.egg-info/dependency_links.txt
    writing manifest file 'pip-egg-info/psycopg2.egg-info/SOURCES.txt'
    Error: could not determine PostgreSQL version from '10.1'

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-NRfbIi/psycopg2/
The command "pip install -U -r requirements.txt" failed and exited with 1 during .
```
internetmosquito added a commit to internetmosquito/flask-jwt that referenced this issue Dec 21, 2018
Why:

* Seems this was causing troubles with Travis CI psycopg/psycopg2#594
tyhoff added a commit to tyhoff/pyembedpg that referenced this issue Dec 26, 2018
AlexRiina pushed a commit to AlexRiina/django-fernet-fields that referenced this issue Jan 18, 2019
psycopg2<2.7 looks for the a postgres version like x.xx which
unfortunately crashes trying to match 10.xx see
psycopg/psycopg2#594
@volartem
Copy link

@volartem volartem commented Feb 2, 2019

Yes upgrading psycopg2 helped.
Guys i had same problem in venv that was created on python 3.7.
I had psycopg2 version 2.6.2, so resolve this issue with upgrding psycopg2 to 2.7.2 and upgrading pip.

@elhadi-mohamed-mahmoud
Copy link

@elhadi-mohamed-mahmoud elhadi-mohamed-mahmoud commented Jul 10, 2019

this worked for me you have to specify the version beaucause 2.6.2 of psycopg2 only supports version 9.5 of postgresql.
pip install psycopg2==2.7.7

jrdh added a commit to NaturalHistoryMuseum/ckan that referenced this issue Oct 2, 2019
This is because of this: psycopg/psycopg2#594.
On 18.04 libpq-dev installs a pg_config which reports 10.10 which psycopg2
version 2.4.5 (good lord, how old?!) can't cope with and fails to install.
There may be a way of resolving this by installing some other version of
libpq-dev but I haven't found it yet, and I think this is the simplest
solution anyway.
@hankuksui
Copy link
Author

@hankuksui hankuksui commented Nov 13, 2019

> `pip install psycopg2==2.6.1`
> 
> > Collecting psycopg2==2.6.1
> > Using cached psycopg2-2.6.1.tar.gz
> > Complete output from command python setup.py egg_info:
> > running egg_info
> > creating pip-egg-info/psycopg2.egg-info
> > writing pip-egg-info/psycopg2.egg-info/PKG-INFO
> > writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt
> > writing dependency_links to pip-egg-info/psycopg2.egg-info/dependency_links.txt
> > writing manifest file 'pip-egg-info/psycopg2.egg-info/SOURCES.txt'
> > Error: could not determine PostgreSQL version from '10beta4'
> > ----------------------------------------
> > Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-_0gGZg/psycopg2/
> 
> `pip install psycopg2` success and installed version 2.7.3.1
> but I want version 2.6.1

PostgreSQL with version number without beta seems to be succeed.

verhyppo added a commit to verhyppo/qabel-block that referenced this issue Feb 14, 2020
abitrolly added a commit to kinaklub/next.filmfest.by that referenced this issue Feb 9, 2021
The error

    Error: could not determine PostgreSQL version from '10.1'

Fixed by psycopg/psycopg2#594
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
7 participants