Join GitHub today
rubygems-update requires Ruby version >= 2.3.0. #2534
I'm having a problem or would like to suggest a feature.
My current problem is that I have projects using
The error messages:
I would like to known how to update
This issue is related to:
Here are my current environment details:
I will abide by the code of conduct.
RubyGems 3.0.0 is only installable on Ruby >= 2.3
For 2.2 & 2.2.10, try
At present, RubyGems does not correctly handle Ruby version constraints.
EDIT: Windows type, not a bash type. For all Ruby versions, try:
It does waste a bit of time downloading 3.0.0 when used on Ruby 2.2, but it still installs 2.7.8...
Since it breaks the build for rubies < 2.3 because it tries to install version 3 of rubygems, which is incompatible. We could go around and keep updating system gems by trying to install rubygems 3 and if it fails we try to install version 2, as stated in rubygems issue #2534. But since most of the issues that made us always update the system gems are solved (conflit between rubygems and bundler) I saw no need for it Related: - Kinda like: plataformatec/devise@6e4b0b9 - Issue about the error: rubygems/rubygems#2534