Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support for Ubuntu 16.04 is removed on setup-php #452

Closed
shivammathur opened this issue May 1, 2021 · 1 comment
Closed

Support for Ubuntu 16.04 is removed on setup-php #452

shivammathur opened this issue May 1, 2021 · 1 comment

Comments

@shivammathur
Copy link
Owner

@shivammathur shivammathur commented May 1, 2021

Standard Support for Ubuntu 16.04 (Xenial Xerus) LTS has ended and it has entered Extended Security Maintenance (ESM), a paid offering from Canonical.

https://ubuntu.com/blog/ubuntu-16-04-lts-transitions-to-extended-security-maintenance-esm

So we will remove support for Ubuntu 16.04 based runners on August 1, 2021. It is highly recommended that you upgrade ubuntu-16.04 workflows to ubuntu-18.04 or ubuntu-20.04 (alias ubuntu-latest).

Notes:

  • ppa:ondrej/php has deleted Ubuntu 16.04 builds, so we have switched to a mirror of the PPA till the support is removed on August 1, 2021. Till that time Ubuntu 16.04 will not receive any updates to PHP versions or extensions. So please upgrade!

  • Many projects in past used ubuntu-16.04 because PHP 5.6 to 8.0 are pre-installed on it. We recently switched to cached PHP builds, which reduces the setup time to less than 5 sec for these versions, pre-installed or not. So you can upgrade the OS environment without any major changes in CI run time.

Thanks
Shivam Mathur

@shivammathur shivammathur pinned this issue May 1, 2021
em92 pushed a commit to RSS-Bridge/rss-bridge that referenced this issue May 30, 2021
Support for Ubuntu 16.04 (Xenial Xerus) runners is deprecated and will be removed on August 1, 2021
shivammathur/setup-php#452
@shivammathur
Copy link
Owner Author

@shivammathur shivammathur commented Aug 2, 2021

Support for Ubuntu 16.04 has been removed in 947009a.

@shivammathur shivammathur changed the title Support for Ubuntu 16.04 (Xenial Xerus) runners is deprecated and will be removed on August 1, 2021 Support for Ubuntu 16.04 is removed on setup-php Aug 2, 2021
@shivammathur shivammathur added this to Done in setup-php-tasks Aug 2, 2021
jrfnl added a commit to jrfnl/phpDocumentor that referenced this issue Aug 4, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant