C++ Ruby
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
ext/apt_pkg
lib/debian
test
.editorconfig
.gitignore
.travis.yml
Gemfile
History.md
LICENSE
README.md
Rakefile
apt-pkg.gemspec

README.md

Ruby interface to apt-pkg

Goal of this project is to have a proper Ruby binding to APT like in Python.

Currently install, remove packages commands are not implemented.

INSTALL

apt install build-essential ruby-dev libapt-pkg-dev (>= 1.0)
gem install apt-pkg

USING

Basic usage:

require 'debian/apt_pkg'

# Initialize the configuration and system of apt
Debian::AptPkg.init

# Update the index files used by the cache
Debian::AptPkg::PkgCache.update

# Search package by names
Debian::AptPkg::PkgCache.pkg_names("vim")

Documentation

BUILD

rake compile

TEST

rake test

LICENSE

The MIT License

Copyright (c) 2014-2016 Laurent Arnoud laurent@spkdev.net


Build Version Documentation License IRC Network Project status