Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error message "Unary operator expected" with new version #71

Closed
Lucas-C opened this issue Jan 20, 2016 · 3 comments

Comments

Projects
None yet
2 participants
@Lucas-C
Copy link

commented Jan 20, 2016

I have the following error messages using the latest apt-cyg when installing packages :

apt-cyg: line 468: [: -v : opérateur unaire attendu
apt-cyg: line 495: [: -v : opérateur unaire attendu

Apart from those log lines, everything seems to work fine.

@Lucas-C

This comment has been minimized.

Copy link
Author

commented Jan 20, 2016

The error seems to come from the following lines:

[ -v nodeps ] && continue
[ -v noscripts ] && continue

which where introduced in commit 395caa5

@Lucas-C

This comment has been minimized.

Copy link
Author

commented Jan 20, 2016

I'm using Bash v4.1 btw

@cup

This comment has been minimized.

Copy link
Contributor

commented Jan 20, 2016

Um, no? Bash 4.2 has been available since 2011:

http://ftp.gnu.org/gnu/bash

Update your system and stop wasting my time.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.