Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CLI fails to map sources/tests with code #146

Closed
alesana-san opened this issue May 1, 2019 · 2 comments
Closed

CLI fails to map sources/tests with code #146

alesana-san opened this issue May 1, 2019 · 2 comments

Comments

@alesana-san
Copy link

@alesana-san alesana-san commented May 1, 2019

Hi!

I post here full information about problem with running CLI using Jenkins CI.
I have the following folder structure:

12:12:29 + pwd
12:12:29 /u01/jenkins_slave/workspace/EPS/simplePayment_update_db
12:12:30 + find . -type d
12:12:30 .
12:12:30 ./tests
12:12:30 ./tests/sp_delayed_requests
12:12:30 ./tests/sp_errors
12:12:30 ./tests/sp_transaction_data
12:12:30 ./tests/sp_transactions
12:12:30 ./tests/views
12:12:30 ./scripts
12:12:30 ./scripts/556376
12:12:30 ./lib
12:12:30 ./utplsql
12:12:30 ./compiled
12:12:30 ./compiled/specs
12:12:30 ./compiled/types
12:12:30 ./compiled/bodies
12:12:30 ./compiled/views
12:12:30 ./rollback
12:12:30 ./rollback/556376
12:12:30 ./changelogs 

Here's my debug xml outputs: debug_xmls.zip
The owner of tests/sources is the same user I use to connect to DB.
Adding some logging stuff inside utplsql mapping routings showed that CLI sends right amount of paths but they are all NULLs (meaning that for 23 source files I saw map array with 23 entries but all of them were NULL in PL/SQL).
Versions of utplsql and utplsql-cli were the latest at the end of April.

@pesse
Copy link
Member

@pesse pesse commented May 15, 2019

Hi @alesana-san ,
can you please try the following cli-version with debug-option on ( -d ) and provide the output (you can also send it to me in private)?

https://bintray.com/utplsql/utPLSQL-cli/download_file?file_path=utPLSQL-cli-develop-201905150804.zip

Loading

pesse added a commit to utPLSQL/utPLSQL-java-api that referenced this issue May 23, 2019
@alesana-san
Copy link
Author

@alesana-san alesana-san commented May 24, 2019

Finally found out that my CLI lib directory lacked orai18n.jar.
The probable problem is https://stackoverflow.com/questions/14998299/oracle-array-filled-with-null-data-in-java (thanks to @pesse)

Loading

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

2 participants