Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

feat(pwa): improve compatibility with v3 plugin usage #4664

Merged
merged 1 commit into from Oct 10, 2019

Conversation

@sodatea
Copy link
Member

commented Oct 9, 2019

  1. public/manifest.json will be used when no pwa.manifestOptions
    present;
  2. warn user when there are both the file & the config field present.

What kind of change does this PR introduce? (check at least one)

  • Bugfix
  • Feature
  • Code style update
  • Refactor
  • Docs
  • Underlying tools
  • Other, please describe:

Does this PR introduce a breaking change? (check one)

  • Yes
  • No

Other information:

1. `public/manifest.json` will be used when no `pwa.manifestOptions`
present;
2. warn user when there are both the file & the config field present.
@sodatea sodatea merged commit 617dd04 into vuejs:dev Oct 10, 2019
7 checks passed
7 checks passed
ci/circleci: cli-ui Your tests passed on CircleCI!
Details
ci/circleci: group-1 Your tests passed on CircleCI!
Details
ci/circleci: group-2 Your tests passed on CircleCI!
Details
ci/circleci: group-3 Your tests passed on CircleCI!
Details
ci/circleci: group-4 Your tests passed on CircleCI!
Details
ci/circleci: install Your tests passed on CircleCI!
Details
continuous-integration/appveyor/pr AppVeyor build succeeded
Details
@sodatea sodatea deleted the sodatea:feat-warn-manifest branch Oct 10, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.