Yii 2 Codeception extension (DEPRECATED)
PHP
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.

README.md

Codeception Extension for Yii 2

This package is deprecated

This package is deprecated. All the features were intergrated into Codeception Yii2 module. Refer to official documentation.


This extension provides Codeception integration for the Yii framework 2.0.

It provides classes that help with testing with codeception:

  • a base class for unit-tests: yii\codeception\TestCase;
  • a base class for codeception page-objects: yii\codeception\BasePage.

For license information check the LICENSE-file.

Documentation is at docs/guide/README.md.

Latest Stable Version Total Downloads

Installation

The preferred way to install this extension is through composer.

Either run

php composer.phar require --prefer-dist yiisoft/yii2-codeception

or add

"yiisoft/yii2-codeception": "~2.0.0"

to the require section of your composer.json.