Repository navigation
Changed
- Dropped Python 3.10 support; the minimum supported Python version is now 3.11.
- Required patched Pillow >= 13.0.0 for every supported interpreter and removed the
Python 3.10 lockfile fallback to Pillow 12.3.0. - Updated the CI matrix, minimum-dependency job and installation documentation for
Python 3.11+, and removed the obsolete test/docs TOML parser compatibility dependency.
Fixed
- Updated the locked certifi dependency to 2026.10.19 to address its reported vulnerability.
Installation
python -m pip install --upgrade "trendfollowing==1.4.0"Requires Python 3.11+ and Pillow 13.0.0+.