Elder driver Xposed Framework.
Branch: master
Clone or download

README.md

EdXposed

A Riru module trying to provide a ART hooking framework (mainly for Android Pie) which delivers consistent APIs with the OG Xposed, leveraging YAHFA hooking framework.

Credits

  • YAHFA: the core java hooking framework
  • Riru: provides a way to inject codes into zygote process
  • XposedBridge: the OG xposed framework APIs
  • dexmaker and dalvikdx: dynamiclly generate YAHFA hooker classes
  • Whale: used for inline hooking

Known issues

  • resources hooking is not supported yet
  • may not be compatible with all ART devices
  • only a few Xposed modules has been tested for working
  • file access services are not implemented yet, now simply use magiskpolicy to enable needed SELinux policies

Build requirements

same as Riru-Core's and zip binaries can be downloaded from here

Build

  1. run :Bridge:makeAndCopyRelease in Gradle window to build edxposed.dex
  2. run :Core:zipRelease to build Magisk Riru module flashable zip file
  3. find the flashable under Core/release/
  4. flash the zip in recovery mode or in Magisk Manager

Install

  1. make sure Magisk v17.0 or higher is installed.
  2. download Riru-core v10 or higher and install it in Magisk Manager or recovery.
  3. download EdXposed and install it in Magisk Manager or recovery.
  4. Install companion application(s)
  5. reboot.
  6. have fun :)

Companion applications

Get help

Forum (recommend): Android Forum

GitHub issues (recommend): Issues

QQ Group: 855219808

Telegream: Code_of_MeowCat

Discord: Code_of_MeowCat

Contribute

Apparently this framework is far from stable and all kinds of PRs are welcome. :)