Skip to content

Actionable v1.10.0

Latest

Choose a tag to compare

@aemadrid-twx aemadrid-twx released this 25 Oct 17:59
3b6399c

Ruby 3.3 or newer is now required; the library itself is unchanged, so on
Ruby 3.3+ this is a drop-in bump from 1.9.0 (UPGRADING.md "1.9.0 → 1.10.0").
The rest is docs: every Ruby block in the docs is now parsed by a spec, USAGE
explains Result#status vs code and struct-typed input errors, and the README
installs from RubyGems. CI runs on our own self-hosted runners.

Changed

  • Ruby 3.3 or newer is required (required_ruby_version >= 3.3.0, was
    >= 3.2.0). 3.3 is the oldest Ruby a known client runs, and CI is moving to
    self-hosted Ubuntu 26.04 runners. The library code is unchanged; CI drops the
    3.2 lane and RuboCop targets 3.3.
    Upgrade note: on Ruby 3.2, stay on 1.9.x.

Fixed

  • A spec now parses every ```ruby block in README, USAGE, UPGRADING, AGENTS,
    the skill and docs/, doctest or not, so an example can't rot into invalid
    Ruby unseen. The one it caught, a `def … = ...` placeholder in UPGRADING's
    core-method-name entry, is now real Ruby.

Documentation

  • USAGE "Results" says what status is and that a Success's code is
    :success; USAGE "Input" shows a FieldStruct class as an input field and how
    an invalid one is reported (errors names only the field). Both doctested;
    gaps found by the docs-site tutorial.
  • README installs from RubyGems (gem 'actionable-rb'); 1.9.0 is published there.