Skip to content
Permalink
Browse files

fix: change template to work with jest (#23150)

Summary:
This change is required to make `yarn test` work in newly initialized project.
`Jest@23` doesn't play well with new babel, so we need to install `babel-core@^7.0.0-bridge.0` and change `.babelrc` to `babel.config.js` to make it work. This is a temporary change till `jest` releases stable `24` version.
Pull Request resolved: #23150

Differential Revision: D13811428

Pulled By: hramos

fbshipit-source-id: 8db6b9177cd31d4a1213fb44964b05f26982bdf2
  • Loading branch information...
Esemesek authored and facebook-github-bot committed Jan 25, 2019
1 parent 7795a67 commit 5218932b13ad0649ff2a57aaf1ec682fe278c47d
Showing with 3 additions and 3 deletions.
  1. +0 −3 template/_babelrc
  2. +3 −0 template/babel.config.js

This file was deleted.

Oops, something went wrong.
@@ -0,0 +1,3 @@
module.exports = {
presets: ['module:metro-react-native-babel-preset'],
};

0 comments on commit 5218932

Please sign in to comment.
You can’t perform that action at this time.