Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

cmd/go: get: can't query version "patch" of module X: no existing version is required #49111

Open
anacrolix opened this issue Oct 22, 2021 · 14 comments
Labels
GoCommand NeedsInvestigation
Milestone

Comments

@anacrolix
Copy link
Contributor

@anacrolix anacrolix commented Oct 22, 2021

What version of Go are you using (go version)?

$ go version
go version go1.17.2 darwin/amd64

Does this issue reproduce with the latest release?

Yes I think this is the latest release.

What operating system and processor architecture are you using (go env)?

go env Output
$ go env
GO111MODULE="auto"
GOARCH="amd64"
GOBIN=""
GOCACHE="/Users/anacrolix/Library/Caches/go-build"
GOENV="/Users/anacrolix/Library/Application Support/go/env"
GOEXE=""
GOEXPERIMENT=""
GOFLAGS=""
GOHOSTARCH="amd64"
GOHOSTOS="darwin"
GOINSECURE=""
GOMODCACHE="/Users/anacrolix/go/pkg/mod"
GONOPROXY="github.com/anacrolix"
GONOSUMDB="github.com/getlantern"
GOOS="darwin"
GOPATH="/Users/anacrolix/go"
GOPRIVATE="github.com/getlantern"
GOPROXY="https://proxy.golang.org,direct"
GOROOT="/Users/anacrolix/src/go1.17"
GOSUMDB="sum.golang.org"
GOTMPDIR=""
GOTOOLDIR="/Users/anacrolix/src/go1.17/pkg/tool/darwin_amd64"
GOVCS=""
GOVERSION="go1.17.2"
GCCGO="gccgo"
AR="ar"
CC="clang"
CXX="clang++"
CGO_ENABLED="1"
GOMOD="/Users/anacrolix/go/src/github.com/anacrolix/torrent/go.mod"
CGO_CFLAGS="-g -O2"
CGO_CPPFLAGS=""
CGO_CXXFLAGS="-g -O2"
CGO_FFLAGS="-g -O2"
CGO_LDFLAGS="-g -O2"
PKG_CONFIG="pkg-config"
GOGCCFLAGS="-fPIC -arch x86_64 -m64 -pthread -fno-caret-diagnostics -Qunused-arguments -fmessage-length=0 -fdebug-prefix-map=/var/folders/rx/s8fbr8m17nvg88dq7lkblhz00000gn/T/go-build2066949857=/tmp/go-build -gno-record-gcc-switches -fno-common"

What did you do?

Ran go get -u=patch in any of my repos (anacrolix/torrent and anacrolix/dht for example).

What did you expect to see?

Some noise about modules being updated to more recent patch releases.

What did you see instead?

$ go get -u=patch
go get: can't query version "patch" of module github.com/benbjohnson: no existing version is required
go get: can't query version "patch" of module github.com/bradfitz: no existing version is required
go get: can't query version "patch" of module github.com/edsrzf: no existing version is required
go get: can't query version "patch" of module github.com/huandu: no existing version is required
go get: can't query version "patch" of module github.com/pkg: no existing version is required
go get: can't query version "patch" of module github.com/rs: no existing version is required
go get: can't query version "patch" of module github.com/spaolacci: no existing version is required
go get: can't query version "patch" of module github.com/willf: no existing version is required
go get: can't query version "patch" of module github.com/willf: no existing version is required
go get: can't query version "patch" of module golang.org/x/sync/singleflight: no existing version is required
go get: can't query version "patch" of module golang.org/x/sys/internal/unsafeheader: no existing version is required
go get: can't query version "patch" of module golang.org/x/sys/unix: no existing version is required
go get: can't query version "patch" of module golang.org/x/sys/windows: no existing version is required
go get: can't query version "patch" of module golang.org/x/time/rate: no existing version is required
@seankhliao
Copy link
Member

@seankhliao seankhliao commented Oct 22, 2021

The errors look weird (those aren't module)
Can you paste the output of go get -u=patch -v -x ?

@anacrolix
Copy link
Contributor Author

@anacrolix anacrolix commented Oct 22, 2021

mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/chansync
mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/dht
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2.lock# /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2 for git3 https://github.com/anacrolix/dht
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264.lockcd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git ls-remote -q origin
mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/go-libutp
# /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264 for git3 https://github.com/anacrolix/chansync
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/2c927aa57f6b1821f9f3d12793c639c5ac54849aa56b7aa89d045b8a3b5de6bc.lockmkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/log
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/ac8f0295c8110f4ffe4f9519367c578aa9cb078595743f97b07424486c83e1d2.lock# /Users/anacrolix/go/pkg/mod/cache/vcs/ac8f0295c8110f4ffe4f9519367c578aa9cb078595743f97b07424486c83e1d2 for git3 https://github.com/anacrolix/log
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git ls-remote -q origin
mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/missinggo
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/b491e96e45f892b3e1d93708a5e0d6d68a08d5c03430ac6209c1e7615ee60c15.lockcd /Users/anacrolix/go/pkg/mod/cache/vcs/ac8f0295c8110f4ffe4f9519367c578aa9cb078595743f97b07424486c83e1d2; git ls-remote -q origin
# /Users/anacrolix/go/pkg/mod/cache/vcs/2c927aa57f6b1821f9f3d12793c639c5ac54849aa56b7aa89d045b8a3b5de6bc for git3 https://github.com/anacrolix/go-libutp
cd /Users/anacrolix/go/pkg/mod/cache/vcs/2c927aa57f6b1821f9f3d12793c639c5ac54849aa56b7aa89d045b8a3b5de6bc; git ls-remote -q origin
# /Users/anacrolix/go/pkg/mod/cache/vcs/b491e96e45f892b3e1d93708a5e0d6d68a08d5c03430ac6209c1e7615ee60c15 for git3 https://github.com/anacrolix/missinggo
cd /Users/anacrolix/go/pkg/mod/cache/vcs/b491e96e45f892b3e1d93708a5e0d6d68a08d5c03430ac6209c1e7615ee60c15; git ls-remote -q origin
0.724s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/ac8f0295c8110f4ffe4f9519367c578aa9cb078595743f97b07424486c83e1d2; git ls-remote -q origin
0.739s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git ls-remote -q origin
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' 3f72684c4a93b4004087c24768c2bc78d683a89c --
0.738s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/b491e96e45f892b3e1d93708a5e0d6d68a08d5c03430ac6209c1e7615ee60c15; git ls-remote -q origin
mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/sync
mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/multiless
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/95529b14e486dc366ce43cbcfdac3410f2ed3db32991fdb46b220e5bfeeb4d74.lock# lock /Users/anacrolix/go/pkg/mod/cache/vcs/cd3fa82511c857f13908c96b7b5cb50c7fdb0143794b8f478e842e9f15221b51.lock# /Users/anacrolix/go/pkg/mod/cache/vcs/cd3fa82511c857f13908c96b7b5cb50c7fdb0143794b8f478e842e9f15221b51 for git3 https://github.com/anacrolix/multiless
# /Users/anacrolix/go/pkg/mod/cache/vcs/95529b14e486dc366ce43cbcfdac3410f2ed3db32991fdb46b220e5bfeeb4d74 for git3 https://github.com/anacrolix/sync
cd /Users/anacrolix/go/pkg/mod/cache/vcs/cd3fa82511c857f13908c96b7b5cb50c7fdb0143794b8f478e842e9f15221b51; git ls-remote -q origin
cd /Users/anacrolix/go/pkg/mod/cache/vcs/95529b14e486dc366ce43cbcfdac3410f2ed3db32991fdb46b220e5bfeeb4d74; git ls-remote -q origin
0.747s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/2c927aa57f6b1821f9f3d12793c639c5ac54849aa56b7aa89d045b8a3b5de6bc; git ls-remote -q origin
0.013s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' 3f72684c4a93b4004087c24768c2bc78d683a89c --
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git tag -l
mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/utp
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/e54e01c7f186ea7e4bf415d674f0b12aee5ce08b5d4a481bd8ab6489a907939d.lockmkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/upnp
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976.lock# /Users/anacrolix/go/pkg/mod/cache/vcs/e54e01c7f186ea7e4bf415d674f0b12aee5ce08b5d4a481bd8ab6489a907939d for git3 https://github.com/anacrolix/utp
# /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976 for git3 https://github.com/anacrolix/upnp
cd /Users/anacrolix/go/pkg/mod/cache/vcs/e54e01c7f186ea7e4bf415d674f0b12aee5ce08b5d4a481bd8ab6489a907939d; git ls-remote -q origin
0.757s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git ls-remote -q origin
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git ls-remote -q origin
cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' a394caa07562a78e7bd4dfe6646e5d67449b0171 --
0.012s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git tag -l
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' refs/tags/v0.2.0 --
0.020s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' a394caa07562a78e7bd4dfe6646e5d67449b0171 --
cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git tag -l
0.015s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' refs/tags/v0.2.0 --
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git cat-file blob b914030c34f91629dbcb52ae24cfa4f42881f7ad:go.mod
0.012s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git tag -l
cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' refs/tags/v2.10.5 --
0.012s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git cat-file blob b914030c34f91629dbcb52ae24cfa4f42881f7ad:go.mod
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git cat-file blob 3f72684c4a93b4004087c24768c2bc78d683a89c:go.mod
0.013s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' refs/tags/v2.10.5 --
cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git cat-file blob 06cc4fe90e53116bf7841b50e3c678353675fd3a:go.mod
0.011s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git cat-file blob 3f72684c4a93b4004087c24768c2bc78d683a89c:go.mod
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git for-each-ref --format %(refname) refs/tags --merged 3f72684c4a93b4004087c24768c2bc78d683a89c
0.011s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git cat-file blob 06cc4fe90e53116bf7841b50e3c678353675fd3a:go.mod
cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git cat-file blob 06cc4fe90e53116bf7841b50e3c678353675fd3a:v2/go.mod
0.013s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git for-each-ref --format %(refname) refs/tags --merged 3f72684c4a93b4004087c24768c2bc78d683a89c
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git fetch -f origin 'refs/heads/*:refs/heads/*' 'refs/tags/*:refs/tags/*'
0.012s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git cat-file blob 06cc4fe90e53116bf7841b50e3c678353675fd3a:v2/go.mod
cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git for-each-ref --format %(refname) refs/tags --merged a394caa07562a78e7bd4dfe6646e5d67449b0171
mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/envpprof
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/c2fb192dab45ced81ad17d71da488432c85f03d855ad52c5e4e78a1f5e4ceb42.lock# /Users/anacrolix/go/pkg/mod/cache/vcs/c2fb192dab45ced81ad17d71da488432c85f03d855ad52c5e4e78a1f5e4ceb42 for git3 https://github.com/anacrolix/envpprof
cd /Users/anacrolix/go/pkg/mod/cache/vcs/c2fb192dab45ced81ad17d71da488432c85f03d855ad52c5e4e78a1f5e4ceb42; git ls-remote -q origin
mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/mmsg
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/7d034700d5690944a1f85a595191788fc570f90048382f203b49a944bde3c3d1.lock0.015s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git for-each-ref --format %(refname) refs/tags --merged a394caa07562a78e7bd4dfe6646e5d67449b0171
# /Users/anacrolix/go/pkg/mod/cache/vcs/7d034700d5690944a1f85a595191788fc570f90048382f203b49a944bde3c3d1 for git3 https://github.com/anacrolix/mmsg
cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' a394caa07562 --
cd /Users/anacrolix/go/pkg/mod/cache/vcs/7d034700d5690944a1f85a595191788fc570f90048382f203b49a944bde3c3d1; git ls-remote -q origin
0.012s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' a394caa07562 --
cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git cat-file blob a394caa07562a78e7bd4dfe6646e5d67449b0171:go.mod
0.010s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git cat-file blob a394caa07562a78e7bd4dfe6646e5d67449b0171:go.mod
cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git cat-file blob a394caa07562a78e7bd4dfe6646e5d67449b0171:v2/go.mod
0.009s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/0f340bbca7fe2777a159bc71ea7e4e7ea3665c5ceebe96fd311e5668e4e9bac2; git cat-file blob a394caa07562a78e7bd4dfe6646e5d67449b0171:v2/go.mod
mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/confluence
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/405aaa672dfd1ccd25134e9d4b2eb0176febfb30e38fa4ac652f0f822e5a73a2.lock# /Users/anacrolix/go/pkg/mod/cache/vcs/405aaa672dfd1ccd25134e9d4b2eb0176febfb30e38fa4ac652f0f822e5a73a2 for git3 https://github.com/anacrolix/confluence
cd /Users/anacrolix/go/pkg/mod/cache/vcs/405aaa672dfd1ccd25134e9d4b2eb0176febfb30e38fa4ac652f0f822e5a73a2; git ls-remote -q origin
mkdir -p /Users/anacrolix/go/pkg/mod/cache/vcs # git3 https://github.com/anacrolix/stm
# lock /Users/anacrolix/go/pkg/mod/cache/vcs/182bf55c53231c0d4ca1eb16ba208c9ca8a806e0f9644854ab5fa0fb96f3f81a.lock# /Users/anacrolix/go/pkg/mod/cache/vcs/182bf55c53231c0d4ca1eb16ba208c9ca8a806e0f9644854ab5fa0fb96f3f81a for git3 https://github.com/anacrolix/stm
cd /Users/anacrolix/go/pkg/mod/cache/vcs/182bf55c53231c0d4ca1eb16ba208c9ca8a806e0f9644854ab5fa0fb96f3f81a; git ls-remote -q origin
0.696s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/95529b14e486dc366ce43cbcfdac3410f2ed3db32991fdb46b220e5bfeeb4d74; git ls-remote -q origin
0.726s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/cd3fa82511c857f13908c96b7b5cb50c7fdb0143794b8f478e842e9f15221b51; git ls-remote -q origin
0.718s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/e54e01c7f186ea7e4bf415d674f0b12aee5ce08b5d4a481bd8ab6489a907939d; git ls-remote -q origin
0.721s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git ls-remote -q origin
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' 5e9378ed14255434af8a3c1f413bf572316c9f8f --
0.009s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' 5e9378ed14255434af8a3c1f413bf572316c9f8f --
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git tag -l
0.008s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git tag -l
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' refs/tags/v0.1.1 --
0.009s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' refs/tags/v0.1.1 --
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git cat-file blob 8463051a5b21bca2fb973a82db7d81d7fd44ccaf:go.mod
0.008s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git cat-file blob 8463051a5b21bca2fb973a82db7d81d7fd44ccaf:go.mod
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git cat-file blob 5e9378ed14255434af8a3c1f413bf572316c9f8f:go.mod
0.008s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git cat-file blob 5e9378ed14255434af8a3c1f413bf572316c9f8f:go.mod
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git for-each-ref --format %(refname) refs/tags --merged 5e9378ed14255434af8a3c1f413bf572316c9f8f
0.689s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/c2fb192dab45ced81ad17d71da488432c85f03d855ad52c5e4e78a1f5e4ceb42; git ls-remote -q origin
0.009s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git for-each-ref --format %(refname) refs/tags --merged 5e9378ed14255434af8a3c1f413bf572316c9f8f
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git fetch -f origin 'refs/heads/*:refs/heads/*' 'refs/tags/*:refs/tags/*'
0.730s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git fetch -f origin 'refs/heads/*:refs/heads/*' 'refs/tags/*:refs/tags/*'
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git for-each-ref --format %(refname) refs/tags --merged 3f72684c4a93b4004087c24768c2bc78d683a89c
0.009s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git for-each-ref --format %(refname) refs/tags --merged 3f72684c4a93b4004087c24768c2bc78d683a89c
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git for-each-ref --format %(refname) refs/tags --merged 3f72684c4a93b4004087c24768c2bc78d683a89c
0.717s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/7d034700d5690944a1f85a595191788fc570f90048382f203b49a944bde3c3d1; git ls-remote -q origin
0.009s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git for-each-ref --format %(refname) refs/tags --merged 3f72684c4a93b4004087c24768c2bc78d683a89c
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' 3f72684c4a93 --
0.009s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' 3f72684c4a93 --
cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git cat-file blob 3f72684c4a93b4004087c24768c2bc78d683a89c:go.mod
0.690s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/405aaa672dfd1ccd25134e9d4b2eb0176febfb30e38fa4ac652f0f822e5a73a2; git ls-remote -q origin
0.008s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/852068a4b9adda57a824b844ad695f2ba6e944bd7e00bcea14d0cc871ae82264; git cat-file blob 3f72684c4a93b4004087c24768c2bc78d683a89c:go.mod
0.694s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/182bf55c53231c0d4ca1eb16ba208c9ca8a806e0f9644854ab5fa0fb96f3f81a; git ls-remote -q origin
0.704s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git fetch -f origin 'refs/heads/*:refs/heads/*' 'refs/tags/*:refs/tags/*'
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git for-each-ref --format %(refname) refs/tags --merged 5e9378ed14255434af8a3c1f413bf572316c9f8f
0.009s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git for-each-ref --format %(refname) refs/tags --merged 5e9378ed14255434af8a3c1f413bf572316c9f8f
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git for-each-ref --format %(refname) refs/tags --merged 5e9378ed14255434af8a3c1f413bf572316c9f8f
0.009s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git for-each-ref --format %(refname) refs/tags --merged 5e9378ed14255434af8a3c1f413bf572316c9f8f
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' 5e9378ed1425 --
0.010s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git -c log.showsignature=false log -n1 '--format=format:%H %ct %D' 5e9378ed1425 --
cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git cat-file blob 5e9378ed14255434af8a3c1f413bf572316c9f8f:go.mod
0.008s # cd /Users/anacrolix/go/pkg/mod/cache/vcs/32afb0c0783ee6b72d41ba7425d207b0c2ce973618d5f179a23185fc6f180976; git cat-file blob 5e9378ed14255434af8a3c1f413bf572316c9f8f:go.mod
go get: can't query version "patch" of module crawshaw.io: no existing version is required
go get: can't query version "patch" of module crawshaw.io/sqlite/c: no existing version is required
go get: can't query version "patch" of module crawshaw.io/sqlite/sqlitex: no existing version is required
go get: can't query version "patch" of module github.com/RoaringBitmap: no existing version is required
go get: can't query version "patch" of module github.com/RoaringBitmap/roaring/internal: no existing version is required
go get: can't query version "patch" of module github.com/benbjohnson: no existing version is required
go get: can't query version "patch" of module github.com/bits-and-blooms: no existing version is required
go get: can't query version "patch" of module github.com/bradfitz: no existing version is required
go get: can't query version "patch" of module github.com/davecgh/go-spew/spew: no existing version is required
go get: can't query version "patch" of module github.com/dustin: no existing version is required
go get: can't query version "patch" of module github.com/edsrzf: no existing version is required
go get: can't query version "patch" of module github.com/elliotchance: no existing version is required
go get: can't query version "patch" of module github.com/google: no existing version is required
go get: can't query version "patch" of module github.com/google: no existing version is required
go get: can't query version "patch" of module github.com/gorilla: no existing version is required
go get: can't query version "patch" of module github.com/huandu: no existing version is required
go get: can't query version "patch" of module github.com/mschoch: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/internal/ciphersuite: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/internal/closer: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/internal/util: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/ccm: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/ciphersuite: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/clientcertificate: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/elliptic: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/fingerprint: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/hash: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/prf: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/signature: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/signaturehash: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/protocol: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/protocol/alert: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/protocol/extension: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/protocol/handshake: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/protocol/recordlayer: no existing version is required
go get: can't query version "patch" of module github.com/pion/ice: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/interceptor/pkg/nack: no existing version is required
go get: can't query version "patch" of module github.com/pion/interceptor/pkg/report: no existing version is required
go get: can't query version "patch" of module github.com/pion/interceptor/pkg/twcc: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/rtp/codecs: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/sdp: no existing version is required
go get: can't query version "patch" of module github.com/pion/srtp: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/stun/internal/hmac: no existing version is required
go get: can't query version "patch" of module github.com/pion/transport/connctx: no existing version is required
go get: can't query version "patch" of module github.com/pion/transport/deadline: no existing version is required
go get: can't query version "patch" of module github.com/pion/transport/packetio: no existing version is required
go get: can't query version "patch" of module github.com/pion/transport/replaydetector: no existing version is required
go get: can't query version "patch" of module github.com/pion/transport/vnet: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn/v2/internal/allocation: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn/v2/internal/client: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn/v2/internal/ipnet: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn/v2/internal/proto: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn/v2/internal/server: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc/v3/internal/fmtp: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc/v3/internal/mux: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc/v3/internal/util: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc/v3/pkg/media: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc/v3/pkg/rtcerr: no existing version is required
go get: can't query version "patch" of module github.com/pkg: no existing version is required
go get: can't query version "patch" of module github.com/rs: no existing version is required
go get: can't query version "patch" of module github.com/ryszard/goskiplist/skiplist: no existing version is required
go get: can't query version "patch" of module github.com/spaolacci: no existing version is required
go get: can't query version "patch" of module github.com/willf: no existing version is required
go get: can't query version "patch" of module github.com/willf: no existing version is required
go get: can't query version "patch" of module go.etcd.io: no existing version is required
go get: can't query version "patch" of module golang.org/x/crypto/cryptobyte: no existing version is required
go get: can't query version "patch" of module golang.org/x/crypto/cryptobyte/asn1: no existing version is required
go get: can't query version "patch" of module golang.org/x/crypto/curve25519: no existing version is required
go get: can't query version "patch" of module golang.org/x/crypto/curve25519/internal/field: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/bpf: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/dns/dnsmessage: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/internal/iana: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/internal/socket: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/internal/socks: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/ipv4: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/proxy: no existing version is required
go get: can't query version "patch" of module golang.org/x/sync/singleflight: no existing version is required
go get: can't query version "patch" of module golang.org/x/sys/internal/unsafeheader: no existing version is required
go get: can't query version "patch" of module golang.org/x/sys/unix: no existing version is required
go get: can't query version "patch" of module golang.org/x/sys/windows: no existing version is required
go get: can't query version "patch" of module golang.org/x/time/rate: no existing version is required
go get: can't query version "patch" of module golang.org/x: no existing version is required
go get: can't query version "patch" of module golang.org/x/xerrors/internal: no existing version is required

@anacrolix
Copy link
Contributor Author

@anacrolix anacrolix commented Oct 22, 2021

I get the same thing on go master.

@seankhliao
Copy link
Member

@seankhliao seankhliao commented Oct 22, 2021

Is something interfering with access to the proxy? Can you try

GOMODCACHE=$(mktemp -d -t gomodcache.XXXX) GOPROXY=direct go get -u=patch -d -v

and

GOMODCACHE=$(mktemp -d -t gomodcache.XXXX) go get -u=patch -d -v

@anacrolix
Copy link
Contributor Author

@anacrolix anacrolix commented Oct 24, 2021

$ GOMODCACHE=$(mktemp -d -t gomodcache.XXXX) GOPROXY=direct go get -u=patch -d -v
get "crawshaw.io/sqlite": found meta tag vcs.metaImport{Prefix:"crawshaw.io/sqlite", VCS:"git", RepoRoot:"https://github.com/crawshaw/sqlite"} at //crawshaw.io/sqlite?go-get=1
get "bazil.org/fuse": found meta tag vcs.metaImport{Prefix:"bazil.org/fuse", VCS:"git", RepoRoot:"https://github.com/bazil/fuse"} at //bazil.org/fuse?go-get=1
get "golang.org/x/sync": found meta tag vcs.metaImport{Prefix:"golang.org/x/sync", VCS:"git", RepoRoot:"https://go.googlesource.com/sync"} at //golang.org/x/sync?go-get=1
get "golang.org/x/net": found meta tag vcs.metaImport{Prefix:"golang.org/x/net", VCS:"git", RepoRoot:"https://go.googlesource.com/net"} at //golang.org/x/net?go-get=1
get "golang.org/x/crypto": found meta tag vcs.metaImport{Prefix:"golang.org/x/crypto", VCS:"git", RepoRoot:"https://go.googlesource.com/crypto"} at //golang.org/x/crypto?go-get=1
get "golang.org/x/sys": found meta tag vcs.metaImport{Prefix:"golang.org/x/sys", VCS:"git", RepoRoot:"https://go.googlesource.com/sys"} at //golang.org/x/sys?go-get=1
get "golang.org/x/time": found meta tag vcs.metaImport{Prefix:"golang.org/x/time", VCS:"git", RepoRoot:"https://go.googlesource.com/time"} at //golang.org/x/time?go-get=1
get "golang.org/x/xerrors": found meta tag vcs.metaImport{Prefix:"golang.org/x/xerrors", VCS:"git", RepoRoot:"https://go.googlesource.com/xerrors"} at //golang.org/x/xerrors?go-get=1
get "go.etcd.io/bbolt": found meta tag vcs.metaImport{Prefix:"go.etcd.io/bbolt", VCS:"git", RepoRoot:"https://github.com/etcd-io/bbolt"} at //go.etcd.io/bbolt?go-get=1
get "gopkg.in/yaml.v3": found meta tag vcs.metaImport{Prefix:"gopkg.in/yaml.v3", VCS:"git", RepoRoot:"https://gopkg.in/yaml.v3"} at //gopkg.in/yaml.v3?go-get=1
get "gopkg.in/check.v1": found meta tag vcs.metaImport{Prefix:"gopkg.in/check.v1", VCS:"git", RepoRoot:"https://gopkg.in/check.v1"} at //gopkg.in/check.v1?go-get=1
get "crawshaw.io/iox": found meta tag vcs.metaImport{Prefix:"crawshaw.io/iox", VCS:"git", RepoRoot:"https://github.com/crawshaw/iox"} at //crawshaw.io/iox?go-get=1
get "go.opencensus.io": found meta tag vcs.metaImport{Prefix:"go.opencensus.io", VCS:"git", RepoRoot:"https://github.com/census-instrumentation/opencensus-go"} at //go.opencensus.io/?go-get=1
get "gopkg.in/errgo.v2": found meta tag vcs.metaImport{Prefix:"gopkg.in/errgo.v2", VCS:"git", RepoRoot:"https://gopkg.in/errgo.v2"} at //gopkg.in/errgo.v2?go-get=1
get "golang.org/x/term": found meta tag vcs.metaImport{Prefix:"golang.org/x/term", VCS:"git", RepoRoot:"https://go.googlesource.com/term"} at //golang.org/x/term?go-get=1
get "gopkg.in/yaml.v2": found meta tag vcs.metaImport{Prefix:"gopkg.in/yaml.v2", VCS:"git", RepoRoot:"https://gopkg.in/yaml.v2"} at //gopkg.in/yaml.v2?go-get=1
get "golang.org/x/text": found meta tag vcs.metaImport{Prefix:"golang.org/x/text", VCS:"git", RepoRoot:"https://go.googlesource.com/text"} at //golang.org/x/text?go-get=1
get "google.golang.org/protobuf": found meta tag vcs.metaImport{Prefix:"google.golang.org/protobuf", VCS:"git", RepoRoot:"https://go.googlesource.com/protobuf"} at //google.golang.org/protobuf?go-get=1
get "google.golang.org/grpc": found meta tag vcs.metaImport{Prefix:"google.golang.org/grpc", VCS:"git", RepoRoot:"https://github.com/grpc/grpc-go"} at //google.golang.org/grpc?go-get=1
get "google.golang.org/genproto": found meta tag vcs.metaImport{Prefix:"google.golang.org/genproto", VCS:"git", RepoRoot:"https://github.com/googleapis/go-genproto"} at //google.golang.org/genproto?go-get=1
get "golang.org/x/tools": found meta tag vcs.metaImport{Prefix:"golang.org/x/tools", VCS:"git", RepoRoot:"https://go.googlesource.com/tools"} at //golang.org/x/tools?go-get=1
get "golang.org/x/lint": found meta tag vcs.metaImport{Prefix:"golang.org/x/lint", VCS:"git", RepoRoot:"https://go.googlesource.com/lint"} at //golang.org/x/lint?go-get=1
get "gopkg.in/alecthomas/kingpin.v2": found meta tag vcs.metaImport{Prefix:"gopkg.in/alecthomas/kingpin.v2", VCS:"git", RepoRoot:"https://gopkg.in/alecthomas/kingpin.v2"} at //gopkg.in/alecthomas/kingpin.v2?go-get=1
get "google.golang.org/api": found meta tag vcs.metaImport{Prefix:"google.golang.org/api", VCS:"git", RepoRoot:"https://github.com/googleapis/google-api-go-client"} at //google.golang.org/api?go-get=1
get "cloud.google.com/go": found meta tag vcs.metaImport{Prefix:"cloud.google.com/go", VCS:"git", RepoRoot:"https://github.com/googleapis/google-cloud-go"} at //cloud.google.com/go?go-get=1
get "golang.org/x/oauth2": found meta tag vcs.metaImport{Prefix:"golang.org/x/oauth2", VCS:"git", RepoRoot:"https://go.googlesource.com/oauth2"} at //golang.org/x/oauth2?go-get=1
get "google.golang.org/appengine": found meta tag vcs.metaImport{Prefix:"google.golang.org/appengine", VCS:"git", RepoRoot:"https://github.com/golang/appengine"} at //google.golang.org/appengine?go-get=1
get "honnef.co/go/tools": found meta tag vcs.metaImport{Prefix:"honnef.co/go/tools", VCS:"git", RepoRoot:"https://github.com/dominikh/go-tools"} at //honnef.co/go/tools?go-get=1
get "gopkg.in/tomb.v1": found meta tag vcs.metaImport{Prefix:"gopkg.in/tomb.v1", VCS:"git", RepoRoot:"https://gopkg.in/tomb.v1"} at //gopkg.in/tomb.v1?go-get=1
get "go.etcd.io/etcd": found meta tag vcs.metaImport{Prefix:"go.etcd.io/etcd", VCS:"git", RepoRoot:"https://github.com/etcd-io/etcd"} at //go.etcd.io/etcd?go-get=1
get "go.uber.org/zap": found meta tag vcs.metaImport{Prefix:"go.uber.org/zap", VCS:"git", RepoRoot:"https://github.com/uber-go/zap"} at //go.uber.org/zap?go-get=1
get "sourcegraph.com/sourcegraph/appdash": found meta tag vcs.metaImport{Prefix:"sourcegraph.com/sourcegraph/appdash", VCS:"git", RepoRoot:"https://github.com/sourcegraph/appdash"} at //sourcegraph.com/sourcegraph/appdash?go-get=1
get "gopkg.in/gcfg.v1": found meta tag vcs.metaImport{Prefix:"gopkg.in/gcfg.v1", VCS:"git", RepoRoot:"https://gopkg.in/gcfg.v1"} at //gopkg.in/gcfg.v1?go-get=1
get "gopkg.in/warnings.v0": found meta tag vcs.metaImport{Prefix:"gopkg.in/warnings.v0", VCS:"git", RepoRoot:"https://gopkg.in/warnings.v0"} at //gopkg.in/warnings.v0?go-get=1
get "golang.org/x/mod": found meta tag vcs.metaImport{Prefix:"golang.org/x/mod", VCS:"git", RepoRoot:"https://go.googlesource.com/mod"} at //golang.org/x/mod?go-get=1
get "golang.org/x/exp": found meta tag vcs.metaImport{Prefix:"golang.org/x/exp", VCS:"git", RepoRoot:"https://go.googlesource.com/exp"} at //golang.org/x/exp?go-get=1
get "gopkg.in/fsnotify.v1": found meta tag vcs.metaImport{Prefix:"gopkg.in/fsnotify.v1", VCS:"git", RepoRoot:"https://gopkg.in/fsnotify.v1"} at //gopkg.in/fsnotify.v1?go-get=1
get "go.uber.org/atomic": found meta tag vcs.metaImport{Prefix:"go.uber.org/atomic", VCS:"git", RepoRoot:"https://github.com/uber-go/atomic"} at //go.uber.org/atomic?go-get=1
get "go.uber.org/multierr": found meta tag vcs.metaImport{Prefix:"go.uber.org/multierr", VCS:"git", RepoRoot:"https://github.com/uber-go/multierr"} at //go.uber.org/multierr?go-get=1
get "gopkg.in/cheggaaa/pb.v1": found meta tag vcs.metaImport{Prefix:"gopkg.in/cheggaaa/pb.v1", VCS:"git", RepoRoot:"https://gopkg.in/cheggaaa/pb.v1"} at //gopkg.in/cheggaaa/pb.v1?go-get=1
get "sigs.k8s.io/yaml": found meta tag vcs.metaImport{Prefix:"sigs.k8s.io/yaml", VCS:"git", RepoRoot:"https://github.com/kubernetes-sigs/yaml"} at //sigs.k8s.io/yaml?go-get=1
get "go.uber.org/tools": found meta tag vcs.metaImport{Prefix:"go.uber.org/tools", VCS:"git", RepoRoot:"https://github.com/uber-go/tools"} at //go.uber.org/tools?go-get=1
get "gopkg.in/resty.v1": found meta tag vcs.metaImport{Prefix:"gopkg.in/resty.v1", VCS:"git", RepoRoot:"https://gopkg.in/resty.v1"} at //gopkg.in/resty.v1?go-get=1
get "golang.org/x/build": found meta tag vcs.metaImport{Prefix:"golang.org/x/build", VCS:"git", RepoRoot:"https://go.googlesource.com/build"} at //golang.org/x/build?go-get=1
get "rsc.io/quote/v3": found meta tag vcs.metaImport{Prefix:"rsc.io/quote", VCS:"git", RepoRoot:"https://github.com/rsc/quote"} at //rsc.io/quote/v3?go-get=1
get "rsc.io/quote/v3": verifying non-authoritative meta tag
get "rsc.io/sampler": found meta tag vcs.metaImport{Prefix:"rsc.io/sampler", VCS:"git", RepoRoot:"https://github.com/rsc/sampler"} at //rsc.io/sampler?go-get=1
get "dmitri.shuralyov.com/html/belt": found meta tag vcs.metaImport{Prefix:"dmitri.shuralyov.com/html/belt", VCS:"mod", RepoRoot:"https://dmitri.shuralyov.com/api/module"} at //dmitri.shuralyov.com/html/belt?go-get=1
get "dmitri.shuralyov.com/app/changes": found meta tag vcs.metaImport{Prefix:"dmitri.shuralyov.com/app/changes", VCS:"mod", RepoRoot:"https://dmitri.shuralyov.com/api/module"} at //dmitri.shuralyov.com/app/changes?go-get=1
get "dmitri.shuralyov.com/service/change": found meta tag vcs.metaImport{Prefix:"dmitri.shuralyov.com/service/change", VCS:"mod", RepoRoot:"https://dmitri.shuralyov.com/api/module"} at //dmitri.shuralyov.com/service/change?go-get=1
get "dmitri.shuralyov.com/state": found meta tag vcs.metaImport{Prefix:"dmitri.shuralyov.com/state", VCS:"mod", RepoRoot:"https://dmitri.shuralyov.com/api/module"} at //dmitri.shuralyov.com/state?go-get=1
get "golang.org/x/perf": found meta tag vcs.metaImport{Prefix:"golang.org/x/perf", VCS:"git", RepoRoot:"https://go.googlesource.com/perf"} at //golang.org/x/perf?go-get=1
get "go4.org": found meta tag vcs.metaImport{Prefix:"go4.org", VCS:"git", RepoRoot:"https://github.com/go4org/go4"} at //go4.org/?go-get=1
get "sourcegraph.com/sourcegraph/go-diff": found meta tag vcs.metaImport{Prefix:"sourcegraph.com/sourcegraph/go-diff", VCS:"git", RepoRoot:"https://github.com/sourcegraph/go-diff"} at //sourcegraph.com/sourcegraph/go-diff?go-get=1
get "grpc.go4.org": found meta tag vcs.metaImport{Prefix:"grpc.go4.org", VCS:"git", RepoRoot:"https://github.com/go4org/grpc"} at //grpc.go4.org/?go-get=1
get "gopkg.in/inf.v0": found meta tag vcs.metaImport{Prefix:"gopkg.in/inf.v0", VCS:"git", RepoRoot:"https://gopkg.in/inf.v0"} at //gopkg.in/inf.v0?go-get=1
get "sourcegraph.com/sqs/pbtypes": found meta tag vcs.metaImport{Prefix:"sourcegraph.com/sqs/pbtypes", VCS:"git", RepoRoot:"https://github.com/sqs/pbtypes"} at //sourcegraph.com/sqs/pbtypes?go-get=1
go: github.com/anacrolix/confluence@v1.8.0 requires
	github.com/anacrolix/torrent@v1.29.0 requires
	github.com/anacrolix/dht/v2@v2.9.1 requires
	github.com/anacrolix/confluence@v1.7.1-0.20210221225853-90405640e928 requires
	github.com/anacrolix/torrent@v1.25.1-0.20210221061757-051093ca31f5 requires
	github.com/anacrolix/dht/v2@v2.8.0 requires
	github.com/anacrolix/torrent@v1.15.0 requires
	github.com/mattn/go-sqlite3@v2.0.2+incompatible: reading github.com/mattn/go-sqlite3/go.mod at revision v2.0.2: unknown revision v2.0.2

@anacrolix
Copy link
Contributor Author

@anacrolix anacrolix commented Oct 24, 2021

$ GOMODCACHE=$(mktemp -d -t gomodcache.XXXX) go get -u=patch -d -v
go: downloading github.com/RoaringBitmap/roaring v0.9.4
go: downloading github.com/anacrolix/chansync v0.3.0-0.0.20211007004133-3f72684c4a93
go: downloading github.com/anacrolix/dht/v2 v2.10.6-0.20211007004332-99263ec9c1c8
go: downloading github.com/anacrolix/go-libutp v1.0.4
go: downloading github.com/anacrolix/log v0.9.0
go: downloading github.com/anacrolix/missinggo v1.3.0
go: downloading github.com/anacrolix/missinggo/perf v1.0.0
go: downloading github.com/anacrolix/missinggo/v2 v2.5.2
go: downloading github.com/anacrolix/multiless v0.1.1-0.20210529082330-de2f6cf29619
go: downloading github.com/anacrolix/sync v0.4.0
go: downloading github.com/anacrolix/upnp v0.1.2-0.20200416075019-5e9378ed1425
go: downloading github.com/anacrolix/utp v0.1.0
go: downloading github.com/davecgh/go-spew v1.1.1
go: downloading github.com/dustin/go-humanize v1.0.0
go: downloading github.com/elliotchance/orderedmap v1.4.0
go: downloading github.com/google/btree v1.0.1
go: downloading github.com/pion/datachannel v1.4.21
go: downloading github.com/pion/webrtc/v3 v3.0.32
go: downloading github.com/pkg/errors v0.9.1
go: downloading golang.org/x/time v0.0.0-20210723032227-1f47c861a9ac
go: downloading github.com/anacrolix/dht v0.0.0-20180412060941-24cbf25b72a4
go: downloading github.com/anacrolix/mmsg v1.0.0
go: downloading github.com/bradfitz/iter v0.0.0-20191230175014-e8f45d346db8
go: downloading github.com/anacrolix/envpprof v1.1.1
go: downloading github.com/edsrzf/mmap-go v1.0.0
go: downloading github.com/gorilla/websocket v1.4.2
go: downloading crawshaw.io/sqlite v0.3.3-0.20210127221821-98b1f83c5508
go: downloading go.etcd.io/bbolt v1.3.6
go: downloading github.com/huandu/xstrings v1.3.2
go: downloading golang.org/x/sys v0.0.0-20210809222454-d867a43fc93e
go: downloading github.com/ryszard/goskiplist v0.0.0-20150312221310-2dfbae5fcf46
go: downloading github.com/pion/logging v0.2.2
go: downloading github.com/pion/sctp v1.7.12
go: downloading github.com/pion/randutil v0.1.0
go: downloading github.com/pion/ice/v2 v2.1.12
go: downloading github.com/pion/dtls/v2 v2.0.9
go: downloading github.com/pion/interceptor v0.0.15
go: downloading github.com/pion/rtcp v1.2.6
go: downloading github.com/pion/rtp v1.7.2
go: downloading github.com/pion/sdp/v3 v3.0.4
go: downloading github.com/pion/srtp/v2 v2.0.5
go: downloading github.com/pion/transport v0.12.3
go: downloading golang.org/x/net v0.0.0-20210813160813-60bc85c4be6d
go: downloading github.com/google/uuid v1.3.0
go: downloading github.com/pion/mdns v0.0.5
go: downloading github.com/pion/stun v0.3.5
go: downloading github.com/pion/turn/v2 v2.0.5
go: downloading github.com/pion/udp v0.1.1
go: downloading golang.org/x/xerrors v0.0.0-20200804184101-5ec99f83aff1
go: downloading golang.org/x/crypto v0.0.0-20210813211128-0a44fdfbc16e
go: downloading github.com/anacrolix/dht/v2 v2.10.6-0.20211022082709-a394caa07562
go: downloading github.com/anacrolix/confluence v1.8.0
go: downloading github.com/willf/bloom v2.0.3+incompatible
go: downloading github.com/rs/dnscache v0.0.0-20210201191234-295bba877686
go: downloading github.com/benbjohnson/immutable v0.3.0
go: downloading github.com/anacrolix/stm v0.3.0
go: downloading golang.org/x/sync v0.0.0-20210220032951-036812b2e83c
go: downloading github.com/willf/bitset v1.1.11
go: downloading github.com/spaolacci/murmur3 v1.1.0
go: downloading github.com/anacrolix/confluence v1.8.1
go: downloading github.com/mschoch/smat v0.2.0
go: downloading github.com/bits-and-blooms/bitset v1.2.0
go get: can't query version "patch" of module crawshaw.io: no existing version is required
go get: can't query version "patch" of module crawshaw.io/sqlite/c: no existing version is required
go get: can't query version "patch" of module crawshaw.io/sqlite/sqlitex: no existing version is required
go get: can't query version "patch" of module github.com/RoaringBitmap: no existing version is required
go get: can't query version "patch" of module github.com/RoaringBitmap/roaring/internal: no existing version is required
go get: can't query version "patch" of module github.com/benbjohnson: no existing version is required
go get: can't query version "patch" of module github.com/bits-and-blooms: no existing version is required
go get: can't query version "patch" of module github.com/bradfitz: no existing version is required
go get: can't query version "patch" of module github.com/davecgh/go-spew/spew: no existing version is required
go get: can't query version "patch" of module github.com/dustin: no existing version is required
go get: can't query version "patch" of module github.com/edsrzf: no existing version is required
go get: can't query version "patch" of module github.com/elliotchance: no existing version is required
go get: can't query version "patch" of module github.com/google: no existing version is required
go get: can't query version "patch" of module github.com/google: no existing version is required
go get: can't query version "patch" of module github.com/gorilla: no existing version is required
go get: can't query version "patch" of module github.com/huandu: no existing version is required
go get: can't query version "patch" of module github.com/mschoch: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/internal/ciphersuite: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/internal/closer: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/internal/util: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/ccm: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/ciphersuite: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/clientcertificate: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/elliptic: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/fingerprint: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/hash: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/prf: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/signature: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/crypto/signaturehash: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/protocol: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/protocol/alert: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/protocol/extension: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/protocol/handshake: no existing version is required
go get: can't query version "patch" of module github.com/pion/dtls/v2/pkg/protocol/recordlayer: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/interceptor/pkg/nack: no existing version is required
go get: can't query version "patch" of module github.com/pion/interceptor/pkg/report: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/rtp/codecs: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/sdp: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/stun/internal/hmac: no existing version is required
go get: can't query version "patch" of module github.com/pion/transport/connctx: no existing version is required
go get: can't query version "patch" of module github.com/pion/transport/deadline: no existing version is required
go get: can't query version "patch" of module github.com/pion/transport/packetio: no existing version is required
go get: can't query version "patch" of module github.com/pion/transport/replaydetector: no existing version is required
go get: can't query version "patch" of module github.com/pion/transport/vnet: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn/v2/internal/allocation: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn/v2/internal/client: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn/v2/internal/ipnet: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn/v2/internal/proto: no existing version is required
go get: can't query version "patch" of module github.com/pion/turn/v2/internal/server: no existing version is required
go get: can't query version "patch" of module github.com/pion: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc/v3/internal/mux: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc/v3/internal/util: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc/v3/pkg/media: no existing version is required
go get: can't query version "patch" of module github.com/pion/webrtc/v3/pkg/rtcerr: no existing version is required
go get: can't query version "patch" of module github.com/pkg: no existing version is required
go get: can't query version "patch" of module github.com/rs: no existing version is required
go get: can't query version "patch" of module github.com/ryszard/goskiplist/skiplist: no existing version is required
go get: can't query version "patch" of module github.com/spaolacci: no existing version is required
go get: can't query version "patch" of module github.com/willf: no existing version is required
go get: can't query version "patch" of module github.com/willf: no existing version is required
go get: can't query version "patch" of module go.etcd.io: no existing version is required
go get: can't query version "patch" of module golang.org/x/crypto/cryptobyte: no existing version is required
go get: can't query version "patch" of module golang.org/x/crypto/cryptobyte/asn1: no existing version is required
go get: can't query version "patch" of module golang.org/x/crypto/curve25519: no existing version is required
go get: can't query version "patch" of module golang.org/x/crypto/curve25519/internal/field: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/bpf: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/dns/dnsmessage: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/internal/iana: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/internal/socket: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/internal/socks: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/ipv4: no existing version is required
go get: can't query version "patch" of module golang.org/x/net/proxy: no existing version is required
go get: can't query version "patch" of module golang.org/x/sync/singleflight: no existing version is required
go get: can't query version "patch" of module golang.org/x/sys/internal/unsafeheader: no existing version is required
go get: can't query version "patch" of module golang.org/x/sys/unix: no existing version is required
go get: can't query version "patch" of module golang.org/x/sys/windows: no existing version is required
go get: can't query version "patch" of module golang.org/x/time/rate: no existing version is required
go get: can't query version "patch" of module golang.org/x: no existing version is required
go get: can't query version "patch" of module golang.org/x/xerrors/internal: no existing version is required

@seankhliao
Copy link
Member

@seankhliao seankhliao commented Oct 24, 2021

do you have HTTP_PROXY or something else that changes the response of proxies?

@seankhliao seankhliao added the WaitingForInfo label Oct 24, 2021
@anacrolix
Copy link
Contributor Author

@anacrolix anacrolix commented Oct 24, 2021

No. My hunch is this has to do with some bad versioning/tagging, possibly in mattn/go-sqlite. Can you reproduce it with anacrolix/torrent on your machine?

@seankhliao
Copy link
Member

@seankhliao seankhliao commented Oct 25, 2021

I can't reproduce the errors you see when you're using a proxy.

I see 2 different problems here

  • with GOPROXY=direct, github.com/mattn/go-sqlite3 does appear to have removed the v2 tags (ref mattn/go-sqlite3#975)
  • with the proxy, given a module (ex crawshaw.io/sqlite), it seems to be correctly locating that but not correctly treating the other queries as non modules
    go: downloading crawshaw.io/sqlite v0.3.3-0.20210127221821-98b1f83c5508
    ...
    go get: can't query version "patch" of module crawshaw.io: no existing version is required
    go get: can't query version "patch" of module crawshaw.io/sqlite/c: no existing version is required
    go get: can't query version "patch" of module crawshaw.io/sqlite/sqlitex: no existing version is required
    

@anacrolix
Copy link
Contributor Author

@anacrolix anacrolix commented Nov 19, 2021

With just GOPROXY=direct, I'm able to patch update github.com/anacrolix/dht.

@seankhliao seankhliao added WaitingForInfo and removed WaitingForInfo labels Jun 12, 2022
@gopherbot
Copy link

@gopherbot gopherbot commented Jul 12, 2022

Timed out in state WaitingForInfo. Closing.

(I am just a bot, though. Please speak up if this is a mistake or you have the requested information.)

@anacrolix
Copy link
Contributor Author

@anacrolix anacrolix commented Jul 12, 2022

Closing this is a mistake @gopherbot, @seankhliao, thanks.

@anacrolix
Copy link
Contributor Author

@anacrolix anacrolix commented Jul 12, 2022

This problem persists with go1.19rc1.

@anacrolix
Copy link
Contributor Author

@anacrolix anacrolix commented Jul 12, 2022

Reproduce by checking out github.com/anacrolix/torrent or github.com/anacrolix/dht. Run with the default GOPROXY (https://proxy.golang.org,direct): go get -u=patch. Errors per above. Run with GOPROXY=direct, no issues. Could this be an issue with the Google proxy?

@ianlancetaylor ianlancetaylor changed the title go get: can't query version "patch" of module X: no existing version is required cmd/go: get: can't query version "patch" of module X: no existing version is required Jul 13, 2022
@ianlancetaylor ianlancetaylor added NeedsInvestigation GoCommand and removed WaitingForInfo labels Jul 13, 2022
@ianlancetaylor ianlancetaylor added this to the Backlog milestone Jul 13, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
GoCommand NeedsInvestigation
Projects
None yet
Development

No branches or pull requests

4 participants