A gulp plugin for atom-shell distribute applications
Switch branches/tags
Nothing to show
Clone or download
Pull request Compare This branch is 4 commits ahead, 45 commits behind mainyaa:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
example
lib
src
test
.coveralls.yml
.editorconfig
.gitignore
.npmignore
.travis.yml
LICENSE
README.md
appveyor.yml
coffeelint.json
gulpfile.js
index.js
package.json

README.md

gulp-electron for gulp NPM version

Build Status AppVayor status Dependency Status Coverage Status Code Climate

A gulp plugin that creates electron based distributable applications.

Install

Install with npm.

npm install --save-dev gulp-electron

Usage

Add a gulp electron task like :

var gulp = require('gulp');
var electron = require('gulp-electron');
var packageJson = require('./src/package.json');

gulp.task('electron', function() {

    gulp.src("")
    .pipe(electron({
        src: './src',
        packageJson: packageJson,
        release: './release',
        cache: './cache',
        version: 'v0.26.1',
        packaging: true,
        platforms: ['win32-ia32', 'darwin-x64']
    }))
    .pipe(gulp.dest(""));
});

Executing gulp electron will create an electron package for the specified platforms.

When you run code under process.NODE_ENV = test more debug information will be displayed.

Dependency

If you using windows: install 7z(http://www.7-zip.org/).

options

  • src The root directory of the sources that shall be packaged, required.
  • packageJson The package.json, required.
  • cache The download path for the electron package, required.
  • release is where the release applictions path, required.
  • version the version of the electron release to be download from the GitHub page, required.
  • platforms Support ['darwin','win32','linux','darwin-x64','linux-ia32','linux-x64','win32-ia32','win64-64'], default is darwin-x64. If verion is under v0.13.0 must use ['darwin','win32','linux'].
  • apm Path to the atom-package-manager executable. If not specified the default behavior will be to use the globally installed apm executable.
  • rebuild Default is false, when set to true then rebuild native-modules.
  • asar Default is false, when set to true then asar pack your app directory. see more docs(https://github.com/atom/electron/blob/master/docs/tutorial/application-packaging.md).
  • symbols Default is false, when set to true the symbols package from GitHub will be downloaded.
  • packaging Default is false, when set to true the packaging zip file.

License

MIT