"Automatic language switching" doesn't get disabled correctly #3124

Closed
nvaccessAuto opened this Issue Apr 2, 2013 · 4 comments

1 participant

@nvaccessAuto

Reported by parham on 2013-04-02 07:50
When disabling the option to automatically switch to the language when reading web documents, the voice needs to be changed once for the change to take effect.

Steps to reproduce:

  1. With automatic language switching enabled and the default voice set to Farsi, go to ​http://www.payaneh.ir/fa/. It is a Farsi document, incorrectly marked as English. You will hear NVDA trying to read the document in the English voice.
  2. Now, disable the automatic language switching functionality and click okay in the V"oice settings" dialog box. When you get back to the webpage, the webpage is still being read using the English voice.
  3. Bring up the "Voice settings" dialog box, press down and then up, then click okay. Observe that this time, the document is being read correctly.

Expected result:

After step 2, the document should be read correctly, without the need to do step three.

@nvaccessAuto

Comment 1 by jteh on 2013-04-03 04:41
Thanks for reporting. This is due to a bug in eSpeak and applies to all languages. It's not new, either; I'm surprised no one has reported it before now. I'll file a bug against eSpeak soon.
Changes:
Milestone changed from None to 2013.2

@nvaccessAuto

Comment 2 by jteh on 2013-04-03 07:15
Filed eSpeak bug ##3609867.

@nvaccessAuto

Comment 3 by jonsd on 2013-04-08 19:52
Fixed in eSpeak 1.47.05.

@nvaccessAuto

Comment 4 by jteh on 2013-04-09 05:36
Updated to eSpeak 1.47.05 in 52a4549.
Changes:
Milestone changed from 2013.2 to 2013.1
State: closed

@nvaccessAuto nvaccessAuto added this to the 2013.1 milestone Nov 10, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment