Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Use python_requires in to avoid installing in unsupported versions #2922

nicoddemus opened this issue Nov 13, 2017 · 0 comments


Copy link

@nicoddemus nicoddemus commented Nov 13, 2017

We should use the python_requires keyword argument to so pip won't install pytest in unsupported versions.

For example, here's hypothesis

    python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',

This is probably worth doing only for the next release (3.3).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.