Skip to content

Please add HELambdaP #619

Closed
marcoxa opened this Issue Jan 6, 2014 · 17 comments

2 participants

@marcoxa
marcoxa commented Jan 6, 2014

Hello,

please add HELambdaP to quicklisp.

The web site is http://helambdap.sourceforge.net

The license is BSD.

The git repository can be accessed (read only) at

git://git.code.sf.net/p/helambdap/code
http://git.code.sf.net/p/helambdap/code

All the best

Marco

@quicklisp
Owner
@quicklisp
Owner

I can't build it. The error on SBCL with ASDF 3 is this:

Component "helambdap" not found

I suspect it's because the system definition uses an uppercase string for the name, but I'm not sure.

@marcoxa
marcoxa commented Jan 6, 2014

I am pretty sure that's the case. I just found out that I cannot quick load xhtmlambda because of something like that (*). Note that you added xhtmlambda to quick lisp some time ago. So the problem is with ASDF3 being rather fascist with names.

I will downcase all the system names to play ball...

Marco

(*) Here is the transcript for the xhtmlambda problem:

CL-USER 17 > ql-dist:system-apropos "XHTM"
#

CL-USER 18 > ql:quickload "XHTMLambda"

Error: System "xhtmlambda" not found
1 (abort) Give up on "xhtmlambda"
2 Return to level 0.
3 Return to top loop level 0.

Type :b for backtrace or :c to proceed.
Type :bug-form "" for a bug report template or :? for other options.

CL-USER 19 : 1 > :top

CL-USER 20 > ql:quickload "xhtmlambda"

Error: System "xhtmlambda" not found
1 (abort) Give up on "xhtmlambda"
2 Return to level 0.
3 Return to top loop level 0.

Type :b for backtrace or :c to proceed.
Type :bug-form "" for a bug report template or :? for other options.

CL-USER 21 : 1 > :top

CL-USER 22 > ql:quickload "XHTMLAMBDA"

Error: System "xhtmlambda" not found
1 (abort) Give up on "xhtmlambda"
2 Return to level 0.
3 Return to top loop level 0.

Type :b for backtrace or :c to proceed.
Type :bug-form "" for a bug report template or :? for other options.

CL-USER 23 : 1 >

@marcoxa
marcoxa commented Jan 6, 2014

Damn HTML formatting under the hood!

The transcript before works. It's just missing the unreadable object print by QL-DIST:SYSTEM-APROPOS

MA

@marcoxa
marcoxa commented Jan 6, 2014

Ok. I have pushed the downcased system names in the the repositories.

Can you double check if it is working?

Thanks

MA

@quicklisp
Owner
@marcoxa
marcoxa commented Jan 7, 2014

Ok. I changed that too. But this is really getting annoying. Mixed case should really not be a problem at all.

Can you check whether things now work?

MA

@quicklisp
Owner

Now it fails because you specified SPLIT-SEQUENCE in uppercase.

@marcoxa
@quicklisp
Owner
@marcoxa
@marcoxa
@quicklisp
Owner
@marcoxa
@marcoxa
marcoxa commented Jan 13, 2014

Hi Zach... any update on this? It is still tagged "cantbuild".

MA

@quicklisp
Owner

It builds fine now, and will be in the next dist update.

@marcoxa
@quicklisp quicklisp closed this Jan 16, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.