New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[WebProfilerBundle] Fix a web profiler form issue with fields added to the form after the form was built #20860

Merged
merged 1 commit into from Dec 12, 2016

Conversation

Projects
None yet
3 participants
@tgalopin
Contributor

tgalopin commented Dec 10, 2016

Q A
Branch? 3.2
Bug fix? yes
New feature? no
BC breaks? no
Deprecations? no
Tests pass? yes
Fixed tickets #20823
License MIT
Doc PR -

I discovered a bug in 3.2 in the web profiler and this PR fixes it. This issue has been fixed in the past by #13166 and probably reintroduced by the refactoring we did in the WebProfiler in 3.2. I simply applied the fix to these changes.

To reproduce the original problem, simply clone the current standard edition, create a Form with a Type and add a field after its creation. Once done, try to access the Webprofiler: it will fails with the following error:

Key "type_class" for array with keys "id, name, view_vars, children" does not exist in @WebProfiler/Collector/form.html.twig at line 460.

@nicolas-grekas

This comment has been minimized.

Member

nicolas-grekas commented Dec 12, 2016

Thank you @tgalopin.

@nicolas-grekas nicolas-grekas merged commit d9af8e9 into symfony:3.2 Dec 12, 2016

3 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
fabbot.io Your code looks good.
Details

nicolas-grekas added a commit that referenced this pull request Dec 12, 2016

bug #20860 [WebProfilerBundle] Fix a web profiler form issue with fie…
…lds added to the form after the form was built (tgalopin)

This PR was merged into the 3.2 branch.

Discussion
----------

[WebProfilerBundle] Fix a web profiler form issue with fields added to the form after the form was built

| Q             | A
| ------------- | ---
| Branch?       | 3.2
| Bug fix?      | yes
| New feature?  | no
| BC breaks?    | no
| Deprecations? | no
| Tests pass?   | yes
| Fixed tickets | #20823
| License       | MIT
| Doc PR        | -

I discovered a bug in 3.2 in the web profiler and this PR fixes it. This issue has been fixed in the past by #13166 and probably reintroduced by the refactoring we did in the WebProfiler in 3.2. I simply applied the fix to these changes.

To reproduce the original problem, simply clone the current standard edition, create a Form with a Type and add a field after its creation. Once done, try to access the Webprofiler: it will fails with the following error:

> Key "type_class" for array with keys "id, name, view_vars, children" does not exist in @WebProfiler/Collector/form.html.twig at line 460.

Commits
-------

d9af8e9 Fix a web profiler form issue with fields added to the form after the form was built

@tgalopin tgalopin deleted the tgalopin:fix-web-profiler branch Dec 12, 2016

@fabpot fabpot referenced this pull request Dec 13, 2016

Merged

Release v3.2.1 #20897

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment