New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Request] GPL Changes #3075

Closed
dcrdev opened this Issue Dec 15, 2017 · 265 comments

Comments

Projects
None yet
@dcrdev

dcrdev commented Dec 15, 2017

Please make available the spec file for the Linux dotnet core rpms - they contain binaries whose source code is not available in this repository. Some of these binaries are GPL licensed - there's no traceability on them, there's no way of knowing whether they have been modified from their upstream source tree.

The rpm is package intended to distribute Emby an GPL licensed application, ergo it in it's self is considered a derived piece of work under the terms of the GPL.

Under the terms of the GPL, you are required to publish or provide (on request) copies of the source code for any binaries derived from GPL licensed applications/libraries.

You are currently in breach of the GPL - can you please rectify this!

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Dec 19, 2017

Reserved

dcrdev commented Dec 19, 2017

Reserved

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Dec 20, 2017

Here's an audit on the lib directory you're bundling with Emby, filtered down to the GPL licensed libraries - whose copyright you are in breach of:

Name                     | License                   | Emby Path                                       | Upstream URL   
+-------------------------------------------------------------------------------------------------------------------------------+
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
elfutils-libelf-devel    | GPLv2+ or LGPLv3+         | /opt/emby-server/lib/libelf.so                  | http://elfutils.org/                 
elfutils-libelf-devel    | GPLv2+ or LGPLv3+         | /opt/emby-server/lib/libelf.so                  | http://elfutils.org/                 
elfutils-libelf          | GPLv2+ or LGPLv3+         | /opt/emby-server/lib/libelf.so.1                | http://elfutils.org/                 
elfutils-libelf          | GPLv2+ or LGPLv3+         | /opt/emby-server/lib/libelf.so.1                | http://elfutils.org/                 
gmp-devel                | LGPLv3+ or GPLv2+         | /opt/emby-server/lib/libgmp.so                  | http://gmplib.org/                 
gmp-devel                | LGPLv3+ or GPLv2+         | /opt/emby-server/lib/libgmp.so                  | http://gmplib.org/                 
gmp                      | LGPLv3+ or GPLv2+         | /opt/emby-server/lib/libgmp.so.10               | http://gmplib.org/                 
gmp                      | LGPLv3+ or GPLv2+         | /opt/emby-server/lib/libgmp.so.10               | http://gmplib.org/                 
gnutls-devel             | GPLv3+ and LGPLv2+        | /opt/emby-server/lib/libgnutls.so               | http://www.gnutls.org/                 
gnutls-devel             | GPLv3+ and LGPLv2+        | /opt/emby-server/lib/libgnutls.so               | http://www.gnutls.org/                 
nettle-devel             | LGPLv2+                   | /opt/emby-server/lib/libhogweed.so              | http://www.lysator.liu.se/~nisse/nettle/                 
nettle-devel             | LGPLv2+                   | /opt/emby-server/lib/libhogweed.so              | http://www.lysator.liu.se/~nisse/nettle/                 
lame-devel               | GPLv2+                    | /opt/emby-server/lib/libmp3lame.so              | http://lame.sourceforge.net/                 
lame-libs                | GPLv2+                    | /opt/emby-server/lib/libmp3lame.so.0            | http://lame.sourceforge.net/                 
lame-libs                | GPLv2+                    | /opt/emby-server/lib/libmp3lame.so.0.0.0        | http://lame.sourceforge.net/                  
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
nettle-devel             | LGPLv2+                   | /opt/emby-server/lib/libnettle.so               | http://www.lysator.liu.se/~nisse/nettle/                 
nettle-devel             | LGPLv2+                   | /opt/emby-server/lib/libnettle.so               | http://www.lysator.liu.se/~nisse/nettle/                 
qmmp                     | GPLv2+                    | /opt/emby-server/lib/libopus.so                 | http://qmmp.ylsoftware.com/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-bp.so              | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-cds.so             | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-common.so          | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-mb.so              | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-qsbr.so            | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-signal.so          | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu.so                 | http://lttng.org/urcu/                 
xmms-libs                | GPLv2+                    | /opt/emby-server/lib/libvorbis.so               | http://legacy.xmms2.org/                 
qmmp                     | GPLv2+                    | /opt/emby-server/lib/libvorbis.so               | http://qmmp.ylsoftware.com/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
sssd-libwbclient         | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | https://pagure.io/SSSD/sssd/                 
sssd-libwbclient         | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | https://pagure.io/SSSD/sssd/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
sssd-libwbclient         | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | https://pagure.io/SSSD/sssd/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
sssd-libwbclient         | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | https://pagure.io/SSSD/sssd/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
darktable                | GPLv3+                    | /opt/emby-server/lib/libwebp.so                 | http://www.darktable.org/                 
samba-common             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/samba                      | http://www.samba.org/								                                          

dcrdev commented Dec 20, 2017

Here's an audit on the lib directory you're bundling with Emby, filtered down to the GPL licensed libraries - whose copyright you are in breach of:

Name                     | License                   | Emby Path                                       | Upstream URL   
+-------------------------------------------------------------------------------------------------------------------------------+
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libdcerpc-binding.so.0.0.1 | http://www.samba.org/                         
elfutils-libelf-devel    | GPLv2+ or LGPLv3+         | /opt/emby-server/lib/libelf.so                  | http://elfutils.org/                 
elfutils-libelf-devel    | GPLv2+ or LGPLv3+         | /opt/emby-server/lib/libelf.so                  | http://elfutils.org/                 
elfutils-libelf          | GPLv2+ or LGPLv3+         | /opt/emby-server/lib/libelf.so.1                | http://elfutils.org/                 
elfutils-libelf          | GPLv2+ or LGPLv3+         | /opt/emby-server/lib/libelf.so.1                | http://elfutils.org/                 
gmp-devel                | LGPLv3+ or GPLv2+         | /opt/emby-server/lib/libgmp.so                  | http://gmplib.org/                 
gmp-devel                | LGPLv3+ or GPLv2+         | /opt/emby-server/lib/libgmp.so                  | http://gmplib.org/                 
gmp                      | LGPLv3+ or GPLv2+         | /opt/emby-server/lib/libgmp.so.10               | http://gmplib.org/                 
gmp                      | LGPLv3+ or GPLv2+         | /opt/emby-server/lib/libgmp.so.10               | http://gmplib.org/                 
gnutls-devel             | GPLv3+ and LGPLv2+        | /opt/emby-server/lib/libgnutls.so               | http://www.gnutls.org/                 
gnutls-devel             | GPLv3+ and LGPLv2+        | /opt/emby-server/lib/libgnutls.so               | http://www.gnutls.org/                 
nettle-devel             | LGPLv2+                   | /opt/emby-server/lib/libhogweed.so              | http://www.lysator.liu.se/~nisse/nettle/                 
nettle-devel             | LGPLv2+                   | /opt/emby-server/lib/libhogweed.so              | http://www.lysator.liu.se/~nisse/nettle/                 
lame-devel               | GPLv2+                    | /opt/emby-server/lib/libmp3lame.so              | http://lame.sourceforge.net/                 
lame-libs                | GPLv2+                    | /opt/emby-server/lib/libmp3lame.so.0            | http://lame.sourceforge.net/                 
lame-libs                | GPLv2+                    | /opt/emby-server/lib/libmp3lame.so.0.0.0        | http://lame.sourceforge.net/                  
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-krb5pac.so.0.0.1    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-nbt.so.0.0.1        | http://www.samba.org/                  
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so                  | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr.so.0                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libndr-standard.so.0.0.1   | http://www.samba.org/                       
nettle-devel             | LGPLv2+                   | /opt/emby-server/lib/libnettle.so               | http://www.lysator.liu.se/~nisse/nettle/                 
nettle-devel             | LGPLv2+                   | /opt/emby-server/lib/libnettle.so               | http://www.lysator.liu.se/~nisse/nettle/                 
qmmp                     | GPLv2+                    | /opt/emby-server/lib/libopus.so                 | http://qmmp.ylsoftware.com/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0  | http://www.samba.org/                        
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-credentials.so.0.0| http://www.samba.org/.1                          
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-errors.so.1       | http://www.samba.org/                   
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0   | http://www.samba.org/                       
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-hostconfig.so.0.0.| http://www.samba.org/1                          
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so           | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0         | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamba-util.so.0.0.1     | http://www.samba.org/                     
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so                | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsamdb.so.0.0.1          | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient-devel       | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so            | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0          | http://www.samba.org/                 
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
libsmbclient             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbclient.so.0.2.3      | http://www.samba.org/                    
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so              | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libsmbconf.so.0            | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-devel              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so          | http://www.samba.org/                 
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0        | http://www.samba.org/                  
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
samba-client-libs        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libtevent-util.so.0.0.1    | http://www.samba.org/                      
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-bp.so              | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-cds.so             | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-common.so          | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-mb.so              | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-qsbr.so            | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu-signal.so          | http://lttng.org/urcu/                 
userspace-rcu-devel      | LGPLv2+                   | /opt/emby-server/lib/liburcu.so                 | http://lttng.org/urcu/                 
xmms-libs                | GPLv2+                    | /opt/emby-server/lib/libvorbis.so               | http://legacy.xmms2.org/                 
qmmp                     | GPLv2+                    | /opt/emby-server/lib/libvorbis.so               | http://qmmp.ylsoftware.com/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
libwbclient-devel        | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | http://www.samba.org/                 
sssd-libwbclient-devel   | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so             | https://pagure.io/SSSD/sssd/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
sssd-libwbclient         | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | https://pagure.io/SSSD/sssd/                 
sssd-libwbclient         | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | https://pagure.io/SSSD/sssd/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
sssd-libwbclient         | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | https://pagure.io/SSSD/sssd/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
sssd-libwbclient         | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | https://pagure.io/SSSD/sssd/                 
libwbclient              | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/libwbclient.so.0           | http://www.samba.org/                 
darktable                | GPLv3+                    | /opt/emby-server/lib/libwebp.so                 | http://www.darktable.org/                 
samba-common             | GPLv3+ and LGPLv3+        | /opt/emby-server/lib/samba                      | http://www.samba.org/								                                          
@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Dec 20, 2017

Here's the script I wrote - should you wish to verify this yourself; bare in mind the above output has been stripped of records where the library is licensed under multiple types.

#!/bin/bash
embyLibs="/opt/emby-server/lib/"
printf "%-40s | %-50s | %-30s | %-40s\n" "Name" "Upstream URL" "License" "Emby Path"
echo "+-------------------------------------------------------------------------------------------------------------------------------------------------------+"

qryBase () {

    for file in $embyLibs*; do
      lib=$(basename "$file")
      repoquery --whatprovides "*/$lib" --qf "%-40{name} | %-50{url} | %-30{license} | $file"
    done;

}

qryBase | grep GPL

dcrdev commented Dec 20, 2017

Here's the script I wrote - should you wish to verify this yourself; bare in mind the above output has been stripped of records where the library is licensed under multiple types.

#!/bin/bash
embyLibs="/opt/emby-server/lib/"
printf "%-40s | %-50s | %-30s | %-40s\n" "Name" "Upstream URL" "License" "Emby Path"
echo "+-------------------------------------------------------------------------------------------------------------------------------------------------------+"

qryBase () {

    for file in $embyLibs*; do
      lib=$(basename "$file")
      repoquery --whatprovides "*/$lib" --qf "%-40{name} | %-50{url} | %-30{license} | $file"
    done;

}

qryBase | grep GPL
@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

nvllsvm Dec 21, 2017

@dcrdev - They're ignoring this. "We will have a response for you" doesn't cut it - they're violating the license.

Any thoughts on where to report this to?

nvllsvm commented Dec 21, 2017

@dcrdev - They're ignoring this. "We will have a response for you" doesn't cut it - they're violating the license.

Any thoughts on where to report this to?

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Dec 21, 2017

Well I'll give them until the middle of next week to resolve, albeit I don't see why they need time to resolve this they should be able to provide the source code immediately.

But we can't take any action directly only the original copyright holder can do so, we would need to contact them and presumably they would take it from there. That's why my script above generates the upstream url.

For the libraries where the Free Software Foundation is the direct copyright holder, we can report the violation by emailing license-violation@gnu.org.

That's according to https://www.gnu.org/licenses/gpl-violation.en.html

dcrdev commented Dec 21, 2017

Well I'll give them until the middle of next week to resolve, albeit I don't see why they need time to resolve this they should be able to provide the source code immediately.

But we can't take any action directly only the original copyright holder can do so, we would need to contact them and presumably they would take it from there. That's why my script above generates the upstream url.

For the libraries where the Free Software Foundation is the direct copyright holder, we can report the violation by emailing license-violation@gnu.org.

That's according to https://www.gnu.org/licenses/gpl-violation.en.html

@RaymondSchnyder

This comment has been minimized.

Show comment
Hide comment
@RaymondSchnyder

RaymondSchnyder Jan 2, 2018

@dcrdev More than a week has passed. Any Update on this?

RaymondSchnyder commented Jan 2, 2018

@dcrdev More than a week has passed. Any Update on this?

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jan 2, 2018

Been a bit busy over the Christmas period, so not done as much as I'd have liked to. I have emailed some of the people on the gnutls mailing list independently/directly, I'd like to at least first get this resolved without drawing too much public attention; I will ofcourse report back here with any new information.

Over the coming days I'm going repeat these steps for all of the projects listed above. If I were a betting man, I'd say that the likely outcome will be that the contributors of those projects issue a DMCA take-down request to GitHub; whether Emby will pay attention to this, or start self hosting - is anyone's guess.

dcrdev commented Jan 2, 2018

Been a bit busy over the Christmas period, so not done as much as I'd have liked to. I have emailed some of the people on the gnutls mailing list independently/directly, I'd like to at least first get this resolved without drawing too much public attention; I will ofcourse report back here with any new information.

Over the coming days I'm going repeat these steps for all of the projects listed above. If I were a betting man, I'd say that the likely outcome will be that the contributors of those projects issue a DMCA take-down request to GitHub; whether Emby will pay attention to this, or start self hosting - is anyone's guess.

@HaoZeke

This comment has been minimized.

Show comment
Hide comment
@HaoZeke

HaoZeke Jan 4, 2018

Would self hosting alter their liability for not adhering to the license clauses?

HaoZeke commented Jan 4, 2018

Would self hosting alter their liability for not adhering to the license clauses?

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jan 4, 2018

No nothing gets them out of their liability for violating the GPL. It's just in all likelihood that the copyright holders of these 3rd party projects wouldn't take legal action. I was just saying that the most likely outcome would be that they submit a DMCA takedown request to Github, who would then be forced to disable the repository.

If Emby were to start self hosting their binary packages, then there's no one to submit that DMCA notice to - the only remaining course of action would be to take legal action.

That being said, I'm hopeful that today/tomorrow brings a resolution to this:
https://emby.media/community/index.php?/topic/49862-source-code-license/page-2#entry526756

dcrdev commented Jan 4, 2018

No nothing gets them out of their liability for violating the GPL. It's just in all likelihood that the copyright holders of these 3rd party projects wouldn't take legal action. I was just saying that the most likely outcome would be that they submit a DMCA takedown request to Github, who would then be forced to disable the repository.

If Emby were to start self hosting their binary packages, then there's no one to submit that DMCA notice to - the only remaining course of action would be to take legal action.

That being said, I'm hopeful that today/tomorrow brings a resolution to this:
https://emby.media/community/index.php?/topic/49862-source-code-license/page-2#entry526756

@spacekookie

This comment has been minimized.

Show comment
Hide comment
@spacekookie

spacekookie Jan 7, 2018

There hasn't been a word from the project creators... http://gpl-violations.org/

spacekookie commented Jan 7, 2018

There hasn't been a word from the project creators... http://gpl-violations.org/

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jan 10, 2018

I'm going to resume contacting people -

Sorry Emby devs it doesn't take nearly a month to release source code that you already have - it's gone from soon to "end of the week" to now "we're working on it" ; doesn't cut it.

dcrdev commented Jan 10, 2018

I'm going to resume contacting people -

Sorry Emby devs it doesn't take nearly a month to release source code that you already have - it's gone from soon to "end of the week" to now "we're working on it" ; doesn't cut it.

@RaymondSchnyder

This comment has been minimized.

Show comment
Hide comment
@RaymondSchnyder

RaymondSchnyder Jan 10, 2018

@LukePulverenti Slightly reminder on this issue.

RaymondSchnyder commented Jan 10, 2018

@LukePulverenti Slightly reminder on this issue.

@jusovsky

This comment has been minimized.

Show comment
Hide comment
@jusovsky

jusovsky Jan 11, 2018

Is it common for self-appointed GPL Gestapo to blow into town and expect developers to cancel Christmas, drop everything, and make this top priority?

jusovsky commented Jan 11, 2018

Is it common for self-appointed GPL Gestapo to blow into town and expect developers to cancel Christmas, drop everything, and make this top priority?

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jan 11, 2018

It's actually not common at all, primarily because people don't tend to use other people's code that they have licensed specifically to prevent people using it without attribution and then take the stance of "whatever".

If you are not OK with this, then maybe you shouldn't have utilised GPL licensed code in your project and also should not have licensed your own product under the GPL; perhaps a BSD license would have been more fitting.

Drop everything? Hardly - how much effort does it really take to provide the source code for something; 5 maybe 10 minutes?

dcrdev commented Jan 11, 2018

It's actually not common at all, primarily because people don't tend to use other people's code that they have licensed specifically to prevent people using it without attribution and then take the stance of "whatever".

If you are not OK with this, then maybe you shouldn't have utilised GPL licensed code in your project and also should not have licensed your own product under the GPL; perhaps a BSD license would have been more fitting.

Drop everything? Hardly - how much effort does it really take to provide the source code for something; 5 maybe 10 minutes?

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jan 11, 2018

Lest we also not forget that these binaries should not have been released in the first place, if at the bare minimum they were not able to provide the source code on request. As per the GPL - you know the thing they have on display in the root of this repository!

dcrdev commented Jan 11, 2018

Lest we also not forget that these binaries should not have been released in the first place, if at the bare minimum they were not able to provide the source code on request. As per the GPL - you know the thing they have on display in the root of this repository!

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jan 12, 2018

Emailed - webmaster@gpl-violations.org as I am unable to subscribe to their mailing list, there's an SSL problem preventing me from doing so.

A guy from gnutls is going to look into this, have also emailed a few people over at samba.

Going to raise an issue for liburcu.org on their github repo - will do some more tomorrow.

dcrdev commented Jan 12, 2018

Emailed - webmaster@gpl-violations.org as I am unable to subscribe to their mailing list, there's an SSL problem preventing me from doing so.

A guy from gnutls is going to look into this, have also emailed a few people over at samba.

Going to raise an issue for liburcu.org on their github repo - will do some more tomorrow.

@LukePulverenti

This comment has been minimized.

Show comment
Hide comment
@LukePulverenti

LukePulverenti Jan 12, 2018

Member

To answer your questions and concerns, we embed ffmpeg as a standalone executable, which the GPL permits us to do. There are several GPL libraries contained in this ffmpeg build, but there is no Emby code linking directly to any of them, it is simply invoked as a standalone process, which the GPL permits.

We are required to disclose the sources of this standalone ffmpeg executable and that's what we've been working on. If you look at the beta packages there is a new licenses sub-folder, and inside you will find a list of all libraries used, the license for each one, and the version that was used. This is where we will also state any modifications to these libraries, there are none, but in the event there ever are any, that's where you will find them.

Please let us know if you have any other questions. Thanks.

Member

LukePulverenti commented Jan 12, 2018

To answer your questions and concerns, we embed ffmpeg as a standalone executable, which the GPL permits us to do. There are several GPL libraries contained in this ffmpeg build, but there is no Emby code linking directly to any of them, it is simply invoked as a standalone process, which the GPL permits.

We are required to disclose the sources of this standalone ffmpeg executable and that's what we've been working on. If you look at the beta packages there is a new licenses sub-folder, and inside you will find a list of all libraries used, the license for each one, and the version that was used. This is where we will also state any modifications to these libraries, there are none, but in the event there ever are any, that's where you will find them.

Please let us know if you have any other questions. Thanks.

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jan 12, 2018

Right, but you are required to provide the code containing the build time flags that were set when these binaries were built!

Furthermore your own product - the relevant parts to reproducibly build that against .net core are not publicly available.

dcrdev commented Jan 12, 2018

Right, but you are required to provide the code containing the build time flags that were set when these binaries were built!

Furthermore your own product - the relevant parts to reproducibly build that against .net core are not publicly available.

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jan 12, 2018

This ^ is why Redhat for instance has to publicly make available the source rpms for all of their packages and that's why for instance CentOS, Oracle Linux and Amazon Linux all exist.

dcrdev commented Jan 12, 2018

This ^ is why Redhat for instance has to publicly make available the source rpms for all of their packages and that's why for instance CentOS, Oracle Linux and Amazon Linux all exist.

@LukePulverenti

This comment has been minimized.

Show comment
Hide comment
@LukePulverenti

LukePulverenti Jan 12, 2018

Member

In regards to ffmpeg, we will disclose the build process for that so that you can see all of the build flags. Thanks.

Member

LukePulverenti commented Jan 12, 2018

In regards to ffmpeg, we will disclose the build process for that so that you can see all of the build flags. Thanks.

@LukePulverenti

This comment has been minimized.

Show comment
Hide comment
@LukePulverenti

LukePulverenti Jan 12, 2018

Member

Until we find a suitable place to put these, here are the ffmpeg build flags:

'--disable-static',
'--disable-cuda',
'--disable-cuvid',
'--disable-iconv',
'--disable-nvenc',
'--disable-doc',
'--disable-ffplay',
'--disable-ffserver',
'--disable-xlib',
'--enable-shared',
'--enable-fontconfig',
'--enable-gnutls',
'--enable-gpl',
'--enable-libass',
'--enable-libfreetype',
'--enable-libfribidi',
'--enable-libmp3lame',
'--enable-libopus',
'--enable-libsmbclient',
'--enable-libtheora',
'--enable-libvorbis',
'--enable-libwebp',
'--enable-libx264',
'--enable-libzvbi',
'--enable-version3',

Plus '--enable-vaapi' on x86_64.

These can also be found at the top of every ffmpeg log.

Member

LukePulverenti commented Jan 12, 2018

Until we find a suitable place to put these, here are the ffmpeg build flags:

'--disable-static',
'--disable-cuda',
'--disable-cuvid',
'--disable-iconv',
'--disable-nvenc',
'--disable-doc',
'--disable-ffplay',
'--disable-ffserver',
'--disable-xlib',
'--enable-shared',
'--enable-fontconfig',
'--enable-gnutls',
'--enable-gpl',
'--enable-libass',
'--enable-libfreetype',
'--enable-libfribidi',
'--enable-libmp3lame',
'--enable-libopus',
'--enable-libsmbclient',
'--enable-libtheora',
'--enable-libvorbis',
'--enable-libwebp',
'--enable-libx264',
'--enable-libzvbi',
'--enable-version3',

Plus '--enable-vaapi' on x86_64.

These can also be found at the top of every ffmpeg log.

@LukePulverenti

This comment has been minimized.

Show comment
Hide comment
@LukePulverenti

LukePulverenti Jan 12, 2018

Member

Additionally the path to the standalone ffmpeg executable is displayed near the beginning of every emby server log. You can use this to locate the executables and play with them in a standalone fashion.

Member

LukePulverenti commented Jan 12, 2018

Additionally the path to the standalone ffmpeg executable is displayed near the beginning of every emby server log. You can use this to locate the executables and play with them in a standalone fashion.

@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

nvllsvm Jan 12, 2018

@LukePulverenti - Are the .NET Core build files proprietary?

nvllsvm commented Jan 12, 2018

@LukePulverenti - Are the .NET Core build files proprietary?

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jan 12, 2018

Yes this seems very elusive...

Also the spec (if there is one - I bet there isn't) is a derivative of Emby and therefore GPL also.

dcrdev commented Jan 12, 2018

Yes this seems very elusive...

Also the spec (if there is one - I bet there isn't) is a derivative of Emby and therefore GPL also.

@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

nvllsvm Jan 13, 2018

If the .NET Core build files are not provided, Emby can no longer be consider fully open source. That is disheartening.

nvllsvm commented Jan 13, 2018

If the .NET Core build files are not provided, Emby can no longer be consider fully open source. That is disheartening.

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jan 13, 2018

This is a joke - you're not complying with the GPL at all!

dcrdev commented Jan 13, 2018

This is a joke - you're not complying with the GPL at all!

@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

nvllsvm Jan 13, 2018

Except from the GPL-2.0:

https://www.gnu.org/licenses/gpl-2.0.html#SEC3

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

@LukePulverenti - Please provide all scripts files that were used to build and assemble the .NET Core releases. The GPL-2.0 requires the be released.

@dcrdev - Should we should trace down people who contributed prior to the CLA and inform them? A DMCA takedown request from one of them on this repo might motivate the Emby team to comply with the license.

nvllsvm commented Jan 13, 2018

Except from the GPL-2.0:

https://www.gnu.org/licenses/gpl-2.0.html#SEC3

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

@LukePulverenti - Please provide all scripts files that were used to build and assemble the .NET Core releases. The GPL-2.0 requires the be released.

@dcrdev - Should we should trace down people who contributed prior to the CLA and inform them? A DMCA takedown request from one of them on this repo might motivate the Emby team to comply with the license.

@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

nvllsvm Jan 13, 2018

Reported a bug for the Arch Linux package. The package cannot claim to be GPL2 when proprietary build files were used to assemble GPL2 code.
https://bugs.archlinux.org/task/57088

nvllsvm commented Jan 13, 2018

Reported a bug for the Arch Linux package. The package cannot claim to be GPL2 when proprietary build files were used to assemble GPL2 code.
https://bugs.archlinux.org/task/57088

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Apr 3, 2018

I need to be very clear on this. The GPL explicitly and loudly states that no warranty is given. The GPL has zero requirement that the source provided work or even compile. It doesn't even require that the code represent a complete program, or even a program at all. The GPL explicitly states that it only concerns itself with the copying, modification and distribution of the work.

I felt the need to clear this up -

Source code as is - there is no need for this to compile, you are correct.

Binary releases licensed under the GPL - these ABSOLOUTELY DO need be accompanied by source code and that source code DOES need to compile. This is covered in Section 3 of the license under the definition for accompanying source code.

See also https://www.gnu.org/licenses/gpl-faq.html#AnonFTPAndSendSources


I need to be very clear on this. The GPL explicitly and loudly states that no warranty is given

Yes but the fact that no warranty is given doesn't somehow invalidate the rights set out by the license agreement. A warranty is a contractual obligation to support, repair or replace a product/service - it's an entirely different beast.


This is indeed a very complicated issue and I'm not a lawyer - one thing I think most people will agree on is that even if this is not technically a violation, it certainly isn't in the spirit of the license. Lets also not forget that atleast once during this debate there was a definite and indisputable violation going on in relation to third part GPL software that was being bundled with the release packages. The library in question was being provided without an accompanying license and/or source code - this has now been resolved but it's not like this is all smoke; also before you say it yes his library was full GPLv2 - as confirmed by the licenses.txt that is now included in these release packages.

And finally I don't know the answer to this - but offering something under the terms of the GPL and then failing to provide the source code (as defined by Section 3) , whilst may not be a violation on the developers part - surely it's still infringing on the rights of the user who downloaded that release under the terms of the GPL. So at best this is false marketing at worst it's causing a violation to occur indirectly - although they seem to have this loophole of re licensing the binary releases on their own; again not sure how this works retrospectively for releases occurring before they made this change.

The mere fact that these practices are in effect preventing end users from realising the rights promised to them by the developers in offering up the GPLv2 license, could at a stretch be considered Estoppel .

From my point of view and by the looks of quite a few others - continuing to present as a GPL project is just PLAIN WRONG. The very fact that this debate needs to take place over something as trivial as the required files to build an 'open source' project - indicates to me that it shouldn't be a GPL project.

The fact that many people arrive at Emby because they read interviews at the likes of Linux.com, watch videos from the 'Linux Action Show' who tout Emby as this great open source GPL project, then arrive at the Emby webpage to further be told that the software is provided under the terms of the GPL - well is just PLAIN WRONG. The fact that the developers don't bother correcting people on this point, perpetuates the false belief people have that this is an open source and GPL compliant project and that is just PLAIN WRONG.


Whilst I fully appreciate the GPL is not for everyone née I even understand why some people hate it, but the fact of the matter is if you fall into that camp - you really shouldn't be using it. To find every tangible excuse not to follow the principles implied by the GPL, says 1 of 2 things:
a) I want all the benefits of the GPL without any of the pain.
b) I'm trying to re license my project covertly.

Both are an affront to the principles upon the GPL was based upon and potentially call into the question the solidity of the license when used legitimately as intended by other individuals.

0. Freedom to run the program as you wish.
1. Freedom to study the source code of the program and then change it so the program does what you wish.
2. Freedom to help your neighbour. That’s the freedom to redistribute the exact copies of the software when you wish.
3. Freedom to contribute to your community. That’s the freedom to distribute copies or modified versions when you wish.

If the end goal here is to re license the project - just be upfront about your intentions and I'm sure a lot less people would be getting worked up about it.


Finally I appreciate that this is no longer the case as it has now been clarified that the binary releases have been re-licensed non-GPL (although we still don't know under what terms those releases are provided) - back when they were being put out as GPL licensed. What the developers were effectively saying is this:

"You are free to modify and redistribute our software as per the terms of the GPL, provided you adhere to the terms of the GPL - which you can't because we're not providing you with the files required to constitute complete source code"

Read into that as you will...

dcrdev commented Apr 3, 2018

I need to be very clear on this. The GPL explicitly and loudly states that no warranty is given. The GPL has zero requirement that the source provided work or even compile. It doesn't even require that the code represent a complete program, or even a program at all. The GPL explicitly states that it only concerns itself with the copying, modification and distribution of the work.

I felt the need to clear this up -

Source code as is - there is no need for this to compile, you are correct.

Binary releases licensed under the GPL - these ABSOLOUTELY DO need be accompanied by source code and that source code DOES need to compile. This is covered in Section 3 of the license under the definition for accompanying source code.

See also https://www.gnu.org/licenses/gpl-faq.html#AnonFTPAndSendSources


I need to be very clear on this. The GPL explicitly and loudly states that no warranty is given

Yes but the fact that no warranty is given doesn't somehow invalidate the rights set out by the license agreement. A warranty is a contractual obligation to support, repair or replace a product/service - it's an entirely different beast.


This is indeed a very complicated issue and I'm not a lawyer - one thing I think most people will agree on is that even if this is not technically a violation, it certainly isn't in the spirit of the license. Lets also not forget that atleast once during this debate there was a definite and indisputable violation going on in relation to third part GPL software that was being bundled with the release packages. The library in question was being provided without an accompanying license and/or source code - this has now been resolved but it's not like this is all smoke; also before you say it yes his library was full GPLv2 - as confirmed by the licenses.txt that is now included in these release packages.

And finally I don't know the answer to this - but offering something under the terms of the GPL and then failing to provide the source code (as defined by Section 3) , whilst may not be a violation on the developers part - surely it's still infringing on the rights of the user who downloaded that release under the terms of the GPL. So at best this is false marketing at worst it's causing a violation to occur indirectly - although they seem to have this loophole of re licensing the binary releases on their own; again not sure how this works retrospectively for releases occurring before they made this change.

The mere fact that these practices are in effect preventing end users from realising the rights promised to them by the developers in offering up the GPLv2 license, could at a stretch be considered Estoppel .

From my point of view and by the looks of quite a few others - continuing to present as a GPL project is just PLAIN WRONG. The very fact that this debate needs to take place over something as trivial as the required files to build an 'open source' project - indicates to me that it shouldn't be a GPL project.

The fact that many people arrive at Emby because they read interviews at the likes of Linux.com, watch videos from the 'Linux Action Show' who tout Emby as this great open source GPL project, then arrive at the Emby webpage to further be told that the software is provided under the terms of the GPL - well is just PLAIN WRONG. The fact that the developers don't bother correcting people on this point, perpetuates the false belief people have that this is an open source and GPL compliant project and that is just PLAIN WRONG.


Whilst I fully appreciate the GPL is not for everyone née I even understand why some people hate it, but the fact of the matter is if you fall into that camp - you really shouldn't be using it. To find every tangible excuse not to follow the principles implied by the GPL, says 1 of 2 things:
a) I want all the benefits of the GPL without any of the pain.
b) I'm trying to re license my project covertly.

Both are an affront to the principles upon the GPL was based upon and potentially call into the question the solidity of the license when used legitimately as intended by other individuals.

0. Freedom to run the program as you wish.
1. Freedom to study the source code of the program and then change it so the program does what you wish.
2. Freedom to help your neighbour. That’s the freedom to redistribute the exact copies of the software when you wish.
3. Freedom to contribute to your community. That’s the freedom to distribute copies or modified versions when you wish.

If the end goal here is to re license the project - just be upfront about your intentions and I'm sure a lot less people would be getting worked up about it.


Finally I appreciate that this is no longer the case as it has now been clarified that the binary releases have been re-licensed non-GPL (although we still don't know under what terms those releases are provided) - back when they were being put out as GPL licensed. What the developers were effectively saying is this:

"You are free to modify and redistribute our software as per the terms of the GPL, provided you adhere to the terms of the GPL - which you can't because we're not providing you with the files required to constitute complete source code"

Read into that as you will...

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Apr 3, 2018

After the inclusion of the correct licensing docs and source for the GPLd third party libraries and @LukePulverenti 's comments:

There is no violation because we have the ability to have a re-licensed version, and you can assume any build scripts are based off such a version. What we are looking at is how we can make you all happy by opening some of these things up, while still being able to sustain our development. There have been good ideas mentioned from cayars, dcrdev and others. Those efforts will require development effort and take time to separate various components, it is not something we can simply flip a switch on and release. Thanks.

I no longer believe there to be a direct violation of the GPL (anymore) - whilst I still believe this goes against the spirit of the license, that is a matter of opinion and I no longer feel this issue is technically valid.

Therefore I'm closing this issue in light of the following separate issues:
#3064
#3196

And in lieu of another issue being opened to get rid of all references to the GPL when used in conjunction with the binary releases - as it's now established they are considered to be a version of the software that has a separate license.

dcrdev commented Apr 3, 2018

After the inclusion of the correct licensing docs and source for the GPLd third party libraries and @LukePulverenti 's comments:

There is no violation because we have the ability to have a re-licensed version, and you can assume any build scripts are based off such a version. What we are looking at is how we can make you all happy by opening some of these things up, while still being able to sustain our development. There have been good ideas mentioned from cayars, dcrdev and others. Those efforts will require development effort and take time to separate various components, it is not something we can simply flip a switch on and release. Thanks.

I no longer believe there to be a direct violation of the GPL (anymore) - whilst I still believe this goes against the spirit of the license, that is a matter of opinion and I no longer feel this issue is technically valid.

Therefore I'm closing this issue in light of the following separate issues:
#3064
#3196

And in lieu of another issue being opened to get rid of all references to the GPL when used in conjunction with the binary releases - as it's now established they are considered to be a version of the software that has a separate license.

@dcrdev dcrdev closed this Apr 3, 2018

@LukePulverenti

This comment has been minimized.

Show comment
Hide comment
@LukePulverenti

LukePulverenti Apr 3, 2018

Member

@dcrdev, I understand your reservations about the embedded binaries and we are actively working on getting them removed. It will take a little time to develop the modularity that is needed but we are going to get that done.

Member

LukePulverenti commented Apr 3, 2018

@dcrdev, I understand your reservations about the embedded binaries and we are actively working on getting them removed. It will take a little time to develop the modularity that is needed but we are going to get that done.

@gsnerf

This comment has been minimized.

Show comment
Hide comment
@gsnerf

gsnerf Apr 5, 2018

Contributor

@LukePulverenti I don't think the reservations are about the embedded binaries. The reservations are about the missing build files for the .net core release and the point that releases other than the Emby.mono.zip provided here don't seem to be licensed under GPL (what exactly are they licensed under now).

A question from my side:

2018 Support is withdrawn for Mono releases on x86_64 making there no reliable way to build, contribute or modify Emby under Linux.

Is this actually the case? Has this been announced anywhere? If so I cannot continue to provide packages for gentoo, as they have to be build on the target system from source.

Contributor

gsnerf commented Apr 5, 2018

@LukePulverenti I don't think the reservations are about the embedded binaries. The reservations are about the missing build files for the .net core release and the point that releases other than the Emby.mono.zip provided here don't seem to be licensed under GPL (what exactly are they licensed under now).

A question from my side:

2018 Support is withdrawn for Mono releases on x86_64 making there no reliable way to build, contribute or modify Emby under Linux.

Is this actually the case? Has this been announced anywhere? If so I cannot continue to provide packages for gentoo, as they have to be build on the target system from source.

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Apr 5, 2018

@gsnerf I think my comments were based on this https://emby.media/community/index.php?/topic/56195-debian-9-x86-missing-dependencies/#entry546783 along with @LukePulverenti advising anyone with issue under mono installs to switch to the .net core releases.

In essence it still builds under mono, but isn't tested or developed for anymore.

I think discussion around that should probably take place here:
#3064

& establishing the licensing of those packages here:
#3225

Interesting point though around Gentoo and how they plan on supporting a source only distro.

dcrdev commented Apr 5, 2018

@gsnerf I think my comments were based on this https://emby.media/community/index.php?/topic/56195-debian-9-x86-missing-dependencies/#entry546783 along with @LukePulverenti advising anyone with issue under mono installs to switch to the .net core releases.

In essence it still builds under mono, but isn't tested or developed for anymore.

I think discussion around that should probably take place here:
#3064

& establishing the licensing of those packages here:
#3225

Interesting point though around Gentoo and how they plan on supporting a source only distro.

@kaithar

This comment has been minimized.

Show comment
Hide comment
@kaithar

kaithar Apr 6, 2018

So in that case it would actually be impossible for any licensee to comply with the license terms (section 3); if nothing else, that seems a bit nonsensical.

The trick would be defining the binary itself as the preferred method for licencees to modify the released object. It makes more sense for things like images, but it's not actually invalid to treat certain classes of raw machine code this way... it's of limited use, true, but I can think of some creative uses. GPL licensed reverse engineering challenges for instance.

Yes but the fact that no warranty is given doesn't somehow invalidate the rights set out by the license agreement.

No warranty invalidates the assumption that functional or possible-to-compile code has to be provided.

Lets also not forget that atleast once during this debate there was a definite and indisputable violation going on in relation to third part GPL software that was being bundled with the release packages.

I refer you again to the Mere Aggregation clause.

And finally I don't know the answer to this - but offering something under the terms of the GPL and then failing to provide the source code (as defined by Section 3) , whilst may not be a violation on the developers part - surely it's still infringing on the rights of the user who downloaded that release under the terms of the GPL.

For downstream to comply with their responsibilities they only have to distribute the files they were provided, they aren't required to distribute files that weren't released by the upstream originators. So no, no infringement there.

2018 Support is withdrawn for Mono releases on x86_64 making there no reliable way to build, contribute or modify Emby under Linux.

Unless I'm failing to understand something, I don't see why requiring .net core has anything to do with not supporting linux, seems pretty officially supportable to me:
https://docs.microsoft.com/en-us/dotnet/core/linux-prerequisites?tabs=netcore2x

The build not currently working isn't necessarily the same as it not being possible or reliable.

If so I cannot continue to provide packages for gentoo, as they have to be build on the target system from source.

As a long time gentoo user I call BS. Take a look at nvidia-drivers, the oracle JDK, and many other blob using ebuilds. Downloading, unpacking and merging a package of binary files is perfectly acceptable.


I'll leave some comments on #3225 on how I'd approach cleaning up this headache.

kaithar commented Apr 6, 2018

So in that case it would actually be impossible for any licensee to comply with the license terms (section 3); if nothing else, that seems a bit nonsensical.

The trick would be defining the binary itself as the preferred method for licencees to modify the released object. It makes more sense for things like images, but it's not actually invalid to treat certain classes of raw machine code this way... it's of limited use, true, but I can think of some creative uses. GPL licensed reverse engineering challenges for instance.

Yes but the fact that no warranty is given doesn't somehow invalidate the rights set out by the license agreement.

No warranty invalidates the assumption that functional or possible-to-compile code has to be provided.

Lets also not forget that atleast once during this debate there was a definite and indisputable violation going on in relation to third part GPL software that was being bundled with the release packages.

I refer you again to the Mere Aggregation clause.

And finally I don't know the answer to this - but offering something under the terms of the GPL and then failing to provide the source code (as defined by Section 3) , whilst may not be a violation on the developers part - surely it's still infringing on the rights of the user who downloaded that release under the terms of the GPL.

For downstream to comply with their responsibilities they only have to distribute the files they were provided, they aren't required to distribute files that weren't released by the upstream originators. So no, no infringement there.

2018 Support is withdrawn for Mono releases on x86_64 making there no reliable way to build, contribute or modify Emby under Linux.

Unless I'm failing to understand something, I don't see why requiring .net core has anything to do with not supporting linux, seems pretty officially supportable to me:
https://docs.microsoft.com/en-us/dotnet/core/linux-prerequisites?tabs=netcore2x

The build not currently working isn't necessarily the same as it not being possible or reliable.

If so I cannot continue to provide packages for gentoo, as they have to be build on the target system from source.

As a long time gentoo user I call BS. Take a look at nvidia-drivers, the oracle JDK, and many other blob using ebuilds. Downloading, unpacking and merging a package of binary files is perfectly acceptable.


I'll leave some comments on #3225 on how I'd approach cleaning up this headache.

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Apr 6, 2018

I refer you again to the Mere Aggregation clause.
The aggregation clause does not cover you against redistributing an independent/standalone binary, without providing the licensing document and providing/offering it's source code.

Again this wasn't available in the package, when this started - now it is.

Unless I'm failing to understand something, I don't see why requiring .net core has anything to do with not supporting linux, seems pretty officially supportable to me:
https://docs.microsoft.com/en-us/dotnet/core/linux-prerequisites?tabs=netcore2x

On this one I think you're misinterpreting what I'm saying - unless I'm missing something... My point is that one can not build Emby against netcore because the csproj files lack the correct dependencies and there are no build scripts availible - neither of which are published.

On Mono however there are build scripts and the dependencies listed in the csproj files work as they are. Luke however has more or less said HE is withdrawing support for Mono, that is Emby under Mono - netcore is the only release they support now.


I do not wish to continue with this thread - that is why I closed it. I believe my original issue has been technically satisfied now.

dcrdev commented Apr 6, 2018

I refer you again to the Mere Aggregation clause.
The aggregation clause does not cover you against redistributing an independent/standalone binary, without providing the licensing document and providing/offering it's source code.

Again this wasn't available in the package, when this started - now it is.

Unless I'm failing to understand something, I don't see why requiring .net core has anything to do with not supporting linux, seems pretty officially supportable to me:
https://docs.microsoft.com/en-us/dotnet/core/linux-prerequisites?tabs=netcore2x

On this one I think you're misinterpreting what I'm saying - unless I'm missing something... My point is that one can not build Emby against netcore because the csproj files lack the correct dependencies and there are no build scripts availible - neither of which are published.

On Mono however there are build scripts and the dependencies listed in the csproj files work as they are. Luke however has more or less said HE is withdrawing support for Mono, that is Emby under Mono - netcore is the only release they support now.


I do not wish to continue with this thread - that is why I closed it. I believe my original issue has been technically satisfied now.

@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

nvllsvm Jul 22, 2018

@dcrdev, I understand your reservations about the embedded binaries and we are actively working on getting them removed. It will take a little time to develop the modularity that is needed but we are going to get that done.

@LukePulverenti - Complete and utter bullshit - the latest release of Emby just removed the source code for the MediaBrowser.Common, MediaBrowser.Model, and MediaBrowser.Controller components. What remains are DLLs.

https://github.com/MediaBrowser/Emby/tree/master/packages/MediaBrowser.Common.3.5.0/lib/netstandard2.0
https://github.com/MediaBrowser/Emby/tree/master/packages/MediaBrowser.Server.Core.3.5.0/lib/netstandard2.0

nvllsvm commented Jul 22, 2018

@dcrdev, I understand your reservations about the embedded binaries and we are actively working on getting them removed. It will take a little time to develop the modularity that is needed but we are going to get that done.

@LukePulverenti - Complete and utter bullshit - the latest release of Emby just removed the source code for the MediaBrowser.Common, MediaBrowser.Model, and MediaBrowser.Controller components. What remains are DLLs.

https://github.com/MediaBrowser/Emby/tree/master/packages/MediaBrowser.Common.3.5.0/lib/netstandard2.0
https://github.com/MediaBrowser/Emby/tree/master/packages/MediaBrowser.Server.Core.3.5.0/lib/netstandard2.0

@LukePulverenti

This comment has been minimized.

Show comment
Hide comment
@LukePulverenti

LukePulverenti Jul 22, 2018

Member

It was moved to a nuget package to make things easier as those projects have multiple consumers. I'll get repos setup for them when i have a chance.

Member

LukePulverenti commented Jul 22, 2018

It was moved to a nuget package to make things easier as those projects have multiple consumers. I'll get repos setup for them when i have a chance.

@Hippyjake

This comment has been minimized.

Show comment
Hide comment
@Hippyjake

Hippyjake Jul 22, 2018

Well, I said I wouldn't do it, but here we go. The time you should have set up the separate repositories is when you were separating the code. You should not have to do this after the fact if you are thinking about open source. But I guess we've already determined this is not the case.
I am increasingly saddened to see the lack of community representation Luke you are really bad at trying to explain things. I'm not sure if English is your first language or not, but you really do need to get a community manager to answer questions on your behalf.

Hippyjake commented Jul 22, 2018

Well, I said I wouldn't do it, but here we go. The time you should have set up the separate repositories is when you were separating the code. You should not have to do this after the fact if you are thinking about open source. But I guess we've already determined this is not the case.
I am increasingly saddened to see the lack of community representation Luke you are really bad at trying to explain things. I'm not sure if English is your first language or not, but you really do need to get a community manager to answer questions on your behalf.

@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

nvllsvm Jul 24, 2018

@LukePulverenti - The new repository has no license. Per the logic @ebr11 used on the Emby forums, the repository cannot be redistributed in any form. https://emby.media/community/index.php?/topic/49862-source-code-license/?p=477050

Is this correct?

nvllsvm commented Jul 24, 2018

@LukePulverenti - The new repository has no license. Per the logic @ebr11 used on the Emby forums, the repository cannot be redistributed in any form. https://emby.media/community/index.php?/topic/49862-source-code-license/?p=477050

Is this correct?

@LukePulverenti

This comment has been minimized.

Show comment
Hide comment
@LukePulverenti

LukePulverenti Jul 24, 2018

Member

You can redistribute them.

Member

LukePulverenti commented Jul 24, 2018

You can redistribute them.

@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

nvllsvm Jul 24, 2018

@LukePulverenti - Under what license?

nvllsvm commented Jul 24, 2018

@LukePulverenti - Under what license?

@LukePulverenti

This comment has been minimized.

Show comment
Hide comment
@LukePulverenti

LukePulverenti Jul 24, 2018

Member

Possibly mit but i'm not sure yet. You can proceed with these three libs without waiting on us. When we do get around to it, it will have a license that will allow you to distribute them. Thanks.

Member

LukePulverenti commented Jul 24, 2018

Possibly mit but i'm not sure yet. You can proceed with these three libs without waiting on us. When we do get around to it, it will have a license that will allow you to distribute them. Thanks.

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jul 24, 2018

@LukePulverenti without the risk of starting this flame war again (which I really don't want to do) - why is that now 1 year later we still don't have an open source build environment for the net core version of this; when it already exists internally.

I'd really appreciate it if you could be a bit more transparent on that one fact :

  • Is it that you're unsure about the future of the open/closed source situation.
  • Are there technical challenges with doing so? If yes, what broadly speaking are they.

Again as someone who recently purchased another Emby premiere membership from you and someone who actively helps people on your community forums, I would very much appreciate an honest answer!

Cheers

dcrdev commented Jul 24, 2018

@LukePulverenti without the risk of starting this flame war again (which I really don't want to do) - why is that now 1 year later we still don't have an open source build environment for the net core version of this; when it already exists internally.

I'd really appreciate it if you could be a bit more transparent on that one fact :

  • Is it that you're unsure about the future of the open/closed source situation.
  • Are there technical challenges with doing so? If yes, what broadly speaking are they.

Again as someone who recently purchased another Emby premiere membership from you and someone who actively helps people on your community forums, I would very much appreciate an honest answer!

Cheers

@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

nvllsvm Jul 24, 2018

@LukePulverenti - To be extra clear, do you grant permission to distribute modified, compiled versions of the files?

nvllsvm commented Jul 24, 2018

@LukePulverenti - To be extra clear, do you grant permission to distribute modified, compiled versions of the files?

@ebr11

This comment has been minimized.

Show comment
Hide comment
@ebr11

ebr11 Jul 24, 2018

Member

To be extra clear, do you grant permission to distribute modified, compiled versions of the files?

I thought we were talking binaries here - in which case it would be no.

Edit: If not talking about binaries, then disregard

Member

ebr11 commented Jul 24, 2018

To be extra clear, do you grant permission to distribute modified, compiled versions of the files?

I thought we were talking binaries here - in which case it would be no.

Edit: If not talking about binaries, then disregard

@nvllsvm

This comment has been minimized.

Show comment
Hide comment
@nvllsvm

nvllsvm Jul 25, 2018

@ebr - No, we're talking about compiling the repo Luke linked to. So we're not allowed to dsitrubte that repo when we compile it ourselves?

nvllsvm commented Jul 25, 2018

@ebr - No, we're talking about compiling the repo Luke linked to. So we're not allowed to dsitrubte that repo when we compile it ourselves?

@jaredallard

This comment has been minimized.

Show comment
Hide comment
@jaredallard

jaredallard Jul 25, 2018

Quick final thoughts on this: Clearly Emby doesn't plan to continue down a OSS path that many people in this thread feel it should. Either; hard fork Emby and continue your own development, write a clone yourself, or stop this thread. This will not, and hasn't been, going anywhere and it's unlikely it ever will go anywhere.

Actions speak louder than arguments on a issue. The beauty of open source is the ability to fork it and take your own direction, that's also still possible, albiet harder, with closed source applications, so let's go that way. Clearly enough of us disagree with emby's direction.

There's a reason iojs did so well and forced nodejs to take a proper direction.

jaredallard commented Jul 25, 2018

Quick final thoughts on this: Clearly Emby doesn't plan to continue down a OSS path that many people in this thread feel it should. Either; hard fork Emby and continue your own development, write a clone yourself, or stop this thread. This will not, and hasn't been, going anywhere and it's unlikely it ever will go anywhere.

Actions speak louder than arguments on a issue. The beauty of open source is the ability to fork it and take your own direction, that's also still possible, albiet harder, with closed source applications, so let's go that way. Clearly enough of us disagree with emby's direction.

There's a reason iojs did so well and forced nodejs to take a proper direction.

@ebr11

This comment has been minimized.

Show comment
Hide comment
@ebr11

ebr11 Jul 25, 2018

Member

@nullsvm - No, sorry for the confusion. I thought you were referencing already compiled binaries.

Member

ebr11 commented Jul 25, 2018

@nullsvm - No, sorry for the confusion. I thought you were referencing already compiled binaries.

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jul 25, 2018

@ebr11 so that precludes anyone from redistributing Emby as a package in any form then?

Due to Emby being reliant on the proprietary binary blobs located here:
https://github.com/MediaBrowser/Emby/tree/master/ThirdParty/emby , in order to run?

Uh oh looks like anyone who has ever forked your repo just violated your imaginary licensing concept... gosh darn it.

dcrdev commented Jul 25, 2018

@ebr11 so that precludes anyone from redistributing Emby as a package in any form then?

Due to Emby being reliant on the proprietary binary blobs located here:
https://github.com/MediaBrowser/Emby/tree/master/ThirdParty/emby , in order to run?

Uh oh looks like anyone who has ever forked your repo just violated your imaginary licensing concept... gosh darn it.

@ebr11

This comment has been minimized.

Show comment
Hide comment
@ebr11

ebr11 Jul 25, 2018

Member

No, I was responding to the question about modified binaries. Meaning something that was provided only in binary form and then modified in some way like by de-compiling it.

Member

ebr11 commented Jul 25, 2018

No, I was responding to the question about modified binaries. Meaning something that was provided only in binary form and then modified in some way like by de-compiling it.

@dcrdev

This comment has been minimized.

Show comment
Hide comment
@dcrdev

dcrdev Jul 25, 2018

@ebr11 ok thanks for being #superawesomelyclear - while we're at it since these it's not clear what's derived from gpl source, what's not, what's propriety and what's mit.

What's your definitive definition of modified...

  • Is that limited to reversing engineering ?
  • Or does it cover more use cases - for example under certain circumstances filesystems might modify the computational hash of a file when applying extended filesystem attributes. What interfacing with these assemblies in different way embedding them in your project for example via AssembleyResolve or ILMerge? How does that play out in the licensing agreement that you haven't provided any of your users with?

#superawesomelyclear

dcrdev commented Jul 25, 2018

@ebr11 ok thanks for being #superawesomelyclear - while we're at it since these it's not clear what's derived from gpl source, what's not, what's propriety and what's mit.

What's your definitive definition of modified...

  • Is that limited to reversing engineering ?
  • Or does it cover more use cases - for example under certain circumstances filesystems might modify the computational hash of a file when applying extended filesystem attributes. What interfacing with these assemblies in different way embedding them in your project for example via AssembleyResolve or ILMerge? How does that play out in the licensing agreement that you haven't provided any of your users with?

#superawesomelyclear

@RaymondSchnyder

This comment has been minimized.

Show comment
Hide comment
@RaymondSchnyder

RaymondSchnyder Jul 26, 2018

I see this thread will be continuing for ages.
anyway, me as customer, who bought the emby pass countless times, i feel cheated by the actions of the emby team.
Just wanna say that.

RaymondSchnyder commented Jul 26, 2018

I see this thread will be continuing for ages.
anyway, me as customer, who bought the emby pass countless times, i feel cheated by the actions of the emby team.
Just wanna say that.

@berrnd

This comment has been minimized.

Show comment
Hide comment
@berrnd

berrnd Jul 28, 2018

I'm maintaining my own fork of Emby with more or less heavy modifications just for private use since a very long time which I update every some months - that's no the topic, today I wanted to update it again, merged upstream changes as always and noted that some components (where I also did modifications in the past) were replaced by binary blobs (DLLs).

@LukePulverenti said above that these were replaced for reasons and the source is now in this repository - which can be in fact not 100% true: The current master branch does not compile when using self-compiled DLLs from Emby.Common. So the included blobs are not compiled from the mentioned repo.

I like Emby very much, how this is all going seems very weird to me. Be Open Source or close it completely somehow. Including compiled dependencies which are obviosly not compiled from the source they belong to is the most disgusting thing I can imagine for an Open Source project.

So anyhow, thanks for all your work @LukePulverenti and just one question: Why is it so hard to fix this?

(References #3376)

berrnd commented Jul 28, 2018

I'm maintaining my own fork of Emby with more or less heavy modifications just for private use since a very long time which I update every some months - that's no the topic, today I wanted to update it again, merged upstream changes as always and noted that some components (where I also did modifications in the past) were replaced by binary blobs (DLLs).

@LukePulverenti said above that these were replaced for reasons and the source is now in this repository - which can be in fact not 100% true: The current master branch does not compile when using self-compiled DLLs from Emby.Common. So the included blobs are not compiled from the mentioned repo.

I like Emby very much, how this is all going seems very weird to me. Be Open Source or close it completely somehow. Including compiled dependencies which are obviosly not compiled from the source they belong to is the most disgusting thing I can imagine for an Open Source project.

So anyhow, thanks for all your work @LukePulverenti and just one question: Why is it so hard to fix this?

(References #3376)

@LukePulverenti LukePulverenti changed the title from [Request] GPL Violation to [Request] GPL Changes Aug 9, 2018

@Blackclaws

This comment has been minimized.

Show comment
Hide comment
@Blackclaws

Blackclaws Sep 2, 2018

So I was wondering, when is the license on the Common DLLs going to be clarified? I would very much like to support a build from only open sources for emby for my local deployment.

Blackclaws commented Sep 2, 2018

So I was wondering, when is the license on the Common DLLs going to be clarified? I would very much like to support a build from only open sources for emby for my local deployment.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment