Pre-release

@nathanhammond nathanhammond released this Dec 1, 2016 · 2467 commits to master since this release

Assets 3

Setup

  1. npm uninstall -g ember-cli -- Remove old global ember-cli
  2. npm cache clean -- Clear NPM cache
  3. bower cache clean -- Clear Bower cache
  4. npm install -g ember-cli@2.11.0-beta.1 -- Install new global ember-cli

Project Update

  1. rm -rf node_modules bower_components dist tmp -- Delete temporary development folders.
  2. npm install --save-dev ember-cli@2.11.0-beta.1 -- Update project's package.json to use latest version.
  3. npm install -- Reinstall NPM dependencies.
  4. bower install -- Reinstall bower dependencies.
  5. ember init -- This runs the new project blueprint on your projects directory. Please follow the prompts, and review all changes (tip: you can see a diff by pressing d). The most common source of upgrade pain is missing changes in this step.

Changelog

The following changes are required if you are upgrading from the previous
version:

Notes:

  • This version of Ember CLI will not officially support Node.js v0.12 per the Ember Node.js LTS Support policy.
  • As part of this release we have made the default behavior inclusion of Ember from npm via the ember-source npm package.

Community Contributions

Thank you to all who took the time to contribute! A special thanks to those who
helped us bring this release to a close after discovering that CI was broken for
the two weeks leading up to the release.