Java Ruby
Clone or download
Latest commit 1b529dd Jan 6, 2018

README.md

Toxiclibs for JRubyArt

travis build Gem Version

Installing

gem install toxiclibs

NB: Use version 0.4 for ruby-processing, and 1.0.0 for propane and JRubyArt

NB: Build is only failing because current version of processing is not available at maven central. This gem provides Karsten Schmidts (aka toxi, @postspectacular) toxiclibs jars for JRubyArt. To compile the gem follow the instructions for JRubyArt. Most parts of toxiclibs API is exposed in the latest version, (but only a few examples are included) in principle it should be possible to make all available!!! For this demonstration I have used up to date source code for version 21, since toxis final release has not yet been released (although Dan Shiffman has released a version for processing-3.0+). There are reported to be number of outstanding bugs with toxiclibs, if they affect you report it here (or better fix them yourself and submit a pull request).

grayscott image

Web Links

Post Spectacular Home

Toxiclibs Bitbucket

Toxiclibs Documentation

Example Usage

Licensing

I should be clear that the original toxiclibs is the work of Karsten Schmidt see Copyright

This demo & library is free software you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation either version 2.1 of the License, or (at your option) any later version.