Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Deprecate `#![plugin]` & `#[plugin_registrar]` #64675

Merged
merged 3 commits into from Oct 4, 2019

Conversation

@Centril
Copy link
Member

commented Sep 21, 2019

This PR deprecates #![plugin] and #[plugin_registrar].

A removal deadline is set: 1.44.0. This will be in 9 months from now and should give everyone who is still relying on the feature ample time to rid themselves of this dependency.

cc #29597

r? @Mark-Simulacrum

@Mark-Simulacrum

This comment has been minimized.

Copy link
Member

commented Sep 21, 2019

Implementation wise this looks reasonable, but we probably want to get sign-off from at least T-lang here, maybe T-compiler (in particular, if plugins are actively blocking any work, we can move removal date closer). So let's: @rustbot modify labels: +I-nominated T-lang T-compiler

Cc @rust-lang/lang @rust-lang/compiler

It might also be worth reaching out to servo directly as they're the ones we're "waiting on" to remove this functionality to make them aware of this timeline. I believe current consensus is that anyone using plugins today is advised to migrate to a custom rustc build (via a rustc_private dep on rustc_interface) which should be relatively fast, though not particularly stable, of course, but no less stable than plugins were/are.

@rust-highfive

This comment was marked as resolved.

Copy link
Collaborator

commented Sep 22, 2019

The job x86_64-gnu-llvm-6.0 of your PR failed (pretty log, raw log). Through arcane magic we have determined that the following fragments from the build log may contain information about the problem.

Click to expand the log.
2019-09-21T23:50:54.7123746Z ##[command]git remote add origin https://github.com/rust-lang/rust
2019-09-21T23:50:55.2719885Z ##[command]git config gc.auto 0
2019-09-21T23:50:55.2725831Z ##[command]git config --get-all http.https://github.com/rust-lang/rust.extraheader
2019-09-21T23:50:55.2729857Z ##[command]git config --get-all http.proxy
2019-09-21T23:50:55.2734637Z ##[command]git -c http.extraheader="AUTHORIZATION: basic ***" fetch --force --tags --prune --progress --no-recurse-submodules --depth=2 origin +refs/heads/*:refs/remotes/origin/* +refs/pull/64675/merge:refs/remotes/pull/64675/merge
---
2019-09-22T00:53:42.1482236Z .................................................................................................... 1500/9030
2019-09-22T00:53:48.2441896Z .................................................................................................... 1600/9030
2019-09-22T00:54:01.1476637Z .....................................................................i...............i.............. 1700/9030
2019-09-22T00:54:07.9136126Z .................................................................................................... 1800/9030
2019-09-22T00:54:23.5499459Z ............................................................iiiii................................... 1900/9030
2019-09-22T00:54:35.9730549Z .................................................................................................... 2100/9030
2019-09-22T00:54:38.5213171Z .................................................................................................... 2200/9030
2019-09-22T00:54:41.8896242Z .................................................................................................... 2300/9030
2019-09-22T00:54:50.5880525Z .................................................................................................... 2400/9030
---
2019-09-22T00:57:52.1253354Z ................................................i...............i................................... 4700/9030
2019-09-22T00:58:01.7490839Z .................................................................................................... 4800/9030
2019-09-22T00:58:09.6729845Z .................................................................................................... 4900/9030
2019-09-22T00:58:19.3701765Z .................................................................................................... 5000/9030
2019-09-22T00:58:27.3239073Z ..................................ii.ii............................................................. 5100/9030
2019-09-22T00:58:36.8313417Z .................................................................................................... 5300/9030
2019-09-22T00:58:47.5453043Z ..................................................................................................i. 5400/9030
2019-09-22T00:58:55.8080937Z .................................................................................................... 5500/9030
2019-09-22T00:59:00.8222115Z .................................................................................................... 5600/9030
2019-09-22T00:59:00.8222115Z .................................................................................................... 5600/9030
2019-09-22T00:59:11.8436018Z .............................................................................................ii...i. 5700/9030
2019-09-22T00:59:26.0612004Z .ii...........i..................................................................................... 5800/9030
2019-09-22T00:59:47.4629732Z .................................................................................................... 6000/9030
2019-09-22T00:59:56.6320512Z ...............................................................................................i..ii 6100/9030
2019-09-22T01:00:12.0400201Z .................................................................................................... 6200/9030
2019-09-22T01:00:25.8624150Z .................................................................................................... 6300/9030
---
2019-09-22T01:05:14.8415306Z  finished in 5.544
2019-09-22T01:05:14.8615809Z Check compiletest suite=codegen mode=codegen (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-09-22T01:05:15.0354358Z 
2019-09-22T01:05:15.0355868Z running 150 tests
2019-09-22T01:05:18.3794515Z i....iii......iii..iiii....i.............................i..i..................i....i.........ii.i.i 100/150
2019-09-22T01:05:20.4137107Z ..iiii..............i.........iii.i.......ii......
2019-09-22T01:05:20.4191916Z 
2019-09-22T01:05:20.4191969Z  finished in 5.551
2019-09-22T01:05:20.4333062Z Check compiletest suite=codegen-units mode=codegen-units (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-09-22T01:05:20.6013251Z 
---
2019-09-22T01:05:22.7628950Z  finished in 2.329
2019-09-22T01:05:22.7813791Z Check compiletest suite=assembly mode=assembly (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-09-22T01:05:22.9441885Z 
2019-09-22T01:05:22.9442750Z running 9 tests
2019-09-22T01:05:22.9443996Z iiiiiiiii
2019-09-22T01:05:22.9445380Z 
2019-09-22T01:05:22.9448383Z  finished in 0.162
2019-09-22T01:05:22.9633676Z Check compiletest suite=incremental mode=incremental (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-09-22T01:05:23.1342482Z 
---
2019-09-22T01:05:41.7929246Z  finished in 18.829
2019-09-22T01:05:41.8164429Z Check compiletest suite=debuginfo mode=debuginfo-gdb+lldb (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-09-22T01:05:41.9936256Z 
2019-09-22T01:05:41.9937280Z running 123 tests
2019-09-22T01:06:06.8345101Z .iiiii...i.....i..i...i..i.i.i..i.ii..i.i.....i..i....ii..........iiii..........i...ii...i.......ii. 100/123
2019-09-22T01:06:11.5233234Z i.i.i......iii.i.....ii
2019-09-22T01:06:11.5233793Z 
2019-09-22T01:06:11.5237185Z  finished in 29.706
2019-09-22T01:06:11.5242891Z Uplifting stage1 rustc (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-09-22T01:06:11.5243242Z Copying stage2 rustc from stage1 (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu / x86_64-unknown-linux-gnu)
2019-09-22T01:06:11.5243242Z Copying stage2 rustc from stage1 (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu / x86_64-unknown-linux-gnu)
2019-09-22T01:06:11.5461495Z Check compiletest suite=ui-fulldeps mode=ui (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-09-22T01:06:11.7077539Z 
2019-09-22T01:06:11.7077903Z running 69 tests
2019-09-22T01:07:14.2563088Z ........................F.F.......FFFF..FFFFFFFF..F..F.FF.FFF..F.....
2019-09-22T01:07:14.2605805Z 
2019-09-22T01:07:14.2606390Z ---- [ui] ui-fulldeps/issue-15778-fail.rs stdout ----
2019-09-22T01:07:14.2606439Z diff of stderr:
2019-09-22T01:07:14.2606467Z 
2019-09-22T01:07:14.2606467Z 
2019-09-22T01:07:14.2607141Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2607374Z +   --> $DIR/issue-15778-fail.rs:6:1
2019-09-22T01:07:14.2607433Z +    |
2019-09-22T01:07:14.2607471Z + LL | #![plugin(lint_for_crate)]
2019-09-22T01:07:14.2607567Z +    |
2019-09-22T01:07:14.2607605Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2607641Z + 
2019-09-22T01:07:14.2607641Z + 
2019-09-22T01:07:14.2607679Z 1 error: crate is not marked with #![crate_okay]
2019-09-22T01:07:14.2608131Z 3    |
2019-09-22T01:07:14.2608154Z 
2019-09-22T01:07:14.2608176Z 
2019-09-22T01:07:14.2608242Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2608242Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2608533Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-fail/issue-15778-fail.stderr
2019-09-22T01:07:14.2608761Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2609326Z To only update this specific test, also pass `--test-args issue-15778-fail.rs`
2019-09-22T01:07:14.2609407Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2609468Z status: exit code: 1
2019-09-22T01:07:14.2609468Z status: exit code: 1
2019-09-22T01:07:14.2610250Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/issue-15778-fail.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-fail" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-D" "crate-not-okay" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-fail/auxiliary" "-A" "unused"
2019-09-22T01:07:14.2610613Z ------------------------------------------
2019-09-22T01:07:14.2610648Z 
2019-09-22T01:07:14.2610892Z ------------------------------------------
2019-09-22T01:07:14.2610940Z stderr:
2019-09-22T01:07:14.2610940Z stderr:
2019-09-22T01:07:14.2611161Z ------------------------------------------
2019-09-22T01:07:14.2611558Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2611876Z    |
2019-09-22T01:07:14.2611876Z    |
2019-09-22T01:07:14.2611937Z LL | #![plugin(lint_for_crate)]
2019-09-22T01:07:14.2612038Z    |
2019-09-22T01:07:14.2612107Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2612137Z 
2019-09-22T01:07:14.2612137Z 
2019-09-22T01:07:14.2612181Z error: crate is not marked with #![crate_okay]
2019-09-22T01:07:14.2612790Z    |
2019-09-22T01:07:14.2612790Z    |
2019-09-22T01:07:14.2612828Z LL | / #![feature(plugin)] //~ ERROR crate is not marked with #![crate_okay]
2019-09-22T01:07:14.2612868Z LL | | #![plugin(lint_for_crate)]
2019-09-22T01:07:14.2612952Z LL | | pub fn main() { }
2019-09-22T01:07:14.2612986Z    | |_________________^
2019-09-22T01:07:14.2613036Z    |
2019-09-22T01:07:14.2613036Z    |
2019-09-22T01:07:14.2613232Z    = note: requested on the command line with `-D crate-not-okay`
2019-09-22T01:07:14.2613294Z error: aborting due to previous error
2019-09-22T01:07:14.2613331Z 
2019-09-22T01:07:14.2613352Z 
2019-09-22T01:07:14.2613539Z ------------------------------------------
2019-09-22T01:07:14.2613539Z ------------------------------------------
2019-09-22T01:07:14.2613566Z 
2019-09-22T01:07:14.2613586Z 
2019-09-22T01:07:14.2613880Z ---- [ui] ui-fulldeps/issue-15778-pass.rs stdout ----
2019-09-22T01:07:14.2613930Z normalized stderr:
2019-09-22T01:07:14.2614270Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2614502Z    |
2019-09-22T01:07:14.2614502Z    |
2019-09-22T01:07:14.2614536Z LL | #![plugin(lint_for_crate_rpass)]
2019-09-22T01:07:14.2614625Z    |
2019-09-22T01:07:14.2614661Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2614702Z 
2019-09-22T01:07:14.2614722Z 
2019-09-22T01:07:14.2614722Z 
2019-09-22T01:07:14.2614742Z 
2019-09-22T01:07:14.2614762Z 
2019-09-22T01:07:14.2614798Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2615067Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-pass/issue-15778-pass.stderr
2019-09-22T01:07:14.2615382Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2615596Z To only update this specific test, also pass `--test-args issue-15778-pass.rs`
2019-09-22T01:07:14.2615677Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2615712Z status: exit code: 0
2019-09-22T01:07:14.2615712Z status: exit code: 0
2019-09-22T01:07:14.2616491Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/issue-15778-pass.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-pass/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-D" "crate-not-okay" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-pass/auxiliary"
2019-09-22T01:07:14.2617002Z ------------------------------------------
2019-09-22T01:07:14.2617039Z 
2019-09-22T01:07:14.2617227Z ------------------------------------------
2019-09-22T01:07:14.2617266Z stderr:
2019-09-22T01:07:14.2617266Z stderr:
2019-09-22T01:07:14.2617464Z ------------------------------------------
2019-09-22T01:07:14.2617773Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2618054Z    |
2019-09-22T01:07:14.2618054Z    |
2019-09-22T01:07:14.2618091Z LL | #![plugin(lint_for_crate_rpass)]
2019-09-22T01:07:14.2620463Z    |
2019-09-22T01:07:14.2620510Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2620544Z 
2019-09-22T01:07:14.2620588Z 
2019-09-22T01:07:14.2620588Z 
2019-09-22T01:07:14.2621092Z ------------------------------------------
2019-09-22T01:07:14.2621148Z 
2019-09-22T01:07:14.2621174Z 
2019-09-22T01:07:14.2621450Z ---- [ui] ui-fulldeps/issue-40001.rs stdout ----
2019-09-22T01:07:14.2621504Z normalized stderr:
2019-09-22T01:07:14.2621932Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2622201Z   --> $DIR/issue-40001.rs:6:1
2019-09-22T01:07:14.2622250Z    |
2019-09-22T01:07:14.2622296Z LL | #![plugin(issue_40001_plugin)]
2019-09-22T01:07:14.2622409Z    |
2019-09-22T01:07:14.2622455Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2622485Z 
2019-09-22T01:07:14.2622527Z 
2019-09-22T01:07:14.2622527Z 
2019-09-22T01:07:14.2622553Z 
2019-09-22T01:07:14.2622579Z 
2019-09-22T01:07:14.2622625Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2622958Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-40001/issue-40001.stderr
2019-09-22T01:07:14.2623359Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2623768Z To only update this specific test, also pass `--test-args issue-40001.rs`
2019-09-22T01:07:14.2623875Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2623913Z status: exit code: 0
2019-09-22T01:07:14.2623913Z status: exit code: 0
2019-09-22T01:07:14.2624569Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/issue-40001.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-40001/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-40001/auxiliary"
2019-09-22T01:07:14.2624959Z ------------------------------------------
2019-09-22T01:07:14.2625009Z 
2019-09-22T01:07:14.2625359Z ------------------------------------------
2019-09-22T01:07:14.2625406Z stderr:
2019-09-22T01:07:14.2625406Z stderr:
2019-09-22T01:07:14.2625779Z ------------------------------------------
2019-09-22T01:07:14.2626503Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2626902Z   --> /checkout/src/test/ui-fulldeps/issue-40001.rs:6:1
2019-09-22T01:07:14.2626946Z    |
2019-09-22T01:07:14.2627189Z LL | #![plugin(issue_40001_plugin)]
2019-09-22T01:07:14.2627286Z    |
2019-09-22T01:07:14.2627324Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2627349Z 
2019-09-22T01:07:14.2627371Z 
2019-09-22T01:07:14.2627371Z 
2019-09-22T01:07:14.2627579Z ------------------------------------------
2019-09-22T01:07:14.2627784Z 
2019-09-22T01:07:14.2627807Z 
2019-09-22T01:07:14.2628544Z ---- [ui] ui-fulldeps/lint-group-plugin-deny-cmdline.rs stdout ----
2019-09-22T01:07:14.2628630Z diff of stderr:
2019-09-22T01:07:14.2628657Z 
2019-09-22T01:07:14.2629432Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2635671Z +   --> $DIR/lint-group-plugin-deny-cmdline.rs:6:1
2019-09-22T01:07:14.2635730Z +    |
2019-09-22T01:07:14.2635768Z + LL | #![plugin(lint_group_plugin_test)]
2019-09-22T01:07:14.2635870Z +    |
2019-09-22T01:07:14.2635907Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2635959Z + 
2019-09-22T01:07:14.2635959Z + 
2019-09-22T01:07:14.2636153Z 1 error: item is named 'lintme'
2019-09-22T01:07:14.2636402Z 3    |
2019-09-22T01:07:14.2636427Z 
2019-09-22T01:07:14.2636448Z 
2019-09-22T01:07:14.2636485Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2636485Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2637005Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin-deny-cmdline/lint-group-plugin-deny-cmdline.stderr
2019-09-22T01:07:14.2637232Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2637469Z To only update this specific test, also pass `--test-args lint-group-plugin-deny-cmdline.rs`
2019-09-22T01:07:14.2637553Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2637591Z status: exit code: 1
2019-09-22T01:07:14.2637591Z status: exit code: 1
2019-09-22T01:07:14.2638616Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-group-plugin-deny-cmdline.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin-deny-cmdline" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-D" "lint-me" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin-deny-cmdline/auxiliary" "-A" "unused"
2019-09-22T01:07:14.2638977Z ------------------------------------------
2019-09-22T01:07:14.2639198Z 
2019-09-22T01:07:14.2639983Z ------------------------------------------
2019-09-22T01:07:14.2640038Z stderr:
2019-09-22T01:07:14.2640038Z stderr:
2019-09-22T01:07:14.2640322Z ------------------------------------------
2019-09-22T01:07:14.2641672Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2642076Z    |
2019-09-22T01:07:14.2642076Z    |
2019-09-22T01:07:14.2642121Z LL | #![plugin(lint_group_plugin_test)]
2019-09-22T01:07:14.2642410Z    |
2019-09-22T01:07:14.2642456Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2642488Z 
2019-09-22T01:07:14.2642488Z 
2019-09-22T01:07:14.2642902Z error: item is named 'lintme'
2019-09-22T01:07:14.2643157Z    |
2019-09-22T01:07:14.2643157Z    |
2019-09-22T01:07:14.2643368Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-09-22T01:07:14.2643442Z    |
2019-09-22T01:07:14.2643646Z    = note: `-D test-lint` implied by `-D lint-me`
2019-09-22T01:07:14.2643674Z 
2019-09-22T01:07:14.2643674Z 
2019-09-22T01:07:14.2643851Z error: item is named 'pleaselintme'
2019-09-22T01:07:14.2644365Z    |
2019-09-22T01:07:14.2644365Z    |
2019-09-22T01:07:14.2647128Z LL | fn pleaselintme() { } //~ ERROR item is named 'pleaselintme'
2019-09-22T01:07:14.2647271Z    |
2019-09-22T01:07:14.2647271Z    |
2019-09-22T01:07:14.2648607Z    = note: `-D please-lint` implied by `-D lint-me`
2019-09-22T01:07:14.2648716Z error: aborting due to 2 previous errors
2019-09-22T01:07:14.2648772Z 
2019-09-22T01:07:14.2649638Z 
2019-09-22T01:07:14.2649994Z ------------------------------------------
2019-09-22T01:07:14.2649994Z ------------------------------------------
2019-09-22T01:07:14.2650028Z 
2019-09-22T01:07:14.2650054Z 
2019-09-22T01:07:14.2650316Z ---- [ui] ui-fulldeps/lint-group-plugin.rs stdout ----
2019-09-22T01:07:14.2650367Z diff of stderr:
2019-09-22T01:07:14.2650396Z 
2019-09-22T01:07:14.2659351Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2659725Z +   --> $DIR/lint-group-plugin.rs:6:1
2019-09-22T01:07:14.2659779Z +    |
2019-09-22T01:07:14.2659848Z + LL | #![plugin(lint_group_plugin_test)]
2019-09-22T01:07:14.2659946Z +    |
2019-09-22T01:07:14.2660008Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2660075Z + 
2019-09-22T01:07:14.2660075Z + 
2019-09-22T01:07:14.2660304Z 1 warning: item is named 'lintme'
2019-09-22T01:07:14.2660609Z 3    |
2019-09-22T01:07:14.2660639Z 
2019-09-22T01:07:14.2660664Z 
2019-09-22T01:07:14.2660711Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2660711Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2661047Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin/lint-group-plugin.stderr
2019-09-22T01:07:14.2661302Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2661569Z To only update this specific test, also pass `--test-args lint-group-plugin.rs`
2019-09-22T01:07:14.2661668Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2661714Z status: exit code: 0
2019-09-22T01:07:14.2661714Z status: exit code: 0
2019-09-22T01:07:14.2662814Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-group-plugin.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin/auxiliary"
2019-09-22T01:07:14.2663164Z ------------------------------------------
2019-09-22T01:07:14.2663194Z 
2019-09-22T01:07:14.2663381Z ------------------------------------------
2019-09-22T01:07:14.2663421Z stderr:
2019-09-22T01:07:14.2663421Z stderr:
2019-09-22T01:07:14.2663622Z ------------------------------------------
2019-09-22T01:07:14.2663947Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2664350Z    |
2019-09-22T01:07:14.2664350Z    |
2019-09-22T01:07:14.2664389Z LL | #![plugin(lint_group_plugin_test)]
2019-09-22T01:07:14.2664495Z    |
2019-09-22T01:07:14.2664533Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2664574Z 
2019-09-22T01:07:14.2664574Z 
2019-09-22T01:07:14.2664991Z warning: item is named 'lintme'
2019-09-22T01:07:14.2665261Z    |
2019-09-22T01:07:14.2665261Z    |
2019-09-22T01:07:14.2665482Z LL | fn lintme() { } //~ WARNING item is named 'lintme'
2019-09-22T01:07:14.2665560Z    |
2019-09-22T01:07:14.2665615Z    = note: `#[warn(test_lint)]` on by default
2019-09-22T01:07:14.2665642Z 
2019-09-22T01:07:14.2665642Z 
2019-09-22T01:07:14.2665828Z warning: item is named 'pleaselintme'
2019-09-22T01:07:14.2666095Z    |
2019-09-22T01:07:14.2666095Z    |
2019-09-22T01:07:14.2666305Z LL | fn pleaselintme() { } //~ WARNING item is named 'pleaselintme'
2019-09-22T01:07:14.2666410Z    |
2019-09-22T01:07:14.2666410Z    |
2019-09-22T01:07:14.2666455Z    = note: `#[warn(please_lint)]` on by default
2019-09-22T01:07:14.2666504Z 
2019-09-22T01:07:14.2666722Z ------------------------------------------
2019-09-22T01:07:14.2666751Z 
2019-09-22T01:07:14.2666773Z 
2019-09-22T01:07:14.2666773Z 
2019-09-22T01:07:14.2666979Z ---- [ui] ui-fulldeps/lint-plugin-cmdline-allow.rs stdout ----
2019-09-22T01:07:14.2667038Z diff of stderr:
2019-09-22T01:07:14.2667062Z 
2019-09-22T01:07:14.2667447Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2667680Z +   --> $DIR/lint-plugin-cmdline-allow.rs:8:1
2019-09-22T01:07:14.2667721Z +    |
2019-09-22T01:07:14.2667759Z + LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2667863Z +    |
2019-09-22T01:07:14.2667903Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2667939Z + 
2019-09-22T01:07:14.2667939Z + 
2019-09-22T01:07:14.2668000Z 1 warning: function is never used: `lintme`
2019-09-22T01:07:14.2668249Z 3    |
2019-09-22T01:07:14.2668288Z 
2019-09-22T01:07:14.2668310Z 
2019-09-22T01:07:14.2668349Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2668349Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2668714Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-cmdline-allow/lint-plugin-cmdline-allow.stderr
2019-09-22T01:07:14.2669377Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2669660Z To only update this specific test, also pass `--test-args lint-plugin-cmdline-allow.rs`
2019-09-22T01:07:14.2669759Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2669803Z status: exit code: 0
2019-09-22T01:07:14.2669803Z status: exit code: 0
2019-09-22T01:07:14.2670686Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin-cmdline-allow.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-cmdline-allow/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-A" "test-lint" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-cmdline-allow/auxiliary"
2019-09-22T01:07:14.2671077Z ------------------------------------------
2019-09-22T01:07:14.2671129Z 
2019-09-22T01:07:14.2671353Z ------------------------------------------
2019-09-22T01:07:14.2671399Z stderr:
2019-09-22T01:07:14.2671399Z stderr:
2019-09-22T01:07:14.2671632Z ------------------------------------------
2019-09-22T01:07:14.2672011Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2672636Z    |
2019-09-22T01:07:14.2672636Z    |
2019-09-22T01:07:14.2672674Z LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2672771Z    |
2019-09-22T01:07:14.2672810Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2672835Z 
2019-09-22T01:07:14.2672835Z 
2019-09-22T01:07:14.2672888Z warning: function is never used: `lintme`
2019-09-22T01:07:14.2673157Z    |
2019-09-22T01:07:14.2673157Z    |
2019-09-22T01:07:14.2673193Z LL | fn lintme() { }
2019-09-22T01:07:14.2673280Z    |
2019-09-22T01:07:14.2673316Z note: lint level defined here
2019-09-22T01:07:14.2673551Z   --> /checkout/src/test/ui-fulldeps/lint-plugin-cmdline-allow.rs:7:9
2019-09-22T01:07:14.2673592Z    |
---
2019-09-22T01:07:14.2674049Z 
2019-09-22T01:07:14.2674250Z ---- [ui] ui-fulldeps/lint-plugin-deny-attr.rs stdout ----
2019-09-22T01:07:14.2674465Z diff of stderr:
2019-09-22T01:07:14.2674506Z 
2019-09-22T01:07:14.2674819Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2675042Z +   --> $DIR/lint-plugin-deny-attr.rs:5:1
2019-09-22T01:07:14.2675081Z +    |
2019-09-22T01:07:14.2675117Z + LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2675214Z +    |
2019-09-22T01:07:14.2675252Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2675295Z + 
2019-09-22T01:07:14.2675295Z + 
2019-09-22T01:07:14.2675492Z 1 error: item is named 'lintme'
2019-09-22T01:07:14.2675724Z 3    |
2019-09-22T01:07:14.2675747Z 
2019-09-22T01:07:14.2675784Z 
2019-09-22T01:07:14.2675821Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2675821Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2676094Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-attr/lint-plugin-deny-attr.stderr
2019-09-22T01:07:14.2676324Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2676554Z To only update this specific test, also pass `--test-args lint-plugin-deny-attr.rs`
2019-09-22T01:07:14.2676621Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2676673Z status: exit code: 1
2019-09-22T01:07:14.2676673Z status: exit code: 1
2019-09-22T01:07:14.2677378Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin-deny-attr.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-attr" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-attr/auxiliary" "-A" "unused"
2019-09-22T01:07:14.2677700Z ------------------------------------------
2019-09-22T01:07:14.2677729Z 
2019-09-22T01:07:14.2677931Z ------------------------------------------
2019-09-22T01:07:14.2677970Z stderr:
2019-09-22T01:07:14.2677970Z stderr:
2019-09-22T01:07:14.2678151Z ------------------------------------------
2019-09-22T01:07:14.2678477Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2678843Z    |
2019-09-22T01:07:14.2678843Z    |
2019-09-22T01:07:14.2678880Z LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2679404Z    |
2019-09-22T01:07:14.2679449Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2679480Z 
2019-09-22T01:07:14.2679480Z 
2019-09-22T01:07:14.2679963Z error: item is named 'lintme'
2019-09-22T01:07:14.2680325Z    |
2019-09-22T01:07:14.2680325Z    |
2019-09-22T01:07:14.2680556Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-09-22T01:07:14.2680663Z    |
2019-09-22T01:07:14.2680704Z note: lint level defined here
2019-09-22T01:07:14.2680949Z   --> /checkout/src/test/ui-fulldeps/lint-plugin-deny-attr.rs:6:9
2019-09-22T01:07:14.2681017Z    |
---
2019-09-22T01:07:14.2681564Z 
2019-09-22T01:07:14.2681798Z ---- [ui] ui-fulldeps/lint-plugin-deny-cmdline.rs stdout ----
2019-09-22T01:07:14.2681846Z diff of stderr:
2019-09-22T01:07:14.2681889Z 
2019-09-22T01:07:14.2682262Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2682508Z +   --> $DIR/lint-plugin-deny-cmdline.rs:6:1
2019-09-22T01:07:14.2682573Z +    |
2019-09-22T01:07:14.2682617Z + LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2682728Z +    |
2019-09-22T01:07:14.2682773Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2682824Z + 
2019-09-22T01:07:14.2682824Z + 
2019-09-22T01:07:14.2683054Z 1 error: item is named 'lintme'
2019-09-22T01:07:14.2683630Z 3    |
2019-09-22T01:07:14.2683655Z 
2019-09-22T01:07:14.2683693Z 
2019-09-22T01:07:14.2683734Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2683734Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2684025Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-cmdline/lint-plugin-deny-cmdline.stderr
2019-09-22T01:07:14.2684429Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2684667Z To only update this specific test, also pass `--test-args lint-plugin-deny-cmdline.rs`
2019-09-22T01:07:14.2684735Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2684789Z status: exit code: 1
2019-09-22T01:07:14.2684789Z status: exit code: 1
2019-09-22T01:07:14.2685714Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin-deny-cmdline.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-cmdline" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-D" "test-lint" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-cmdline/auxiliary" "-A" "unused"
2019-09-22T01:07:14.2686058Z ------------------------------------------
2019-09-22T01:07:14.2686087Z 
2019-09-22T01:07:14.2686288Z ------------------------------------------
2019-09-22T01:07:14.2686326Z stderr:
2019-09-22T01:07:14.2686326Z stderr:
2019-09-22T01:07:14.2686506Z ------------------------------------------
2019-09-22T01:07:14.2686833Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2687205Z    |
2019-09-22T01:07:14.2687205Z    |
2019-09-22T01:07:14.2687242Z LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2687342Z    |
2019-09-22T01:07:14.2687380Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2687405Z 
2019-09-22T01:07:14.2687405Z 
2019-09-22T01:07:14.2687605Z error: item is named 'lintme'
2019-09-22T01:07:14.2687874Z    |
2019-09-22T01:07:14.2687874Z    |
2019-09-22T01:07:14.2688066Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-09-22T01:07:14.2688155Z    |
2019-09-22T01:07:14.2688529Z    = note: requested on the command line with `-D test-lint`
2019-09-22T01:07:14.2688558Z 
2019-09-22T01:07:14.2688612Z error: aborting due to previous error
---
2019-09-22T01:07:14.2689293Z 
2019-09-22T01:07:14.2689582Z ---- [ui] ui-fulldeps/lint-plugin-forbid-attrs.rs stdout ----
2019-09-22T01:07:14.2689632Z diff of stderr:
2019-09-22T01:07:14.2689660Z 
2019-09-22T01:07:14.2689718Z 7 LL | #[allow(test_lint)]
2019-09-22T01:07:14.2689764Z 8    |         ^^^^^^^^^ overruled by previous forbid
2019-09-22T01:07:14.2689806Z 9 
2019-09-22T01:07:14.2690201Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2690448Z +   --> $DIR/lint-plugin-forbid-attrs.rs:5:1
2019-09-22T01:07:14.2690511Z +    |
2019-09-22T01:07:14.2690555Z + LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2690648Z +    |
2019-09-22T01:07:14.2690710Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2690753Z + 
2019-09-22T01:07:14.2690753Z + 
2019-09-22T01:07:14.2690966Z 10 error: item is named 'lintme'
2019-09-22T01:07:14.2691265Z 12    |
2019-09-22T01:07:14.2691300Z 
2019-09-22T01:07:14.2691326Z 
2019-09-22T01:07:14.2691386Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2691386Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2691708Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-attrs/lint-plugin-forbid-attrs.stderr
2019-09-22T01:07:14.2691962Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2692249Z To only update this specific test, also pass `--test-args lint-plugin-forbid-attrs.rs`
2019-09-22T01:07:14.2692330Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2692552Z status: exit code: 1
2019-09-22T01:07:14.2692552Z status: exit code: 1
2019-09-22T01:07:14.2693283Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin-forbid-attrs.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-attrs" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-attrs/auxiliary" "-A" "unused"
2019-09-22T01:07:14.2693607Z ------------------------------------------
2019-09-22T01:07:14.2693635Z 
2019-09-22T01:07:14.2694016Z ------------------------------------------
2019-09-22T01:07:14.2694056Z stderr:
2019-09-22T01:07:14.2694056Z stderr:
2019-09-22T01:07:14.2694245Z ------------------------------------------
2019-09-22T01:07:14.2694291Z error[E0453]: allow(test_lint) overruled by outer forbid(test_lint)
2019-09-22T01:07:14.2694575Z    |
2019-09-22T01:07:14.2694575Z    |
2019-09-22T01:07:14.2694611Z LL | #![forbid(test_lint)]
2019-09-22T01:07:14.2695092Z    |           --------- `forbid` level set here
2019-09-22T01:07:14.2695132Z ...
2019-09-22T01:07:14.2695176Z LL | #[allow(test_lint)]
2019-09-22T01:07:14.2695401Z    |         ^^^^^^^^^ overruled by previous forbid
2019-09-22T01:07:14.2695428Z 
2019-09-22T01:07:14.2695753Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2696235Z    |
2019-09-22T01:07:14.2696235Z    |
2019-09-22T01:07:14.2696448Z LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2696552Z    |
2019-09-22T01:07:14.2696592Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2696636Z 
2019-09-22T01:07:14.2696636Z 
2019-09-22T01:07:14.2697021Z error: item is named 'lintme'
2019-09-22T01:07:14.2697464Z    |
2019-09-22T01:07:14.2697464Z    |
2019-09-22T01:07:14.2697870Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-09-22T01:07:14.2697964Z    |
2019-09-22T01:07:14.2698020Z note: lint level defined here
2019-09-22T01:07:14.2701285Z   --> /checkout/src/test/ui-fulldeps/lint-plugin-forbid-attrs.rs:6:11
2019-09-22T01:07:14.2701363Z    |
2019-09-22T01:07:14.2701363Z    |
2019-09-22T01:07:14.2701429Z LL | #![forbid(test_lint)]
2019-09-22T01:07:14.2701503Z 
2019-09-22T01:07:14.2701547Z error: aborting due to 2 previous errors
2019-09-22T01:07:14.2701594Z 
2019-09-22T01:07:14.2701866Z For more information about this error, try `rustc --explain E0453`.
---
2019-09-22T01:07:14.2702594Z ---- [ui] ui-fulldeps/lint-plugin-forbid-cmdline.rs stdout ----
2019-09-22T01:07:14.2702637Z diff of stderr:
2019-09-22T01:07:14.2702677Z 
2019-09-22T01:07:14.2702728Z 6    |
2019-09-22T01:07:14.2702766Z 7    = note: `forbid` lint level was set on command line
2019-09-22T01:07:14.2702809Z 8 
2019-09-22T01:07:14.2703174Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2703391Z +   --> $DIR/lint-plugin-forbid-cmdline.rs:6:1
2019-09-22T01:07:14.2703446Z +    |
2019-09-22T01:07:14.2703483Z + LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2703561Z +    |
2019-09-22T01:07:14.2703616Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2703651Z + 
2019-09-22T01:07:14.2703651Z + 
2019-09-22T01:07:14.2703833Z 9 error: item is named 'lintme'
2019-09-22T01:07:14.2704084Z 11    |
2019-09-22T01:07:14.2704106Z 
2019-09-22T01:07:14.2704128Z 
2019-09-22T01:07:14.2704189Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2704189Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2704813Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-cmdline/lint-plugin-forbid-cmdline.stderr
2019-09-22T01:07:14.2705089Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2705343Z To only update this specific test, also pass `--test-args lint-plugin-forbid-cmdline.rs`
2019-09-22T01:07:14.2705414Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2705452Z status: exit code: 1
2019-09-22T01:07:14.2705452Z status: exit code: 1
2019-09-22T01:07:14.2706154Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin-forbid-cmdline.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-cmdline" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-F" "test-lint" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-cmdline/auxiliary" "-A" "unused"
2019-09-22T01:07:14.2706566Z ------------------------------------------
2019-09-22T01:07:14.2706597Z 
2019-09-22T01:07:14.2706790Z ------------------------------------------
2019-09-22T01:07:14.2706846Z stderr:
2019-09-22T01:07:14.2706846Z stderr:
2019-09-22T01:07:14.2707035Z ------------------------------------------
2019-09-22T01:07:14.2707081Z error[E0453]: allow(test_lint) overruled by outer forbid(test_lint)
2019-09-22T01:07:14.2707365Z    |
2019-09-22T01:07:14.2707365Z    |
2019-09-22T01:07:14.2707408Z LL | #[allow(test_lint)] //~ ERROR allow(test_lint) overruled by outer forbid(test_lint)
2019-09-22T01:07:14.2707471Z    |         ^^^^^^^^^ overruled by previous forbid
2019-09-22T01:07:14.2707510Z    |
2019-09-22T01:07:14.2707556Z    = note: `forbid` lint level was set on command line
2019-09-22T01:07:14.2707600Z 
2019-09-22T01:07:14.2707937Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2708240Z    |
2019-09-22T01:07:14.2708240Z    |
2019-09-22T01:07:14.2708278Z LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2708376Z    |
2019-09-22T01:07:14.2708414Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2708440Z 
2019-09-22T01:07:14.2708440Z 
2019-09-22T01:07:14.2708645Z error: item is named 'lintme'
2019-09-22T01:07:14.2708905Z    |
2019-09-22T01:07:14.2708905Z    |
2019-09-22T01:07:14.2709106Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-09-22T01:07:14.2709209Z    |
2019-09-22T01:07:14.2709417Z    = note: requested on the command line with `-F test-lint`
2019-09-22T01:07:14.2709462Z 
2019-09-22T01:07:14.2709505Z error: aborting due to 2 previous errors
---
2019-09-22T01:07:14.2711179Z 
2019-09-22T01:07:14.2711426Z ---- [ui] ui-fulldeps/lint-plugin.rs stdout ----
2019-09-22T01:07:14.2711475Z diff of stderr:
2019-09-22T01:07:14.2711502Z 
2019-09-22T01:07:14.2711895Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2712129Z +   --> $DIR/lint-plugin.rs:5:1
2019-09-22T01:07:14.2712175Z +    |
2019-09-22T01:07:14.2712218Z + LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2712340Z +    |
2019-09-22T01:07:14.2712512Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2712591Z + 
2019-09-22T01:07:14.2712591Z + 
2019-09-22T01:07:14.2712838Z 1 warning: item is named 'lintme'
2019-09-22T01:07:14.2713114Z 3    |
2019-09-22T01:07:14.2713141Z 
2019-09-22T01:07:14.2713167Z 
2019-09-22T01:07:14.2713211Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2713211Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2713741Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin/lint-plugin.stderr
2019-09-22T01:07:14.2714149Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2714536Z To only update this specific test, also pass `--test-args lint-plugin.rs`
2019-09-22T01:07:14.2714780Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2714818Z status: exit code: 0
2019-09-22T01:07:14.2714818Z status: exit code: 0
2019-09-22T01:07:14.2715438Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin/auxiliary"
2019-09-22T01:07:14.2715989Z ------------------------------------------
2019-09-22T01:07:14.2716035Z 
2019-09-22T01:07:14.2716224Z ------------------------------------------
2019-09-22T01:07:14.2716262Z stderr:
2019-09-22T01:07:14.2716262Z stderr:
2019-09-22T01:07:14.2716459Z ------------------------------------------
2019-09-22T01:07:14.2716772Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2717062Z    |
2019-09-22T01:07:14.2717062Z    |
2019-09-22T01:07:14.2717104Z LL | #![plugin(lint_plugin_test)]
2019-09-22T01:07:14.2717199Z    |
2019-09-22T01:07:14.2717236Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2717261Z 
2019-09-22T01:07:14.2717261Z 
2019-09-22T01:07:14.2717458Z warning: item is named 'lintme'
2019-09-22T01:07:14.2717699Z    |
2019-09-22T01:07:14.2717699Z    |
2019-09-22T01:07:14.2717894Z LL | fn lintme() { } //~ WARNING item is named 'lintme'
2019-09-22T01:07:14.2717984Z    |
2019-09-22T01:07:14.2718021Z    = note: `#[warn(test_lint)]` on by default
2019-09-22T01:07:14.2718063Z 
2019-09-22T01:07:14.2718085Z 
---
2019-09-22T01:07:14.2718609Z 
2019-09-22T01:07:14.2718642Z 2    |
2019-09-22T01:07:14.2718863Z 3    = note: requested on the command line with `-A test_lint`
2019-09-22T01:07:14.2718903Z 4 
2019-09-22T01:07:14.2719819Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2720073Z +   --> $DIR/lint-tool-cmdline-allow.rs:8:1
2019-09-22T01:07:14.2720119Z +    |
2019-09-22T01:07:14.2720179Z + LL | #![plugin(lint_tool_test)]
2019-09-22T01:07:14.2720271Z +    |
2019-09-22T01:07:14.2720315Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2720374Z + 
2019-09-22T01:07:14.2720374Z + 
2019-09-22T01:07:14.2720586Z 5 warning: item is named 'lintme'
2019-09-22T01:07:14.2720885Z 7    |
2019-09-22T01:07:14.2720912Z 
2019-09-22T01:07:14.2720938Z 
2019-09-22T01:07:14.2721094Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2721094Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2721481Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-cmdline-allow/lint-tool-cmdline-allow.stderr
2019-09-22T01:07:14.2721735Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2722004Z To only update this specific test, also pass `--test-args lint-tool-cmdline-allow.rs`
2019-09-22T01:07:14.2722099Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2722143Z status: exit code: 0
2019-09-22T01:07:14.2722143Z status: exit code: 0
2019-09-22T01:07:14.2723045Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-tool-cmdline-allow.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-cmdline-allow/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-A" "test-lint" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-cmdline-allow/auxiliary"
2019-09-22T01:07:14.2723439Z ------------------------------------------
2019-09-22T01:07:14.2723469Z 
2019-09-22T01:07:14.2723656Z ------------------------------------------
2019-09-22T01:07:14.2723695Z stderr:
2019-09-22T01:07:14.2723695Z stderr:
2019-09-22T01:07:14.2723895Z ------------------------------------------
2019-09-22T01:07:14.2723944Z warning: lint name `test_lint` is deprecated and does not have an effect anymore. Use: clippy::test_lint
2019-09-22T01:07:14.2724524Z    = note: requested on the command line with `-A test_lint`
2019-09-22T01:07:14.2724568Z 
2019-09-22T01:07:14.2724568Z 
2019-09-22T01:07:14.2724906Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2725231Z    |
2019-09-22T01:07:14.2725231Z    |
2019-09-22T01:07:14.2725268Z LL | #![plugin(lint_tool_test)]
2019-09-22T01:07:14.2725362Z    |
2019-09-22T01:07:14.2725399Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2725441Z 
2019-09-22T01:07:14.2725441Z 
2019-09-22T01:07:14.2725623Z warning: item is named 'lintme'
2019-09-22T01:07:14.2725875Z    |
2019-09-22T01:07:14.2725875Z    |
2019-09-22T01:07:14.2725926Z LL | fn lintme() {}
2019-09-22T01:07:14.2725994Z    |
2019-09-22T01:07:14.2726047Z    = note: `#[warn(clippy::test_lint)]` on by default
2019-09-22T01:07:14.2726071Z 
2019-09-22T01:07:14.2726071Z 
2019-09-22T01:07:14.2726107Z warning: function is never used: `lintme`
2019-09-22T01:07:14.2726383Z    |
2019-09-22T01:07:14.2726383Z    |
2019-09-22T01:07:14.2726417Z LL | fn lintme() {}
2019-09-22T01:07:14.2726509Z    |
2019-09-22T01:07:14.2726544Z note: lint level defined here
2019-09-22T01:07:14.2726755Z   --> /checkout/src/test/ui-fulldeps/lint-tool-cmdline-allow.rs:7:9
2019-09-22T01:07:14.2726811Z    |
---
2019-09-22T01:07:14.2727221Z 
2019-09-22T01:07:14.2727429Z ---- [ui] ui-fulldeps/lint-tool-test.rs stdout ----
2019-09-22T01:07:14.2727470Z diff of stderr:
2019-09-22T01:07:14.2727492Z 
2019-09-22T01:07:14.2727543Z 32 LL | #![cfg_attr(foo, warn(test_lint))]
2019-09-22T01:07:14.2727594Z 33    |                       ^^^^^^^^^ help: change it to: `clippy::test_lint`
2019-09-22T01:07:14.2727632Z 34 
2019-09-22T01:07:14.2728064Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2728312Z +   --> $DIR/lint-tool-test.rs:6:1
2019-09-22T01:07:14.2728354Z +    |
2019-09-22T01:07:14.2728407Z + LL | #![plugin(lint_tool_test)]
2019-09-22T01:07:14.2728484Z +    |
2019-09-22T01:07:14.2728537Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2728572Z + 
2019-09-22T01:07:14.2728572Z + 
2019-09-22T01:07:14.2728755Z 35 error: item is named 'lintme'
2019-09-22T01:07:14.2729567Z 37    |
2019-09-22T01:07:14.2729594Z 
2019-09-22T01:07:14.2729619Z 
2019-09-22T01:07:14.2729663Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2729663Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2730142Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-test/lint-tool-test.stderr
2019-09-22T01:07:14.2730403Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2730681Z To only update this specific test, also pass `--test-args lint-tool-test.rs`
2019-09-22T01:07:14.2730762Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2730807Z status: exit code: 1
2019-09-22T01:07:14.2730807Z status: exit code: 1
2019-09-22T01:07:14.2731564Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-tool-test.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-test" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "--cfg" "foo" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-test/auxiliary" "-A" "unused"
2019-09-22T01:07:14.2731911Z ------------------------------------------
2019-09-22T01:07:14.2731945Z 
2019-09-22T01:07:14.2732166Z ------------------------------------------
2019-09-22T01:07:14.2732228Z stderr:
2019-09-22T01:07:14.2732228Z stderr:
2019-09-22T01:07:14.2732598Z ------------------------------------------
2019-09-22T01:07:14.2733034Z warning: lint name `test_lint` is deprecated and may not have an effect in the future. Also `cfg_attr(cargo-clippy)` won't be necessary anymore
2019-09-22T01:07:14.2733308Z    |
2019-09-22T01:07:14.2733308Z    |
2019-09-22T01:07:14.2733344Z LL | #![cfg_attr(foo, warn(test_lint))]
2019-09-22T01:07:14.2733402Z    |                       ^^^^^^^^^ help: change it to: `clippy::test_lint`
2019-09-22T01:07:14.2733478Z    = note: `#[warn(renamed_and_removed_lints)]` on by default
2019-09-22T01:07:14.2733503Z 
2019-09-22T01:07:14.2733503Z 
2019-09-22T01:07:14.2733806Z warning: lint name `clippy_group` is deprecated and may not have an effect in the future. Also `cfg_attr(cargo-clippy)` won't be necessary anymore
2019-09-22T01:07:14.2734062Z    |
2019-09-22T01:07:14.2734114Z LL | #![deny(clippy_group)]
2019-09-22T01:07:14.2734114Z LL | #![deny(clippy_group)]
2019-09-22T01:07:14.2734154Z    |         ^^^^^^^^^^^^ help: change it to: `clippy::group`
2019-09-22T01:07:14.2734179Z 
2019-09-22T01:07:14.2734461Z warning: lint name `test_group` is deprecated and may not have an effect in the future. Also `cfg_attr(cargo-clippy)` won't be necessary anymore
2019-09-22T01:07:14.2734712Z    |
2019-09-22T01:07:14.2734712Z    |
2019-09-22T01:07:14.2734768Z LL | #[allow(test_group)]
2019-09-22T01:07:14.2734809Z    |         ^^^^^^^^^^ help: change it to: `clippy::test_group`
2019-09-22T01:07:14.2734834Z 
2019-09-22T01:07:14.2734890Z warning: unknown lint: `this_lint_does_not_exist`
2019-09-22T01:07:14.2735145Z    |
2019-09-22T01:07:14.2735145Z    |
2019-09-22T01:07:14.2735282Z LL | #[deny(this_lint_does_not_exist)] //~ WARNING unknown lint: `this_lint_does_not_exist`
2019-09-22T01:07:14.2735371Z    |
2019-09-22T01:07:14.2735408Z    = note: `#[warn(unknown_lints)]` on by default
2019-09-22T01:07:14.2735453Z 
2019-09-22T01:07:14.2735453Z 
2019-09-22T01:07:14.2735748Z warning: lint name `test_lint` is deprecated and may not have an effect in the future. Also `cfg_attr(cargo-clippy)` won't be necessary anymore
2019-09-22T01:07:14.2736015Z    |
2019-09-22T01:07:14.2736015Z    |
2019-09-22T01:07:14.2736051Z LL | #![cfg_attr(foo, warn(test_lint))]
2019-09-22T01:07:14.2736094Z    |                       ^^^^^^^^^ help: change it to: `clippy::test_lint`
2019-09-22T01:07:14.2736120Z 
2019-09-22T01:07:14.2736456Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2736864Z    |
2019-09-22T01:07:14.2736864Z    |
2019-09-22T01:07:14.2736899Z LL | #![plugin(lint_tool_test)]
2019-09-22T01:07:14.2736993Z    |
2019-09-22T01:07:14.2737030Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2737056Z 
2019-09-22T01:07:14.2737056Z 
2019-09-22T01:07:14.2737235Z error: item is named 'lintme'
2019-09-22T01:07:14.2737495Z    |
2019-09-22T01:07:14.2737495Z    |
2019-09-22T01:07:14.2737690Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-09-22T01:07:14.2737784Z    |
2019-09-22T01:07:14.2737818Z note: lint level defined here
2019-09-22T01:07:14.2738020Z   --> /checkout/src/test/ui-fulldeps/lint-tool-test.rs:11:9
2019-09-22T01:07:14.2738087Z    |
2019-09-22T01:07:14.2738087Z    |
2019-09-22T01:07:14.2738442Z LL | #![deny(clippy_group)]
2019-09-22T01:07:14.2738481Z    |         ^^^^^^^^^^^^
2019-09-22T01:07:14.2738552Z    = note: `#[deny(clippy::test_lint)]` implied by `#[deny(clippy::group)]`
2019-09-22T01:07:14.2738580Z 
2019-09-22T01:07:14.2738799Z error: item is named 'lintmetoo'
2019-09-22T01:07:14.2740053Z    |
2019-09-22T01:07:14.2740053Z    |
2019-09-22T01:07:14.2740354Z LL |     fn lintmetoo() { } //~ ERROR item is named 'lintmetoo'
2019-09-22T01:07:14.2740467Z    |
2019-09-22T01:07:14.2740508Z note: lint level defined here
2019-09-22T01:07:14.2740747Z   --> /checkout/src/test/ui-fulldeps/lint-tool-test.rs:11:9
2019-09-22T01:07:14.2740815Z    |
2019-09-22T01:07:14.2740815Z    |
2019-09-22T01:07:14.2740857Z LL | #![deny(clippy_group)]
2019-09-22T01:07:14.2740899Z    |         ^^^^^^^^^^^^
2019-09-22T01:07:14.2741024Z    = note: `#[deny(clippy::test_group)]` implied by `#[deny(clippy::group)]`
2019-09-22T01:07:14.2741113Z error: aborting due to 2 previous errors
2019-09-22T01:07:14.2741142Z 
2019-09-22T01:07:14.2741175Z 
2019-09-22T01:07:14.2741427Z ------------------------------------------
2019-09-22T01:07:14.2741427Z ------------------------------------------
2019-09-22T01:07:14.2741460Z 
2019-09-22T01:07:14.2741485Z 
2019-09-22T01:07:14.2741710Z ---- [ui] ui-fulldeps/llvm-pass-plugin.rs stdout ----
2019-09-22T01:07:14.2741779Z normalized stderr:
2019-09-22T01:07:14.2742157Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2742458Z    |
2019-09-22T01:07:14.2742458Z    |
2019-09-22T01:07:14.2742500Z LL | #![plugin(llvm_pass_plugin)]
2019-09-22T01:07:14.2742771Z    |
2019-09-22T01:07:14.2742811Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2742837Z 
2019-09-22T01:07:14.2743027Z 
2019-09-22T01:07:14.2743027Z 
2019-09-22T01:07:14.2743076Z 
2019-09-22T01:07:14.2743097Z 
2019-09-22T01:07:14.2743135Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2743531Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/llvm-pass-plugin/llvm-pass-plugin.stderr
2019-09-22T01:07:14.2744029Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2744261Z To only update this specific test, also pass `--test-args llvm-pass-plugin.rs`
2019-09-22T01:07:14.2744350Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2744388Z status: exit code: 0
2019-09-22T01:07:14.2744388Z status: exit code: 0
2019-09-22T01:07:14.2745017Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/llvm-pass-plugin.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/llvm-pass-plugin/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/llvm-pass-plugin/auxiliary"
2019-09-22T01:07:14.2745628Z ------------------------------------------
2019-09-22T01:07:14.2745664Z 
2019-09-22T01:07:14.2745886Z ------------------------------------------
2019-09-22T01:07:14.2745926Z stderr:
2019-09-22T01:07:14.2745926Z stderr:
2019-09-22T01:07:14.2746113Z ------------------------------------------
2019-09-22T01:07:14.2746462Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2746756Z    |
2019-09-22T01:07:14.2746756Z    |
2019-09-22T01:07:14.2746793Z LL | #![plugin(llvm_pass_plugin)]
2019-09-22T01:07:14.2746891Z    |
2019-09-22T01:07:14.2746929Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2746964Z 
2019-09-22T01:07:14.2746987Z 
2019-09-22T01:07:14.2746987Z 
2019-09-22T01:07:14.2747209Z ------------------------------------------
2019-09-22T01:07:14.2747239Z 
2019-09-22T01:07:14.2747261Z 
2019-09-22T01:07:14.2747467Z ---- [ui] ui-fulldeps/lto-syntax-extension.rs stdout ----
2019-09-22T01:07:14.2747531Z normalized stderr:
2019-09-22T01:07:14.2747844Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2748110Z    |
2019-09-22T01:07:14.2748110Z    |
2019-09-22T01:07:14.2748149Z LL | #![plugin(lto_syntax_extension_plugin)]
2019-09-22T01:07:14.2748250Z    |
2019-09-22T01:07:14.2748288Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2748313Z 
2019-09-22T01:07:14.2748335Z 
2019-09-22T01:07:14.2748335Z 
2019-09-22T01:07:14.2748357Z 
2019-09-22T01:07:14.2748405Z 
2019-09-22T01:07:14.2748444Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2748729Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lto-syntax-extension/lto-syntax-extension.stderr
2019-09-22T01:07:14.2749375Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2749652Z To only update this specific test, also pass `--test-args lto-syntax-extension.rs`
2019-09-22T01:07:14.2749732Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2749798Z status: exit code: 0
2019-09-22T01:07:14.2749798Z status: exit code: 0
2019-09-22T01:07:14.2750637Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lto-syntax-extension.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lto-syntax-extension/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-C" "lto" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lto-syntax-extension/auxiliary"
2019-09-22T01:07:14.2751017Z ------------------------------------------
2019-09-22T01:07:14.2751051Z 
2019-09-22T01:07:14.2751291Z ------------------------------------------
2019-09-22T01:07:14.2751337Z stderr:
2019-09-22T01:07:14.2751337Z stderr:
2019-09-22T01:07:14.2751551Z ------------------------------------------
2019-09-22T01:07:14.2751944Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2752283Z    |
2019-09-22T01:07:14.2752283Z    |
2019-09-22T01:07:14.2752587Z LL | #![plugin(lto_syntax_extension_plugin)]
2019-09-22T01:07:14.2752687Z    |
2019-09-22T01:07:14.2752725Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2752839Z 
2019-09-22T01:07:14.2752862Z 
2019-09-22T01:07:14.2752862Z 
2019-09-22T01:07:14.2753084Z ------------------------------------------
2019-09-22T01:07:14.2753135Z 
2019-09-22T01:07:14.2753157Z 
2019-09-22T01:07:14.2753362Z ---- [ui] ui-fulldeps/outlive-expansion-phase.rs stdout ----
2019-09-22T01:07:14.2753405Z normalized stderr:
2019-09-22T01:07:14.2753744Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2754020Z    |
2019-09-22T01:07:14.2754020Z    |
2019-09-22T01:07:14.2754058Z LL | #![plugin(outlive_expansion_phase)]
2019-09-22T01:07:14.2754157Z    |
2019-09-22T01:07:14.2754195Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2754220Z 
2019-09-22T01:07:14.2754242Z 
2019-09-22T01:07:14.2754242Z 
2019-09-22T01:07:14.2754264Z 
2019-09-22T01:07:14.2754312Z 
2019-09-22T01:07:14.2754350Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2754642Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/outlive-expansion-phase/outlive-expansion-phase.stderr
2019-09-22T01:07:14.2754885Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2755117Z To only update this specific test, also pass `--test-args outlive-expansion-phase.rs`
2019-09-22T01:07:14.2755186Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2755243Z status: exit code: 0
2019-09-22T01:07:14.2755243Z status: exit code: 0
2019-09-22T01:07:14.2755891Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/outlive-expansion-phase.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/outlive-expansion-phase/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/outlive-expansion-phase/auxiliary"
2019-09-22T01:07:14.2756190Z ------------------------------------------
2019-09-22T01:07:14.2756220Z 
2019-09-22T01:07:14.2756431Z ------------------------------------------
2019-09-22T01:07:14.2756471Z stderr:
2019-09-22T01:07:14.2756471Z stderr:
2019-09-22T01:07:14.2756657Z ------------------------------------------
2019-09-22T01:07:14.2756991Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2757289Z    |
2019-09-22T01:07:14.2757289Z    |
2019-09-22T01:07:14.2757327Z LL | #![plugin(outlive_expansion_phase)]
2019-09-22T01:07:14.2757428Z    |
2019-09-22T01:07:14.2757473Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2757498Z 
2019-09-22T01:07:14.2757521Z 
2019-09-22T01:07:14.2757521Z 
2019-09-22T01:07:14.2757812Z ------------------------------------------
2019-09-22T01:07:14.2757870Z 
2019-09-22T01:07:14.2757892Z 
2019-09-22T01:07:14.2758115Z ---- [ui] ui-fulldeps/plugin-args-1.rs stdout ----
2019-09-22T01:07:14.2758156Z normalized stderr:
2019-09-22T01:07:14.2758492Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2758697Z   --> $DIR/plugin-args-1.rs:6:1
2019-09-22T01:07:14.2758756Z    |
2019-09-22T01:07:14.2758793Z LL | #![plugin(plugin_args)]
2019-09-22T01:07:14.2759041Z    |
2019-09-22T01:07:14.2759294Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2759324Z 
2019-09-22T01:07:14.2759349Z 
2019-09-22T01:07:14.2759349Z 
2019-09-22T01:07:14.2759375Z 
2019-09-22T01:07:14.2759419Z 
2019-09-22T01:07:14.2759587Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2759970Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-1/plugin-args-1.stderr
2019-09-22T01:07:14.2760250Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2760510Z To only update this specific test, also pass `--test-args plugin-args-1.rs`
2019-09-22T01:07:14.2760589Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2760653Z status: exit code: 0
2019-09-22T01:07:14.2760653Z status: exit code: 0
2019-09-22T01:07:14.2761359Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/plugin-args-1.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-1/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-1/auxiliary"
2019-09-22T01:07:14.2761706Z ------------------------------------------
2019-09-22T01:07:14.2761740Z 
2019-09-22T01:07:14.2761979Z ------------------------------------------
2019-09-22T01:07:14.2762024Z stderr:
2019-09-22T01:07:14.2762024Z stderr:
2019-09-22T01:07:14.2762239Z ------------------------------------------
2019-09-22T01:07:14.2762917Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2763147Z   --> /checkout/src/test/ui-fulldeps/plugin-args-1.rs:6:1
2019-09-22T01:07:14.2763189Z    |
2019-09-22T01:07:14.2763245Z LL | #![plugin(plugin_args)]
2019-09-22T01:07:14.2763323Z    |
2019-09-22T01:07:14.2763380Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2763405Z 
2019-09-22T01:07:14.2763435Z 
2019-09-22T01:07:14.2763435Z 
2019-09-22T01:07:14.2763628Z ------------------------------------------
2019-09-22T01:07:14.2763675Z 
2019-09-22T01:07:14.2763698Z 
2019-09-22T01:07:14.2763903Z ---- [ui] ui-fulldeps/plugin-args-2.rs stdout ----
2019-09-22T01:07:14.2763945Z normalized stderr:
2019-09-22T01:07:14.2764275Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2764479Z   --> $DIR/plugin-args-2.rs:6:1
2019-09-22T01:07:14.2764519Z    |
2019-09-22T01:07:14.2764577Z LL | #![plugin(plugin_args())]
2019-09-22T01:07:14.2764656Z    |
2019-09-22T01:07:14.2764713Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2764738Z 
2019-09-22T01:07:14.2764760Z 
2019-09-22T01:07:14.2764760Z 
2019-09-22T01:07:14.2764782Z 
2019-09-22T01:07:14.2764803Z 
2019-09-22T01:07:14.2764863Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2765140Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-2/plugin-args-2.stderr
2019-09-22T01:07:14.2765444Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2765728Z To only update this specific test, also pass `--test-args plugin-args-2.rs`
2019-09-22T01:07:14.2765801Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2765858Z status: exit code: 0
2019-09-22T01:07:14.2765858Z status: exit code: 0
2019-09-22T01:07:14.2766474Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/plugin-args-2.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-2/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-2/auxiliary"
2019-09-22T01:07:14.2766864Z ------------------------------------------
2019-09-22T01:07:14.2766901Z 
2019-09-22T01:07:14.2767276Z ------------------------------------------
2019-09-22T01:07:14.2767397Z stderr:
2019-09-22T01:07:14.2767397Z stderr:
2019-09-22T01:07:14.2767592Z ------------------------------------------
2019-09-22T01:07:14.2767939Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2768176Z   --> /checkout/src/test/ui-fulldeps/plugin-args-2.rs:6:1
2019-09-22T01:07:14.2768221Z    |
2019-09-22T01:07:14.2768278Z LL | #![plugin(plugin_args())]
2019-09-22T01:07:14.2768360Z    |
2019-09-22T01:07:14.2768419Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2768446Z 
2019-09-22T01:07:14.2768469Z 
2019-09-22T01:07:14.2768469Z 
2019-09-22T01:07:14.2768669Z ------------------------------------------
2019-09-22T01:07:14.2768706Z 
2019-09-22T01:07:14.2768748Z 
2019-09-22T01:07:14.2769495Z ---- [ui] ui-fulldeps/plugin-attr-register-deny.rs stdout ----
2019-09-22T01:07:14.2769658Z diff of stderr:
2019-09-22T01:07:14.2769687Z 
2019-09-22T01:07:14.2770103Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2770354Z +   --> $DIR/plugin-attr-register-deny.rs:5:1
2019-09-22T01:07:14.2770421Z +    |
2019-09-22T01:07:14.2770465Z + LL | #![plugin(attr_plugin_test)]
2019-09-22T01:07:14.2770556Z +    |
2019-09-22T01:07:14.2770620Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2770663Z + 
2019-09-22T01:07:14.2770706Z 1 error: unused attribute
2019-09-22T01:07:14.2770706Z 1 error: unused attribute
2019-09-22T01:07:14.2770953Z 2   --> $DIR/plugin-attr-register-deny.rs:14:5
2019-09-22T01:07:14.2770999Z 3    |
2019-09-22T01:07:14.2771025Z 
2019-09-22T01:07:14.2771051Z 
2019-09-22T01:07:14.2771125Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2771460Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-attr-register-deny/plugin-attr-register-deny.stderr
2019-09-22T01:07:14.2771719Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2772011Z To only update this specific test, also pass `--test-args plugin-attr-register-deny.rs`
2019-09-22T01:07:14.2772091Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2772156Z status: exit code: 1
2019-09-22T01:07:14.2772156Z status: exit code: 1
2019-09-22T01:07:14.2774223Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/plugin-attr-register-deny.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-attr-register-deny" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-attr-register-deny/auxiliary" "-A" "unused"
2019-09-22T01:07:14.2774675Z ------------------------------------------
2019-09-22T01:07:14.2774708Z 
2019-09-22T01:07:14.2774907Z ------------------------------------------
2019-09-22T01:07:14.2774969Z stderr:
2019-09-22T01:07:14.2774969Z stderr:
2019-09-22T01:07:14.2775160Z ------------------------------------------
2019-09-22T01:07:14.2775525Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2775817Z    |
2019-09-22T01:07:14.2775817Z    |
2019-09-22T01:07:14.2775875Z LL | #![plugin(attr_plugin_test)]
2019-09-22T01:07:14.2775955Z    |
2019-09-22T01:07:14.2776116Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2776144Z 
2019-09-22T01:07:14.2776179Z error: unused attribute
---
2019-09-22T01:07:14.2777302Z    |
2019-09-22T01:07:14.2777359Z LL | #![deny(unused_attributes)]
2019-09-22T01:07:14.2777631Z    |         ^^^^^^^^^^^^^^^^^
2019-09-22T01:07:14.2777657Z 
2019-09-22T01:07:14.2777920Z error: crate-level attribute should be an inner attribute: add an exclamation mark: `#![foo]`
2019-09-22T01:07:14.2778599Z    |
2019-09-22T01:07:14.2778647Z LL |     #[bar]
2019-09-22T01:07:14.2778708Z    |     ^^^^^^
2019-09-22T01:07:14.2778734Z 
---
2019-09-22T01:07:14.2780486Z 
2019-09-22T01:07:14.2780527Z 10 LL | pub use mac as reexport;
2019-09-22T01:07:14.2780572Z 11    |         ^^^^^^^^^^^^^^^
2019-09-22T01:07:14.2780632Z 12 
2019-09-22T01:07:14.2781016Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2781299Z +   --> $DIR/plugin-reexport.rs:6:1
2019-09-22T01:07:14.2781348Z +    |
2019-09-22T01:07:14.2781390Z + LL | #![plugin(attr_plugin_test)]
2019-09-22T01:07:14.2781502Z +    |
2019-09-22T01:07:14.2781548Z +    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2781591Z + 
2019-09-22T01:07:14.2781653Z 13 error: aborting due to previous error
2019-09-22T01:07:14.2781653Z 13 error: aborting due to previous error
2019-09-22T01:07:14.2781695Z 14 
2019-09-22T01:07:14.2781949Z 15 For more information about this error, try `rustc --explain E0364`.
2019-09-22T01:07:14.2781984Z 
2019-09-22T01:07:14.2782031Z 
2019-09-22T01:07:14.2782077Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2782384Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-reexport/plugin-reexport.stderr
2019-09-22T01:07:14.2782809Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2783160Z To only update this specific test, also pass `--test-args plugin-reexport.rs`
2019-09-22T01:07:14.2783241Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2783301Z status: exit code: 1
2019-09-22T01:07:14.2783301Z status: exit code: 1
2019-09-22T01:07:14.2784157Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/plugin-reexport.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-reexport" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "--edition=2018" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-reexport/auxiliary" "-A" "unused"
2019-09-22T01:07:14.2784575Z ------------------------------------------
2019-09-22T01:07:14.2784608Z 
2019-09-22T01:07:14.2784837Z ------------------------------------------
2019-09-22T01:07:14.2784878Z stderr:
2019-09-22T01:07:14.2784878Z stderr:
2019-09-22T01:07:14.2785072Z ------------------------------------------
2019-09-22T01:07:14.2785307Z error[E0364]: `mac` is private, and cannot be re-exported
2019-09-22T01:07:14.2785577Z    |
2019-09-22T01:07:14.2785577Z    |
2019-09-22T01:07:14.2785827Z LL | pub use mac as reexport; //~ ERROR `mac` is private, and cannot be re-exported
2019-09-22T01:07:14.2785914Z    |
2019-09-22T01:07:14.2785914Z    |
2019-09-22T01:07:14.2785973Z note: consider marking `mac` as `pub` in the imported module
2019-09-22T01:07:14.2786232Z    |
2019-09-22T01:07:14.2786232Z    |
2019-09-22T01:07:14.2786462Z LL | pub use mac as reexport; //~ ERROR `mac` is private, and cannot be re-exported
2019-09-22T01:07:14.2786562Z 
2019-09-22T01:07:14.2786562Z 
2019-09-22T01:07:14.2786920Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2787202Z    |
2019-09-22T01:07:14.2787202Z    |
2019-09-22T01:07:14.2787261Z LL | #![plugin(attr_plugin_test)]
2019-09-22T01:07:14.2787344Z    |
2019-09-22T01:07:14.2787402Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2787428Z 
2019-09-22T01:07:14.2787466Z error: aborting due to previous error
---
2019-09-22T01:07:14.2787990Z 
2019-09-22T01:07:14.2788013Z 
2019-09-22T01:07:14.2788247Z ---- [ui] ui-fulldeps/plugin-args-3.rs stdout ----
2019-09-22T01:07:14.2788291Z normalized stderr:
2019-09-22T01:07:14.2788620Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2788856Z   --> $DIR/plugin-args-3.rs:6:1
2019-09-22T01:07:14.2788899Z    |
2019-09-22T01:07:14.2788939Z LL | #![plugin(plugin_args(hello(there), how(are="you")))]
2019-09-22T01:07:14.2789410Z    |
2019-09-22T01:07:14.2789454Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2789504Z 
2019-09-22T01:07:14.2789530Z 
2019-09-22T01:07:14.2789530Z 
2019-09-22T01:07:14.2789555Z 
2019-09-22T01:07:14.2789581Z 
2019-09-22T01:07:14.2789626Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2789996Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-3/plugin-args-3.stderr
2019-09-22T01:07:14.2790259Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2790637Z To only update this specific test, also pass `--test-args plugin-args-3.rs`
2019-09-22T01:07:14.2790750Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2790794Z status: exit code: 0
2019-09-22T01:07:14.2790794Z status: exit code: 0
2019-09-22T01:07:14.2791551Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/plugin-args-3.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-3/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-3/auxiliary"
2019-09-22T01:07:14.2791882Z ------------------------------------------
2019-09-22T01:07:14.2792013Z 
2019-09-22T01:07:14.2792263Z ------------------------------------------
2019-09-22T01:07:14.2792309Z stderr:
2019-09-22T01:07:14.2792309Z stderr:
2019-09-22T01:07:14.2792772Z ------------------------------------------
2019-09-22T01:07:14.2793113Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2793370Z   --> /checkout/src/test/ui-fulldeps/plugin-args-3.rs:6:1
2019-09-22T01:07:14.2793416Z    |
2019-09-22T01:07:14.2793456Z LL | #![plugin(plugin_args(hello(there), how(are="you")))]
2019-09-22T01:07:14.2793563Z    |
2019-09-22T01:07:14.2793602Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2793628Z 
2019-09-22T01:07:14.2793670Z 
2019-09-22T01:07:14.2793670Z 
2019-09-22T01:07:14.2793871Z ------------------------------------------
2019-09-22T01:07:14.2793900Z 
2019-09-22T01:07:14.2793923Z 
2019-09-22T01:07:14.2794156Z ---- [ui] ui-fulldeps/roman-numerals-macro.rs stdout ----
2019-09-22T01:07:14.2794200Z normalized stderr:
2019-09-22T01:07:14.2794532Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2794770Z   --> $DIR/roman-numerals-macro.rs:6:1
2019-09-22T01:07:14.2794811Z    |
2019-09-22T01:07:14.2794849Z LL | #![plugin(roman_numerals)]
2019-09-22T01:07:14.2794951Z    |
2019-09-22T01:07:14.2794990Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2795016Z 
2019-09-22T01:07:14.2795059Z 
2019-09-22T01:07:14.2795059Z 
2019-09-22T01:07:14.2795082Z 
2019-09-22T01:07:14.2795104Z 
2019-09-22T01:07:14.2795144Z The actual stderr differed from the expected stderr.
2019-09-22T01:07:14.2795605Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/roman-numerals-macro/roman-numerals-macro.stderr
2019-09-22T01:07:14.2795837Z To update references, rerun the tests and pass the `--bless` flag
2019-09-22T01:07:14.2796070Z To only update this specific test, also pass `--test-args roman-numerals-macro.rs`
2019-09-22T01:07:14.2796157Z error: 1 errors occurred comparing output.
2019-09-22T01:07:14.2796196Z status: exit code: 0
2019-09-22T01:07:14.2796196Z status: exit code: 0
2019-09-22T01:07:14.2796846Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/roman-numerals-macro.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/roman-numerals-macro/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/roman-numerals-macro/auxiliary"
2019-09-22T01:07:14.2797137Z ------------------------------------------
2019-09-22T01:07:14.2797173Z 
2019-09-22T01:07:14.2797365Z ------------------------------------------
2019-09-22T01:07:14.2797497Z stderr:
2019-09-22T01:07:14.2797497Z stderr:
2019-09-22T01:07:14.2797748Z ------------------------------------------
2019-09-22T01:07:14.2798070Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated and will be removed in 1.44.0. See ***/issues/29597
2019-09-22T01:07:14.2798367Z    |
2019-09-22T01:07:14.2798367Z    |
2019-09-22T01:07:14.2798403Z LL | #![plugin(roman_numerals)]
2019-09-22T01:07:14.2798500Z    |
2019-09-22T01:07:14.2798538Z    = note: `#[warn(deprecated)]` on by default
2019-09-22T01:07:14.2798564Z 
2019-09-22T01:07:14.2798605Z 
---
2019-09-22T01:07:14.2805167Z test result: FAILED. 47 passed; 22 failed; 0 ignored; 0 measured; 0 filtered out
2019-09-22T01:07:14.2805199Z 
2019-09-22T01:07:14.2805229Z 
2019-09-22T01:07:14.2805251Z 
2019-09-22T01:07:14.2806655Z command did not execute successfully: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage0-tools-bin/compiletest" "--compile-lib-path" "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/lib" "--run-lib-path" "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/lib/rustlib/x86_64-unknown-linux-gnu/lib" "--rustc-path" "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "--src-base" "/checkout/src/test/ui-fulldeps" "--build-base" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps" "--stage-id" "stage2-x86_64-unknown-linux-gnu" "--mode" "ui" "--target" "x86_64-unknown-linux-gnu" "--host" "x86_64-unknown-linux-gnu" "--llvm-filecheck" "/usr/lib/llvm-6.0/bin/FileCheck" "--host-rustcflags" "-Crpath -O -Cdebuginfo=0 -Zunstable-options  -Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "--target-rustcflags" "-Crpath -O -Cdebuginfo=0 -Zunstable-options  -Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "--docck-python" "/usr/bin/python2.7" "--lldb-python" "/usr/bin/python2.7" "--gdb" "/usr/bin/gdb" "--quiet" "--llvm-version" "6.0.0\n" "--system-llvm" "--cc" "" "--cxx" "" "--cflags" "" "--llvm-components" "" "--llvm-cxxflags" "" "--adb-path" "adb" "--adb-test-dir" "/data/tmp/work" "--android-cross-path" "" "--color" "always"
2019-09-22T01:07:14.2806889Z 
2019-09-22T01:07:14.2806914Z 
2019-09-22T01:07:14.2806976Z failed to run: /checkout/obj/build/bootstrap/debug/bootstrap test
2019-09-22T01:07:14.2807019Z Build completed unsuccessfully in 1:09:28
2019-09-22T01:07:14.2807019Z Build completed unsuccessfully in 1:09:28
2019-09-22T01:07:14.2807175Z == clock drift check ==
2019-09-22T01:07:14.2807216Z   local time: Sun Sep 22 01:07:14 UTC 2019
2019-09-22T01:07:14.3513725Z   network time: Sun, 22 Sep 2019 01:07:14 GMT
2019-09-22T01:07:14.3517165Z == end clock drift check ==
2019-09-22T01:07:15.2810437Z ##[error]Bash exited with code '1'.
2019-09-22T01:07:15.2864406Z ##[section]Starting: Checkout
2019-09-22T01:07:15.2866118Z ==============================================================================
2019-09-22T01:07:15.2866169Z Task         : Get sources
2019-09-22T01:07:15.2866227Z Description  : Get sources from a repository. Supports Git, TfsVC, and SVN repositories.

I'm a bot! I can only do what humans tell me to, so if this was not helpful or you have suggestions for improvements, please ping or otherwise contact @TimNN. (Feature Requests)

@gnzlbg

This comment has been minimized.

Copy link
Contributor

commented Sep 22, 2019

and should give everyone who is still relying on the feature ample time to rid themselves of this dependency.

Do we know who these are and what they are using plugins for? Or could we do a crater run with this set to error to at least find out ?

@Centril

This comment has been minimized.

Copy link
Member Author

commented Sep 22, 2019

Or could we do a crater run with this set to error to at least find out ?

Folks have used it previously for the same thing as proc macros, they've also used it for custom lints and such. In any case, it has been clear for a long long time that this is to be removed eventually.

Also, I think we should use crater more sparingly, at least until we have more crater instances.

@gnzlbg

This comment has been minimized.

Copy link
Contributor

commented Sep 22, 2019

We managed to stop using plugins last december, as alternatives for our use cases became available. That's not that long ago. I think it would make sense to at least try to find out who the current users of plugins are and why and whether they have something they can migrate to.

@Centril

This comment has been minimized.

Copy link
Member Author

commented Sep 23, 2019

Last December was quite a while ago (9 months) and this will take some more 9 months which is quite a while. Most use cases are satisfied by procedural macros and others by what @Mark-Simulacrum noted in #64675 (comment). I also don't think we are obligated to satisfy every and each use case that is covered by plugins. Using crater on this (right now) is in my view a waste of project resources - people can complain by opening issues when they see the warning.

@Mark-Simulacrum

This comment has been minimized.

Copy link
Member

commented Sep 23, 2019

To be clear, I think a crater run on removal makes sense -- that'll be in 6 months I believe -- by then, we'll hopefully be at a point where ~no one who maintains their code at all is using plugins. Any non-maintained code, well, it is an unstable feature for a reason.

@gnzlbg

This comment has been minimized.

Copy link
Contributor

commented Sep 23, 2019

I also don't think we are obligated to satisfy every and each use case that is covered by plugins.

The only thing I'm saying is that in my experience it makes sense to try to figure out who is using a feature and what for before starting the process of removing it, since it's hard to tell whether the "deadline" is appropriately long or short without having this information. For all I know nobody might be using this and a 6 weeks cycle of warnings might be ok.

@Centril

This comment has been minimized.

Copy link
Member Author

commented Sep 23, 2019

For all I know nobody might be using this and a 6 weeks cycle of warnings might be ok.

I would suspect the deadline is possibly too long. A follow up PR can turn these into errors and use that to do a crater run. But I'd like the warnings to be in place sooner rather than later.

@nikomatsakis

This comment has been minimized.

Copy link
Contributor

commented Sep 24, 2019

cc @nox and @SimonSapin -- take a look at this comment by @Mark-Simulacrum, in particular this part:

It might also be worth reaching out to servo directly as they're the ones we're "waiting on" to remove this functionality to make them aware of this timeline. I believe current consensus is that anyone using plugins today is advised to migrate to a custom rustc build (via a rustc_private dep on rustc_interface) which should be relatively fast, though not particularly stable, of course, but no less stable than plugins were/are.

Any thoughts here?

@nox

This comment has been minimized.

Copy link
Contributor

commented Sep 24, 2019

@jdm

This comment has been minimized.

Copy link
Contributor

commented Sep 24, 2019

clippy appears to use plugin_registrar; what's the plan for allowing that popular tool to continue existing?

@oli-obk

This comment has been minimized.

Copy link
Contributor

commented Sep 24, 2019

what's the plan for allowing that popular tool to continue existing?

I've been wanting to nuke that since forever. We're already warning users that the plugin API will disappear since over a year. Clippy works via a custom driver, which is also the proposed solution for servo.

@Manishearth

This comment has been minimized.

Copy link
Member

commented Sep 24, 2019

In any case, it has been clear for a long long time that this is to be removed eventually.

This is not true: Every time this has been brought up Servo has mentioned that it would be pretty hard to move to a custom driver, and discussion AIUI hasn't progressed from there since no replacement was suggested.

The real path out for Servo to get rid of its lints requires significant refactoring to use a lintless GC design, which is on hold for now. An alternate route might be to build this on RLS but it's not 100% clear that that is feasible.

I don't see why this feature so desperately needs to be removed: the internal lint interface is still going to be used by clippy, the only thing you're removing is the ability to externally load lints. Lints are quite useful for usage in a non-release context.

Is there a major cost to keeping this feature around? My read was that it's largely not been a maintenance burden, it just exists without issue.

@nox

This comment has been minimized.

Copy link
Contributor

commented Sep 24, 2019

@Manishearth

This comment has been minimized.

Copy link
Member

commented Sep 24, 2019

Previously there was a plan to add GC integration support to Rust, and that was since scrapped, and one of the reasons we've been okay with that was that we were fine relying on our lints.

@Manishearth

This comment has been minimized.

Copy link
Member

commented Sep 24, 2019

What exactly is a custom driver, and does that mean users can install nightly and compile just the custom driver, or do they end up building a rustc from scratch etc?

@nox @jdm They just compile the custom driver, not all of rustc. But doing so will make other tooling (like RLS) harder to use.

A custom driver is basically a drop-in rustc binary replacement, which is created by copying over rustc's main function and modifying some bits. This is essentially what Clippy is: see https://github.com/rust-lang/rust-clippy/blob/master/src/driver.rs

@Manishearth

This comment has been minimized.

Copy link
Member

commented Sep 24, 2019

Basically, I don't think enough work has been put into custom driver readiness for us to use it. I'd be okay with this if work had been put into making Cargo and RLS better aware of these things, but it hasn't. RLS works with clippy because it directly knows about clippy. And putting that work in is just replacing one less-used feature with another.

@Mark-Simulacrum

This comment has been minimized.

Copy link
Member

commented Sep 24, 2019

To my knowledge, using a custom driver is pretty easy today - it does require nightly (or otherwise bypassing stability...). It does not require a lengthy build process (it's "just" a binary depending on a sysroot crate, like all binaries that depend on std in some way), but does "become" your rustc; you'd use it by override the rustc cargo uses to your own. I believe Servo is already using a custom build tool (similar to x.py here in rust-lang/rust) so that shouldn't be that big of a hassle to do.

I do think making sure that Servo, Clippy have migration paths is necessary, but I don't think we need to do that before we schedule deletion to start in 9 months.

Is there a major cost to keeping this feature around? My read was that it's largely not been a maintenance burden, it just exists without issue.

In my experience, technically, no. However, plugins are somewhat of a hassle to support as they are "late registered" and are dynamically loaded at runtime via dlopen and such all of which is overall quite painful from a maintenance perspective. The late registration in particular has been a thorny issue in a few of the refactors I've been working on -- it's not great that we have to start parsing the crate and only then realize that we have lints and possibly macros that need to be registered via #![plugin(...)]. I believe @petrochenkov's work on cleaning up syntax contexts also wants to see us move away from plugins and the "direct plug" they provide to a TokenStream model.

But doing so [using plugins] will make other tooling (like RLS) harder to use.

I think this is somewhat true, but only marginally so. For the most part, if Servo is using them just for lints, then I would imagine that it would be not too hard to architect that in such a way that the lint warnings simply vanish when using RLS.

@Manishearth

This comment has been minimized.

Copy link
Member

commented Sep 24, 2019

For the most part, if Servo is using them just for lints, then I would imagine that it would be not too hard to architect that in such a way that the lint warnings simply vanish when using RLS.

I think cargo doesn't like it when you swap out compilers that way.

Like, this is buggy. This even is buggy for clippy, and part of the fix was moving cargo-clippy into cargo. Clippy is very much a special case: both RLS and Cargo know about it.

To be clear: we're totally okay with syntax extensions being removed: it's just the plugin lint interface we care about. That doesn't have the parsing lifecycle issues you talk about.

@Mark-Simulacrum

This comment has been minimized.

Copy link
Member

commented Sep 24, 2019

I would be okay deprecating just the plugin attribute then -- if we can make plugins loadable strictly through the CLI then that's already a step forward. -Zextra-plugins works for Servo, right? Y'all can presumably pass it via rustflags and such?

@jdm

This comment has been minimized.

Copy link
Contributor

commented Sep 24, 2019

Yep, extra flags aren't a problem for Servo.

@jdm

This comment has been minimized.

Copy link
Contributor

commented Sep 24, 2019

#62868 also contains a bunch of analysis that @SimonSapin has previously done for Servo's requirements, so we shouldn't need to spend much time rehashing them here.

@Centril

This comment has been minimized.

Copy link
Member Author

commented Oct 3, 2019

I've changed the implementation to use silenceable deprecation warnings and removed the wording regarding schedule for now per the consensus on the last language team meeting. We decided that we should track future work through the compiler team.

(I would like to emphasize that from my perspective, the wish-list in #62868 contains non-starters if they require changes to the language. For example, access to full type information through the compiler would be such a non-starter.)

r? @oli-obk

@rust-highfive rust-highfive assigned oli-obk and unassigned Centril Oct 3, 2019
@Manishearth

This comment has been minimized.

Copy link
Member

commented Oct 3, 2019

I don't understand why we can't just deprecate plugin-loaded syntax extensions for now? They're the ones causing y'all problems, and nobody uses them anymore because proc macros exist.

@Manishearth

This comment has been minimized.

Copy link
Member

commented Oct 3, 2019

Oh, I see, y'all aren't yet planning to remove them, just deprecating them to avoid further use. That's fine.

Could you share more about the consensus reached in the compiler team meeting?

@Centril

This comment has been minimized.

Copy link
Member Author

commented Oct 3, 2019

@Manishearth

Could you share more about the consensus reached in the compiler team meeting?

@rust-highfive

This comment was marked as resolved.

Copy link
Collaborator

commented Oct 3, 2019

The job x86_64-gnu-llvm-6.0 of your PR failed (pretty log, raw log). Through arcane magic we have determined that the following fragments from the build log may contain information about the problem.

Click to expand the log.
2019-10-03T05:04:03.2243003Z ##[command]git remote add origin https://github.com/rust-lang/rust
2019-10-03T05:04:03.2468296Z ##[command]git config gc.auto 0
2019-10-03T05:04:03.2535088Z ##[command]git config --get-all http.https://github.com/rust-lang/rust.extraheader
2019-10-03T05:04:03.2586924Z ##[command]git config --get-all http.proxy
2019-10-03T05:04:03.2730243Z ##[command]git -c http.extraheader="AUTHORIZATION: basic ***" fetch --force --tags --prune --progress --no-recurse-submodules --depth=2 origin +refs/heads/*:refs/remotes/origin/* +refs/pull/64675/merge:refs/remotes/pull/64675/merge
---
2019-10-03T06:08:48.9087753Z .................................................................................................... 1500/9092
2019-10-03T06:08:56.3397753Z .................................................................................................... 1600/9092
2019-10-03T06:09:06.5519328Z .................................................................................................... 1700/9092
2019-10-03T06:09:16.0516777Z ...i...............i................................................................................ 1800/9092
2019-10-03T06:09:24.3454572Z ..............................................................................................iiiii. 1900/9092
2019-10-03T06:09:48.7465730Z .................................................................................................... 2100/9092
2019-10-03T06:09:51.4585673Z .................................................................................................... 2200/9092
2019-10-03T06:09:54.2984360Z .................................................................................................... 2300/9092
2019-10-03T06:10:01.4033495Z .................................................................................................... 2400/9092
---
2019-10-03T06:13:14.4295524Z .................................................................................i...............i.. 4700/9092
2019-10-03T06:13:23.2629664Z .................................................................................................... 4800/9092
2019-10-03T06:13:34.1982705Z .................................................................................................... 4900/9092
2019-10-03T06:13:40.8255431Z .................................................................................................... 5000/9092
2019-10-03T06:13:53.2314231Z .........................................................................ii.ii...................... 5100/9092
2019-10-03T06:14:04.1138394Z .................................................................................................... 5300/9092
2019-10-03T06:14:14.7298483Z .................................................................................................... 5400/9092
2019-10-03T06:14:22.5424239Z .......................................i............................................................ 5500/9092
2019-10-03T06:14:29.6930616Z .................................................................................................... 5600/9092
2019-10-03T06:14:29.6930616Z .................................................................................................... 5600/9092
2019-10-03T06:14:41.6468689Z .................................................................................................... 5700/9092
2019-10-03T06:14:53.4591035Z ....................................ii...i..ii...........i.......................................... 5800/9092
2019-10-03T06:15:17.5316832Z .................................................................................................... 6000/9092
2019-10-03T06:15:27.4389713Z .................................................................................................... 6100/9092
2019-10-03T06:15:27.4389713Z .................................................................................................... 6100/9092
2019-10-03T06:15:44.1869293Z .......................................i..ii........................................................ 6200/9092
2019-10-03T06:16:06.9778188Z ...................................................................................................i 6400/9092
2019-10-03T06:16:09.3729150Z .................................................................................................... 6500/9092
2019-10-03T06:16:11.8753909Z .......................................................................i............................ 6600/9092
2019-10-03T06:16:15.1358702Z .................................................................................................... 6700/9092
---
2019-10-03T06:21:13.5070170Z  finished in 5.989
2019-10-03T06:21:13.5285704Z Check compiletest suite=codegen mode=codegen (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-10-03T06:21:13.7479110Z 
2019-10-03T06:21:13.7479587Z running 150 tests
2019-10-03T06:21:17.2725722Z i....iii......iii..iiii....i.............................i..i..................i....i.........ii.i.i 100/150
2019-10-03T06:21:19.4278979Z ..iiii..............i.........iii.i.......ii......
2019-10-03T06:21:19.4279616Z 
2019-10-03T06:21:19.4294418Z  finished in 5.900
2019-10-03T06:21:19.4525776Z Check compiletest suite=codegen-units mode=codegen-units (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-10-03T06:21:19.6309616Z 
---
2019-10-03T06:21:21.9094095Z  finished in 2.456
2019-10-03T06:21:21.9298698Z Check compiletest suite=assembly mode=assembly (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-10-03T06:21:22.1108869Z 
2019-10-03T06:21:22.1110804Z running 9 tests
2019-10-03T06:21:22.1111679Z iiiiiiiii
2019-10-03T06:21:22.1112075Z 
2019-10-03T06:21:22.1112122Z  finished in 0.181
2019-10-03T06:21:22.1362588Z Check compiletest suite=incremental mode=incremental (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-10-03T06:21:22.3466832Z 
---
2019-10-03T06:21:42.1132168Z  finished in 19.977
2019-10-03T06:21:42.1499073Z Check compiletest suite=debuginfo mode=debuginfo-gdb+lldb (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-10-03T06:21:42.3610808Z 
2019-10-03T06:21:42.3611134Z running 123 tests
2019-10-03T06:22:09.2274650Z .iiiii...i.....i..i...i..i.i.i..i.ii..i.i.....i..i....ii..........iiii..........i...ii...i.......ii. 100/123
2019-10-03T06:22:14.5359866Z i.i.i......iii.i.....ii
2019-10-03T06:22:14.5363319Z 
2019-10-03T06:22:14.5369119Z  finished in 32.386
2019-10-03T06:22:14.5376392Z Uplifting stage1 rustc (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-10-03T06:22:14.5379113Z Copying stage2 rustc from stage1 (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu / x86_64-unknown-linux-gnu)
2019-10-03T06:22:14.5379113Z Copying stage2 rustc from stage1 (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu / x86_64-unknown-linux-gnu)
2019-10-03T06:22:14.5671640Z Check compiletest suite=ui-fulldeps mode=ui (x86_64-unknown-linux-gnu -> x86_64-unknown-linux-gnu)
2019-10-03T06:22:14.7711810Z 
2019-10-03T06:22:14.7712749Z running 69 tests
2019-10-03T06:23:22.9614095Z ........................F.F.......FFFF.F.FFFFFFF..F..F.FF.FFF..F.....
2019-10-03T06:23:22.9614624Z 
2019-10-03T06:23:22.9641420Z ---- [ui] ui-fulldeps/issue-15778-fail.rs stdout ----
2019-10-03T06:23:22.9642038Z diff of stderr:
2019-10-03T06:23:22.9642236Z 
2019-10-03T06:23:22.9642236Z 
2019-10-03T06:23:22.9642928Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9643436Z +   --> $DIR/issue-15778-fail.rs:6:1
2019-10-03T06:23:22.9643636Z +    |
2019-10-03T06:23:22.9643809Z + LL | #![plugin(lint_for_crate)]
2019-10-03T06:23:22.9644138Z +    |
2019-10-03T06:23:22.9644307Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9644458Z + 
2019-10-03T06:23:22.9644458Z + 
2019-10-03T06:23:22.9644613Z 1 error: crate is not marked with #![crate_okay]
2019-10-03T06:23:22.9645190Z 3    |
2019-10-03T06:23:22.9645321Z 
2019-10-03T06:23:22.9645471Z 
2019-10-03T06:23:22.9645632Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9645632Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9646086Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-fail/issue-15778-fail.stderr
2019-10-03T06:23:22.9646527Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9647030Z To only update this specific test, also pass `--test-args issue-15778-fail.rs`
2019-10-03T06:23:22.9647434Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9647612Z status: exit code: 1
2019-10-03T06:23:22.9647612Z status: exit code: 1
2019-10-03T06:23:22.9648578Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/issue-15778-fail.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-fail" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-D" "crate-not-okay" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-fail/auxiliary" "-A" "unused"
2019-10-03T06:23:22.9649256Z ------------------------------------------
2019-10-03T06:23:22.9649433Z 
2019-10-03T06:23:22.9649837Z ------------------------------------------
2019-10-03T06:23:22.9650052Z stderr:
2019-10-03T06:23:22.9650052Z stderr:
2019-10-03T06:23:22.9650436Z ------------------------------------------
2019-10-03T06:23:22.9651189Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9652037Z    |
2019-10-03T06:23:22.9652037Z    |
2019-10-03T06:23:22.9652214Z LL | #![plugin(lint_for_crate)]
2019-10-03T06:23:22.9652525Z    |
2019-10-03T06:23:22.9652698Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9652856Z 
2019-10-03T06:23:22.9652856Z 
2019-10-03T06:23:22.9653010Z error: crate is not marked with #![crate_okay]
2019-10-03T06:23:22.9653629Z    |
2019-10-03T06:23:22.9653629Z    |
2019-10-03T06:23:22.9653786Z LL | / #![feature(plugin)] //~ ERROR crate is not marked with #![crate_okay]
2019-10-03T06:23:22.9654140Z LL | | #![plugin(lint_for_crate)]
2019-10-03T06:23:22.9654442Z LL | | pub fn main() { }
2019-10-03T06:23:22.9654613Z    | |_________________^
2019-10-03T06:23:22.9654770Z    |
2019-10-03T06:23:22.9654770Z    |
2019-10-03T06:23:22.9655187Z    = note: requested on the command line with `-D crate-not-okay`
2019-10-03T06:23:22.9655535Z error: aborting due to previous error
2019-10-03T06:23:22.9655666Z 
2019-10-03T06:23:22.9655814Z 
2019-10-03T06:23:22.9656179Z ------------------------------------------
2019-10-03T06:23:22.9656179Z ------------------------------------------
2019-10-03T06:23:22.9656345Z 
2019-10-03T06:23:22.9656477Z 
2019-10-03T06:23:22.9656897Z ---- [ui] ui-fulldeps/issue-15778-pass.rs stdout ----
2019-10-03T06:23:22.9657904Z normalized stderr:
2019-10-03T06:23:22.9658875Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9659573Z    |
2019-10-03T06:23:22.9659573Z    |
2019-10-03T06:23:22.9659752Z LL | #![plugin(lint_for_crate_rpass)]
2019-10-03T06:23:22.9660092Z    |
2019-10-03T06:23:22.9660301Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9660441Z 
2019-10-03T06:23:22.9660574Z 
2019-10-03T06:23:22.9660574Z 
2019-10-03T06:23:22.9660703Z 
2019-10-03T06:23:22.9660855Z 
2019-10-03T06:23:22.9661009Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9661483Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-pass/issue-15778-pass.stderr
2019-10-03T06:23:22.9661945Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9662384Z To only update this specific test, also pass `--test-args issue-15778-pass.rs`
2019-10-03T06:23:22.9663079Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9663230Z status: exit code: 0
2019-10-03T06:23:22.9663230Z status: exit code: 0
2019-10-03T06:23:22.9664211Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/issue-15778-pass.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-pass/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-D" "crate-not-okay" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-15778-pass/auxiliary"
2019-10-03T06:23:22.9665591Z ------------------------------------------
2019-10-03T06:23:22.9665776Z 
2019-10-03T06:23:22.9666154Z ------------------------------------------
2019-10-03T06:23:22.9666366Z stderr:
2019-10-03T06:23:22.9666366Z stderr:
2019-10-03T06:23:22.9666730Z ------------------------------------------
2019-10-03T06:23:22.9667305Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9668138Z    |
2019-10-03T06:23:22.9668138Z    |
2019-10-03T06:23:22.9668319Z LL | #![plugin(lint_for_crate_rpass)]
2019-10-03T06:23:22.9668861Z    |
2019-10-03T06:23:22.9669042Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9669174Z 
2019-10-03T06:23:22.9669304Z 
2019-10-03T06:23:22.9669304Z 
2019-10-03T06:23:22.9669729Z ------------------------------------------
2019-10-03T06:23:22.9669909Z 
2019-10-03T06:23:22.9670040Z 
2019-10-03T06:23:22.9670426Z ---- [ui] ui-fulldeps/issue-40001.rs stdout ----
2019-10-03T06:23:22.9679669Z normalized stderr:
2019-10-03T06:23:22.9680195Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9680432Z   --> $DIR/issue-40001.rs:6:1
2019-10-03T06:23:22.9680481Z    |
2019-10-03T06:23:22.9680547Z LL | #![plugin(issue_40001_plugin)]
2019-10-03T06:23:22.9680874Z    |
2019-10-03T06:23:22.9680920Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9680970Z 
2019-10-03T06:23:22.9680998Z 
2019-10-03T06:23:22.9680998Z 
2019-10-03T06:23:22.9681024Z 
2019-10-03T06:23:22.9681059Z 
2019-10-03T06:23:22.9681124Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9681462Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-40001/issue-40001.stderr
2019-10-03T06:23:22.9681708Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9683612Z To only update this specific test, also pass `--test-args issue-40001.rs`
2019-10-03T06:23:22.9683718Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9683764Z status: exit code: 0
2019-10-03T06:23:22.9683764Z status: exit code: 0
2019-10-03T06:23:22.9688983Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/issue-40001.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-40001/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/issue-40001/auxiliary"
2019-10-03T06:23:22.9689366Z ------------------------------------------
2019-10-03T06:23:22.9689402Z 
2019-10-03T06:23:22.9689624Z ------------------------------------------
2019-10-03T06:23:22.9689691Z stderr:
2019-10-03T06:23:22.9689691Z stderr:
2019-10-03T06:23:22.9689904Z ------------------------------------------
2019-10-03T06:23:22.9690264Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9690552Z   --> /checkout/src/test/ui-fulldeps/issue-40001.rs:6:1
2019-10-03T06:23:22.9690605Z    |
2019-10-03T06:23:22.9690652Z LL | #![plugin(issue_40001_plugin)]
2019-10-03T06:23:22.9690779Z    |
2019-10-03T06:23:22.9690826Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9690858Z 
2019-10-03T06:23:22.9690912Z 
2019-10-03T06:23:22.9690912Z 
2019-10-03T06:23:22.9691135Z ------------------------------------------
2019-10-03T06:23:22.9691167Z 
2019-10-03T06:23:22.9691193Z 
2019-10-03T06:23:22.9691449Z ---- [ui] ui-fulldeps/lint-group-plugin-deny-cmdline.rs stdout ----
2019-10-03T06:23:22.9691500Z diff of stderr:
2019-10-03T06:23:22.9691529Z 
2019-10-03T06:23:22.9691874Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9692117Z +   --> $DIR/lint-group-plugin-deny-cmdline.rs:6:1
2019-10-03T06:23:22.9692164Z +    |
2019-10-03T06:23:22.9692562Z + LL | #![plugin(lint_group_plugin_test)]
2019-10-03T06:23:22.9692674Z +    |
2019-10-03T06:23:22.9692734Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9692799Z + 
2019-10-03T06:23:22.9692799Z + 
2019-10-03T06:23:22.9693244Z 1 error: item is named 'lintme'
2019-10-03T06:23:22.9694123Z 3    |
2019-10-03T06:23:22.9694151Z 
2019-10-03T06:23:22.9694177Z 
2019-10-03T06:23:22.9702919Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9702919Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9703704Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin-deny-cmdline/lint-group-plugin-deny-cmdline.stderr
2019-10-03T06:23:22.9704062Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9704378Z To only update this specific test, also pass `--test-args lint-group-plugin-deny-cmdline.rs`
2019-10-03T06:23:22.9704492Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9704541Z status: exit code: 1
2019-10-03T06:23:22.9704541Z status: exit code: 1
2019-10-03T06:23:22.9705645Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-group-plugin-deny-cmdline.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin-deny-cmdline" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-D" "lint-me" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin-deny-cmdline/auxiliary" "-A" "unused"
2019-10-03T06:23:22.9706264Z ------------------------------------------
2019-10-03T06:23:22.9706302Z 
2019-10-03T06:23:22.9706546Z ------------------------------------------
2019-10-03T06:23:22.9706616Z stderr:
2019-10-03T06:23:22.9706616Z stderr:
2019-10-03T06:23:22.9706850Z ------------------------------------------
2019-10-03T06:23:22.9707237Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9707623Z    |
2019-10-03T06:23:22.9707623Z    |
2019-10-03T06:23:22.9707680Z LL | #![plugin(lint_group_plugin_test)]
2019-10-03T06:23:22.9707804Z    |
2019-10-03T06:23:22.9707852Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9707903Z 
2019-10-03T06:23:22.9707903Z 
2019-10-03T06:23:22.9708132Z error: item is named 'lintme'
2019-10-03T06:23:22.9708451Z    |
2019-10-03T06:23:22.9708451Z    |
2019-10-03T06:23:22.9708714Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-10-03T06:23:22.9708813Z    |
2019-10-03T06:23:22.9709072Z    = note: `-D test-lint` implied by `-D lint-me`
2019-10-03T06:23:22.9709108Z 
2019-10-03T06:23:22.9709108Z 
2019-10-03T06:23:22.9709333Z error: item is named 'pleaselintme'
2019-10-03T06:23:22.9709681Z    |
2019-10-03T06:23:22.9709681Z    |
2019-10-03T06:23:22.9710244Z LL | fn pleaselintme() { } //~ ERROR item is named 'pleaselintme'
2019-10-03T06:23:22.9710684Z    |
2019-10-03T06:23:22.9710684Z    |
2019-10-03T06:23:22.9710886Z    = note: `-D please-lint` implied by `-D lint-me`
2019-10-03T06:23:22.9710954Z error: aborting due to 2 previous errors
2019-10-03T06:23:22.9710998Z 
2019-10-03T06:23:22.9711020Z 
2019-10-03T06:23:22.9711206Z ------------------------------------------
2019-10-03T06:23:22.9711206Z ------------------------------------------
2019-10-03T06:23:22.9711233Z 
2019-10-03T06:23:22.9711256Z 
2019-10-03T06:23:22.9711468Z ---- [ui] ui-fulldeps/lint-group-plugin.rs stdout ----
2019-10-03T06:23:22.9711511Z diff of stderr:
2019-10-03T06:23:22.9711537Z 
2019-10-03T06:23:22.9711840Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9712422Z +   --> $DIR/lint-group-plugin.rs:6:1
2019-10-03T06:23:22.9712744Z +    |
2019-10-03T06:23:22.9712811Z + LL | #![plugin(lint_group_plugin_test)]
2019-10-03T06:23:22.9713039Z +    |
2019-10-03T06:23:22.9713114Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9713158Z + 
2019-10-03T06:23:22.9713158Z + 
2019-10-03T06:23:22.9716635Z 1 warning: item is named 'lintme'
2019-10-03T06:23:22.9717254Z 3    |
2019-10-03T06:23:22.9717284Z 
2019-10-03T06:23:22.9717312Z 
2019-10-03T06:23:22.9717359Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9717359Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9717689Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin/lint-group-plugin.stderr
2019-10-03T06:23:22.9718336Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9718617Z To only update this specific test, also pass `--test-args lint-group-plugin.rs`
2019-10-03T06:23:22.9718882Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9718928Z status: exit code: 0
2019-10-03T06:23:22.9718928Z status: exit code: 0
2019-10-03T06:23:22.9719851Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-group-plugin.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-group-plugin/auxiliary"
2019-10-03T06:23:22.9721839Z ------------------------------------------
2019-10-03T06:23:22.9721893Z 
2019-10-03T06:23:22.9722795Z ------------------------------------------
2019-10-03T06:23:22.9722882Z stderr:
2019-10-03T06:23:22.9722882Z stderr:
2019-10-03T06:23:22.9723137Z ------------------------------------------
2019-10-03T06:23:22.9725873Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9726721Z    |
2019-10-03T06:23:22.9726721Z    |
2019-10-03T06:23:22.9726767Z LL | #![plugin(lint_group_plugin_test)]
2019-10-03T06:23:22.9726884Z    |
2019-10-03T06:23:22.9726929Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9726981Z 
2019-10-03T06:23:22.9726981Z 
2019-10-03T06:23:22.9727198Z warning: item is named 'lintme'
2019-10-03T06:23:22.9728049Z    |
2019-10-03T06:23:22.9728049Z    |
2019-10-03T06:23:22.9728465Z LL | fn lintme() { } //~ WARNING item is named 'lintme'
2019-10-03T06:23:22.9728724Z    |
2019-10-03T06:23:22.9728787Z    = note: `#[warn(test_lint)]` on by default
2019-10-03T06:23:22.9728825Z 
2019-10-03T06:23:22.9728825Z 
2019-10-03T06:23:22.9729215Z warning: item is named 'pleaselintme'
2019-10-03T06:23:22.9729525Z    |
2019-10-03T06:23:22.9729525Z    |
2019-10-03T06:23:22.9729766Z LL | fn pleaselintme() { } //~ WARNING item is named 'pleaselintme'
2019-10-03T06:23:22.9729877Z    |
2019-10-03T06:23:22.9729877Z    |
2019-10-03T06:23:22.9729923Z    = note: `#[warn(please_lint)]` on by default
2019-10-03T06:23:22.9729979Z 
2019-10-03T06:23:22.9730209Z ------------------------------------------
2019-10-03T06:23:22.9730242Z 
2019-10-03T06:23:22.9730267Z 
2019-10-03T06:23:22.9730267Z 
2019-10-03T06:23:22.9730497Z ---- [ui] ui-fulldeps/lint-plugin-cmdline-allow.rs stdout ----
2019-10-03T06:23:22.9730564Z diff of stderr:
2019-10-03T06:23:22.9730592Z 
2019-10-03T06:23:22.9730978Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9731239Z +   --> $DIR/lint-plugin-cmdline-allow.rs:8:1
2019-10-03T06:23:22.9731297Z +    |
2019-10-03T06:23:22.9731342Z + LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9731634Z +    |
2019-10-03T06:23:22.9731679Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9731722Z + 
2019-10-03T06:23:22.9731722Z + 
2019-10-03T06:23:22.9731788Z 1 warning: function is never used: `lintme`
2019-10-03T06:23:22.9732099Z 3    |
2019-10-03T06:23:22.9732147Z 
2019-10-03T06:23:22.9732174Z 
2019-10-03T06:23:22.9732220Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9732220Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9732933Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-cmdline-allow/lint-plugin-cmdline-allow.stderr
2019-10-03T06:23:22.9733222Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9733486Z To only update this specific test, also pass `--test-args lint-plugin-cmdline-allow.rs`
2019-10-03T06:23:22.9733728Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9733773Z status: exit code: 0
2019-10-03T06:23:22.9733773Z status: exit code: 0
2019-10-03T06:23:22.9734795Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin-cmdline-allow.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-cmdline-allow/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-A" "test-lint" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-cmdline-allow/auxiliary"
2019-10-03T06:23:22.9735140Z ------------------------------------------
2019-10-03T06:23:22.9735193Z 
2019-10-03T06:23:22.9738514Z ------------------------------------------
2019-10-03T06:23:22.9738591Z stderr:
2019-10-03T06:23:22.9738591Z stderr:
2019-10-03T06:23:22.9738829Z ------------------------------------------
2019-10-03T06:23:22.9739189Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9739692Z    |
2019-10-03T06:23:22.9739692Z    |
2019-10-03T06:23:22.9739738Z LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9740045Z    |
2019-10-03T06:23:22.9740087Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9740115Z 
2019-10-03T06:23:22.9740115Z 
2019-10-03T06:23:22.9741891Z warning: function is never used: `lintme`
2019-10-03T06:23:22.9743035Z    |
2019-10-03T06:23:22.9743035Z    |
2019-10-03T06:23:22.9743078Z LL | fn lintme() { }
2019-10-03T06:23:22.9743204Z    |
2019-10-03T06:23:22.9743248Z note: lint level defined here
2019-10-03T06:23:22.9743524Z   --> /checkout/src/test/ui-fulldeps/lint-plugin-cmdline-allow.rs:7:9
2019-10-03T06:23:22.9743574Z    |
---
2019-10-03T06:23:22.9744094Z 
2019-10-03T06:23:22.9744323Z ---- [ui] ui-fulldeps/lint-plugin-deny-attr.rs stdout ----
2019-10-03T06:23:22.9744373Z diff of stderr:
2019-10-03T06:23:22.9744421Z 
2019-10-03T06:23:22.9744783Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9745023Z +   --> $DIR/lint-plugin-deny-attr.rs:5:1
2019-10-03T06:23:22.9745089Z +    |
2019-10-03T06:23:22.9745134Z + LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9745259Z +    |
2019-10-03T06:23:22.9745564Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9745631Z + 
2019-10-03T06:23:22.9745631Z + 
2019-10-03T06:23:22.9746070Z 1 error: item is named 'lintme'
2019-10-03T06:23:22.9746310Z 3    |
2019-10-03T06:23:22.9746335Z 
2019-10-03T06:23:22.9746358Z 
2019-10-03T06:23:22.9746417Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9746417Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9747064Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-attr/lint-plugin-deny-attr.stderr
2019-10-03T06:23:22.9747324Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9747579Z To only update this specific test, also pass `--test-args lint-plugin-deny-attr.rs`
2019-10-03T06:23:22.9747659Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9747820Z status: exit code: 1
2019-10-03T06:23:22.9747820Z status: exit code: 1
2019-10-03T06:23:22.9748570Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin-deny-attr.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-attr" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-attr/auxiliary" "-A" "unused"
2019-10-03T06:23:22.9748891Z ------------------------------------------
2019-10-03T06:23:22.9748923Z 
2019-10-03T06:23:22.9749152Z ------------------------------------------
2019-10-03T06:23:22.9749196Z stderr:
2019-10-03T06:23:22.9749196Z stderr:
2019-10-03T06:23:22.9749399Z ------------------------------------------
2019-10-03T06:23:22.9750073Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9750571Z    |
2019-10-03T06:23:22.9750571Z    |
2019-10-03T06:23:22.9750613Z LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9750882Z    |
2019-10-03T06:23:22.9750945Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9750976Z 
2019-10-03T06:23:22.9750976Z 
2019-10-03T06:23:22.9751178Z error: item is named 'lintme'
2019-10-03T06:23:22.9751654Z    |
2019-10-03T06:23:22.9751654Z    |
2019-10-03T06:23:22.9751879Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-10-03T06:23:22.9752526Z    |
2019-10-03T06:23:22.9752568Z note: lint level defined here
2019-10-03T06:23:22.9752862Z   --> /checkout/src/test/ui-fulldeps/lint-plugin-deny-attr.rs:6:9
2019-10-03T06:23:22.9752942Z    |
---
2019-10-03T06:23:22.9753483Z 
2019-10-03T06:23:22.9753995Z ---- [ui] ui-fulldeps/lint-plugin-deny-cmdline.rs stdout ----
2019-10-03T06:23:22.9754053Z diff of stderr:
2019-10-03T06:23:22.9754103Z 
2019-10-03T06:23:22.9754452Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9754694Z +   --> $DIR/lint-plugin-deny-cmdline.rs:6:1
2019-10-03T06:23:22.9754761Z +    |
2019-10-03T06:23:22.9754807Z + LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9754932Z +    |
2019-10-03T06:23:22.9754979Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9755024Z + 
2019-10-03T06:23:22.9755024Z + 
2019-10-03T06:23:22.9755237Z 1 error: item is named 'lintme'
2019-10-03T06:23:22.9755675Z 3    |
2019-10-03T06:23:22.9755703Z 
2019-10-03T06:23:22.9755729Z 
2019-10-03T06:23:22.9755797Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9755797Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9756143Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-cmdline/lint-plugin-deny-cmdline.stderr
2019-10-03T06:23:22.9756393Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9756680Z To only update this specific test, also pass `--test-args lint-plugin-deny-cmdline.rs`
2019-10-03T06:23:22.9756761Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9756826Z status: exit code: 1
2019-10-03T06:23:22.9756826Z status: exit code: 1
2019-10-03T06:23:22.9758823Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin-deny-cmdline.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-cmdline" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-D" "test-lint" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-deny-cmdline/auxiliary" "-A" "unused"
2019-10-03T06:23:22.9759331Z ------------------------------------------
2019-10-03T06:23:22.9759364Z 
2019-10-03T06:23:22.9760010Z ------------------------------------------
2019-10-03T06:23:22.9760058Z stderr:
2019-10-03T06:23:22.9760058Z stderr:
2019-10-03T06:23:22.9760269Z ------------------------------------------
2019-10-03T06:23:22.9760628Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9760956Z    |
2019-10-03T06:23:22.9760956Z    |
2019-10-03T06:23:22.9761031Z LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9761297Z    |
2019-10-03T06:23:22.9761363Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9761395Z 
2019-10-03T06:23:22.9761395Z 
2019-10-03T06:23:22.9761642Z error: item is named 'lintme'
2019-10-03T06:23:22.9761953Z    |
2019-10-03T06:23:22.9761953Z    |
2019-10-03T06:23:22.9762178Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-10-03T06:23:22.9762287Z    |
2019-10-03T06:23:22.9762758Z    = note: requested on the command line with `-D test-lint`
2019-10-03T06:23:22.9762800Z 
2019-10-03T06:23:22.9762848Z error: aborting due to previous error
---
2019-10-03T06:23:22.9763221Z 
2019-10-03T06:23:22.9763480Z ---- [ui] ui-fulldeps/lint-plugin-forbid-attrs.rs stdout ----
2019-10-03T06:23:22.9763530Z diff of stderr:
2019-10-03T06:23:22.9763559Z 
2019-10-03T06:23:22.9763621Z 7 LL | #[allow(test_lint)]
2019-10-03T06:23:22.9763668Z 8    |         ^^^^^^^^^ overruled by previous forbid
2019-10-03T06:23:22.9763713Z 9 
2019-10-03T06:23:22.9764076Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9764313Z +   --> $DIR/lint-plugin-forbid-attrs.rs:5:1
2019-10-03T06:23:22.9764360Z +    |
2019-10-03T06:23:22.9764425Z + LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9764519Z +    |
2019-10-03T06:23:22.9764583Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9764637Z + 
2019-10-03T06:23:22.9764637Z + 
2019-10-03T06:23:22.9764854Z 10 error: item is named 'lintme'
2019-10-03T06:23:22.9765143Z 12    |
2019-10-03T06:23:22.9765296Z 
2019-10-03T06:23:22.9765330Z 
2019-10-03T06:23:22.9765377Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9765377Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9765743Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-attrs/lint-plugin-forbid-attrs.stderr
2019-10-03T06:23:22.9766197Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9766547Z To only update this specific test, also pass `--test-args lint-plugin-forbid-attrs.rs`
2019-10-03T06:23:22.9766638Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9766688Z status: exit code: 1
2019-10-03T06:23:22.9766688Z status: exit code: 1
2019-10-03T06:23:22.9767488Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin-forbid-attrs.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-attrs" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-attrs/auxiliary" "-A" "unused"
2019-10-03T06:23:22.9767994Z ------------------------------------------
2019-10-03T06:23:22.9768031Z 
2019-10-03T06:23:22.9768265Z ------------------------------------------
2019-10-03T06:23:22.9768335Z stderr:
2019-10-03T06:23:22.9768335Z stderr:
2019-10-03T06:23:22.9768566Z ------------------------------------------
2019-10-03T06:23:22.9768622Z error[E0453]: allow(test_lint) overruled by outer forbid(test_lint)
2019-10-03T06:23:22.9768976Z    |
2019-10-03T06:23:22.9768976Z    |
2019-10-03T06:23:22.9769021Z LL | #![forbid(test_lint)]
2019-10-03T06:23:22.9769284Z    |           --------- `forbid` level set here
2019-10-03T06:23:22.9769333Z ...
2019-10-03T06:23:22.9769389Z LL | #[allow(test_lint)]
2019-10-03T06:23:22.9769439Z    |         ^^^^^^^^^ overruled by previous forbid
2019-10-03T06:23:22.9769494Z 
2019-10-03T06:23:22.9769856Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9770209Z    |
2019-10-03T06:23:22.9770209Z    |
2019-10-03T06:23:22.9770258Z LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9770377Z    |
2019-10-03T06:23:22.9770425Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9770457Z 
2019-10-03T06:23:22.9770457Z 
2019-10-03T06:23:22.9770697Z error: item is named 'lintme'
2019-10-03T06:23:22.9771023Z    |
2019-10-03T06:23:22.9771023Z    |
2019-10-03T06:23:22.9771272Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-10-03T06:23:22.9771396Z    |
2019-10-03T06:23:22.9771443Z note: lint level defined here
2019-10-03T06:23:22.9771727Z   --> /checkout/src/test/ui-fulldeps/lint-plugin-forbid-attrs.rs:6:11
2019-10-03T06:23:22.9771778Z    |
2019-10-03T06:23:22.9771778Z    |
2019-10-03T06:23:22.9771824Z LL | #![forbid(test_lint)]
2019-10-03T06:23:22.9772131Z 
2019-10-03T06:23:22.9772176Z error: aborting due to 2 previous errors
2019-10-03T06:23:22.9772207Z 
2019-10-03T06:23:22.9772619Z For more information about this error, try `rustc --explain E0453`.
---
2019-10-03T06:23:22.9773184Z ---- [ui] ui-fulldeps/lint-plugin-forbid-cmdline.rs stdout ----
2019-10-03T06:23:22.9773244Z diff of stderr:
2019-10-03T06:23:22.9773273Z 
2019-10-03T06:23:22.9773313Z 6    |
2019-10-03T06:23:22.9773378Z 7    = note: `forbid` lint level was set on command line
2019-10-03T06:23:22.9773422Z 8 
2019-10-03T06:23:22.9774142Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9774432Z +   --> $DIR/lint-plugin-forbid-cmdline.rs:6:1
2019-10-03T06:23:22.9774480Z +    |
2019-10-03T06:23:22.9774525Z + LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9774642Z +    |
2019-10-03T06:23:22.9774688Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9774751Z + 
2019-10-03T06:23:22.9774751Z + 
2019-10-03T06:23:22.9774961Z 9 error: item is named 'lintme'
2019-10-03T06:23:22.9775250Z 11    |
2019-10-03T06:23:22.9775278Z 
2019-10-03T06:23:22.9775304Z 
2019-10-03T06:23:22.9775442Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9775442Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9775813Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-cmdline/lint-plugin-forbid-cmdline.stderr
2019-10-03T06:23:22.9776069Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9776356Z To only update this specific test, also pass `--test-args lint-plugin-forbid-cmdline.rs`
2019-10-03T06:23:22.9776461Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9776510Z status: exit code: 1
2019-10-03T06:23:22.9776510Z status: exit code: 1
2019-10-03T06:23:22.9777324Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin-forbid-cmdline.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-cmdline" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-F" "test-lint" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin-forbid-cmdline/auxiliary" "-A" "unused"
2019-10-03T06:23:22.9777683Z ------------------------------------------
2019-10-03T06:23:22.9777719Z 
2019-10-03T06:23:22.9777953Z ------------------------------------------
2019-10-03T06:23:22.9778001Z stderr:
2019-10-03T06:23:22.9778001Z stderr:
2019-10-03T06:23:22.9778252Z ------------------------------------------
2019-10-03T06:23:22.9778308Z error[E0453]: allow(test_lint) overruled by outer forbid(test_lint)
2019-10-03T06:23:22.9778655Z    |
2019-10-03T06:23:22.9778655Z    |
2019-10-03T06:23:22.9778708Z LL | #[allow(test_lint)] //~ ERROR allow(test_lint) overruled by outer forbid(test_lint)
2019-10-03T06:23:22.9778765Z    |         ^^^^^^^^^ overruled by previous forbid
2019-10-03T06:23:22.9778831Z    |
2019-10-03T06:23:22.9778889Z    = note: `forbid` lint level was set on command line
2019-10-03T06:23:22.9778922Z 
2019-10-03T06:23:22.9779308Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9779640Z    |
2019-10-03T06:23:22.9779640Z    |
2019-10-03T06:23:22.9779707Z LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9779804Z    |
2019-10-03T06:23:22.9779871Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9779903Z 
2019-10-03T06:23:22.9779903Z 
2019-10-03T06:23:22.9780124Z error: item is named 'lintme'
2019-10-03T06:23:22.9780454Z    |
2019-10-03T06:23:22.9780454Z    |
2019-10-03T06:23:22.9780696Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-10-03T06:23:22.9780813Z    |
2019-10-03T06:23:22.9781073Z    = note: requested on the command line with `-F test-lint`
2019-10-03T06:23:22.9781110Z 
2019-10-03T06:23:22.9781157Z error: aborting due to 2 previous errors
---
2019-10-03T06:23:22.9782184Z 
2019-10-03T06:23:22.9782448Z ---- [ui] ui-fulldeps/lint-plugin.rs stdout ----
2019-10-03T06:23:22.9782498Z diff of stderr:
2019-10-03T06:23:22.9782547Z 
2019-10-03T06:23:22.9782889Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9783117Z +   --> $DIR/lint-plugin.rs:5:1
2019-10-03T06:23:22.9783184Z +    |
2019-10-03T06:23:22.9783230Z + LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9783480Z +    |
2019-10-03T06:23:22.9783526Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9783569Z + 
2019-10-03T06:23:22.9783569Z + 
2019-10-03T06:23:22.9783825Z 1 warning: item is named 'lintme'
2019-10-03T06:23:22.9784090Z 3    |
2019-10-03T06:23:22.9784117Z 
2019-10-03T06:23:22.9784143Z 
2019-10-03T06:23:22.9784210Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9784210Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9784505Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin/lint-plugin.stderr
2019-10-03T06:23:22.9784772Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9785028Z To only update this specific test, also pass `--test-args lint-plugin.rs`
2019-10-03T06:23:22.9785109Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9785174Z status: exit code: 0
2019-10-03T06:23:22.9785174Z status: exit code: 0
2019-10-03T06:23:22.9785880Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-plugin.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-plugin/auxiliary"
2019-10-03T06:23:22.9786213Z ------------------------------------------
2019-10-03T06:23:22.9786247Z 
2019-10-03T06:23:22.9786480Z ------------------------------------------
2019-10-03T06:23:22.9786527Z stderr:
2019-10-03T06:23:22.9786527Z stderr:
2019-10-03T06:23:22.9786739Z ------------------------------------------
2019-10-03T06:23:22.9787084Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9787394Z    |
2019-10-03T06:23:22.9787394Z    |
2019-10-03T06:23:22.9787459Z LL | #![plugin(lint_plugin_test)]
2019-10-03T06:23:22.9787554Z    |
2019-10-03T06:23:22.9787625Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9787656Z 
2019-10-03T06:23:22.9787656Z 
2019-10-03T06:23:22.9787868Z warning: item is named 'lintme'
2019-10-03T06:23:22.9788163Z    |
2019-10-03T06:23:22.9788163Z    |
2019-10-03T06:23:22.9788389Z LL | fn lintme() { } //~ WARNING item is named 'lintme'
2019-10-03T06:23:22.9788499Z    |
2019-10-03T06:23:22.9788545Z    = note: `#[warn(test_lint)]` on by default
2019-10-03T06:23:22.9788575Z 
2019-10-03T06:23:22.9788601Z 
---
2019-10-03T06:23:22.9789226Z 
2019-10-03T06:23:22.9789266Z 2    |
2019-10-03T06:23:22.9789501Z 3    = note: requested on the command line with `-A test_lint`
2019-10-03T06:23:22.9789656Z 4 
2019-10-03T06:23:22.9790022Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9790256Z +   --> $DIR/lint-tool-cmdline-allow.rs:8:1
2019-10-03T06:23:22.9790324Z +    |
2019-10-03T06:23:22.9790369Z + LL | #![plugin(lint_tool_test)]
2019-10-03T06:23:22.9790484Z +    |
2019-10-03T06:23:22.9790530Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9790573Z + 
2019-10-03T06:23:22.9790573Z + 
2019-10-03T06:23:22.9790802Z 5 warning: item is named 'lintme'
2019-10-03T06:23:22.9791071Z 7    |
2019-10-03T06:23:22.9791098Z 
2019-10-03T06:23:22.9791142Z 
2019-10-03T06:23:22.9791281Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9791281Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9791628Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-cmdline-allow/lint-tool-cmdline-allow.stderr
2019-10-03T06:23:22.9791899Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9792182Z To only update this specific test, also pass `--test-args lint-tool-cmdline-allow.rs`
2019-10-03T06:23:22.9792467Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9792535Z status: exit code: 0
2019-10-03T06:23:22.9792535Z status: exit code: 0
2019-10-03T06:23:22.9793315Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-tool-cmdline-allow.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-cmdline-allow/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-A" "test-lint" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-cmdline-allow/auxiliary"
2019-10-03T06:23:22.9793665Z ------------------------------------------
2019-10-03T06:23:22.9793698Z 
2019-10-03T06:23:22.9793936Z ------------------------------------------
2019-10-03T06:23:22.9793982Z stderr:
2019-10-03T06:23:22.9793982Z stderr:
2019-10-03T06:23:22.9794193Z ------------------------------------------
2019-10-03T06:23:22.9794269Z warning: lint name `test_lint` is deprecated and does not have an effect anymore. Use: clippy::test_lint
2019-10-03T06:23:22.9794555Z    = note: requested on the command line with `-A test_lint`
2019-10-03T06:23:22.9794608Z 
2019-10-03T06:23:22.9794608Z 
2019-10-03T06:23:22.9794941Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9795276Z    |
2019-10-03T06:23:22.9795276Z    |
2019-10-03T06:23:22.9795320Z LL | #![plugin(lint_tool_test)]
2019-10-03T06:23:22.9795437Z    |
2019-10-03T06:23:22.9795491Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9795522Z 
2019-10-03T06:23:22.9795522Z 
2019-10-03T06:23:22.9795730Z warning: item is named 'lintme'
2019-10-03T06:23:22.9796041Z    |
2019-10-03T06:23:22.9796041Z    |
2019-10-03T06:23:22.9796084Z LL | fn lintme() {}
2019-10-03T06:23:22.9796187Z    |
2019-10-03T06:23:22.9796233Z    = note: `#[warn(clippy::test_lint)]` on by default
2019-10-03T06:23:22.9796264Z 
2019-10-03T06:23:22.9796264Z 
2019-10-03T06:23:22.9796327Z warning: function is never used: `lintme`
2019-10-03T06:23:22.9796796Z    |
2019-10-03T06:23:22.9796796Z    |
2019-10-03T06:23:22.9796854Z LL | fn lintme() {}
2019-10-03T06:23:22.9797102Z    |
2019-10-03T06:23:22.9797142Z note: lint level defined here
2019-10-03T06:23:22.9797979Z   --> /checkout/src/test/ui-fulldeps/lint-tool-cmdline-allow.rs:7:9
2019-10-03T06:23:22.9798037Z    |
---
2019-10-03T06:23:22.9798543Z 
2019-10-03T06:23:22.9798569Z 
2019-10-03T06:23:22.9798793Z ---- [ui] ui-fulldeps/llvm-pass-plugin.rs stdout ----
2019-10-03T06:23:22.9798860Z normalized stderr:
2019-10-03T06:23:22.9799189Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9799483Z    |
2019-10-03T06:23:22.9799483Z    |
2019-10-03T06:23:22.9799622Z LL | #![plugin(llvm_pass_plugin)]
2019-10-03T06:23:22.9799739Z    |
2019-10-03T06:23:22.9799791Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9799822Z 
2019-10-03T06:23:22.9799848Z 
2019-10-03T06:23:22.9799848Z 
2019-10-03T06:23:22.9799892Z 
2019-10-03T06:23:22.9799918Z 
2019-10-03T06:23:22.9799963Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9800292Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/llvm-pass-plugin/llvm-pass-plugin.stderr
2019-10-03T06:23:22.9800559Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9800812Z To only update this specific test, also pass `--test-args llvm-pass-plugin.rs`
2019-10-03T06:23:22.9800911Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9800959Z status: exit code: 0
2019-10-03T06:23:22.9800959Z status: exit code: 0
2019-10-03T06:23:22.9802859Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/llvm-pass-plugin.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/llvm-pass-plugin/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/llvm-pass-plugin/auxiliary"
2019-10-03T06:23:22.9803234Z ------------------------------------------
2019-10-03T06:23:22.9803268Z 
2019-10-03T06:23:22.9803508Z ------------------------------------------
2019-10-03T06:23:22.9803555Z stderr:
2019-10-03T06:23:22.9803555Z stderr:
2019-10-03T06:23:22.9803767Z ------------------------------------------
2019-10-03T06:23:22.9804254Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9804589Z    |
2019-10-03T06:23:22.9804589Z    |
2019-10-03T06:23:22.9804633Z LL | #![plugin(llvm_pass_plugin)]
2019-10-03T06:23:22.9804735Z    |
2019-10-03T06:23:22.9804800Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9804832Z 
2019-10-03T06:23:22.9804858Z 
2019-10-03T06:23:22.9804858Z 
2019-10-03T06:23:22.9805078Z ------------------------------------------
2019-10-03T06:23:22.9805128Z 
2019-10-03T06:23:22.9805154Z 
2019-10-03T06:23:22.9805376Z ---- [ui] ui-fulldeps/lint-tool-test.rs stdout ----
2019-10-03T06:23:22.9805426Z diff of stderr:
2019-10-03T06:23:22.9805474Z 
2019-10-03T06:23:22.9805519Z 32 LL | #![cfg_attr(foo, warn(test_lint))]
2019-10-03T06:23:22.9805571Z 33    |                       ^^^^^^^^^ help: change it to: `clippy::test_lint`
2019-10-03T06:23:22.9805634Z 34 
2019-10-03T06:23:22.9805960Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9806200Z +   --> $DIR/lint-tool-test.rs:6:1
2019-10-03T06:23:22.9806267Z +    |
2019-10-03T06:23:22.9806311Z + LL | #![plugin(lint_tool_test)]
2019-10-03T06:23:22.9806596Z +    |
2019-10-03T06:23:22.9806643Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9806687Z + 
2019-10-03T06:23:22.9806687Z + 
2019-10-03T06:23:22.9806927Z 35 error: item is named 'lintme'
2019-10-03T06:23:22.9807209Z 37    |
2019-10-03T06:23:22.9807237Z 
2019-10-03T06:23:22.9807264Z 
2019-10-03T06:23:22.9807489Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9807489Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9808121Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-test/lint-tool-test.stderr
2019-10-03T06:23:22.9808362Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9808880Z To only update this specific test, also pass `--test-args lint-tool-test.rs`
2019-10-03T06:23:22.9809058Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9809123Z status: exit code: 1
2019-10-03T06:23:22.9809123Z status: exit code: 1
2019-10-03T06:23:22.9810239Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lint-tool-test.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-test" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "--cfg" "foo" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lint-tool-test/auxiliary" "-A" "unused"
2019-10-03T06:23:22.9810606Z ------------------------------------------
2019-10-03T06:23:22.9810640Z 
2019-10-03T06:23:22.9810859Z ------------------------------------------
2019-10-03T06:23:22.9810934Z stderr:
2019-10-03T06:23:22.9810934Z stderr:
2019-10-03T06:23:22.9811146Z ------------------------------------------
2019-10-03T06:23:22.9811464Z warning: lint name `test_lint` is deprecated and may not have an effect in the future. Also `cfg_attr(cargo-clippy)` won't be necessary anymore
2019-10-03T06:23:22.9811786Z    |
2019-10-03T06:23:22.9811786Z    |
2019-10-03T06:23:22.9811831Z LL | #![cfg_attr(foo, warn(test_lint))]
2019-10-03T06:23:22.9812232Z    |                       ^^^^^^^^^ help: change it to: `clippy::test_lint`
2019-10-03T06:23:22.9812326Z    = note: `#[warn(renamed_and_removed_lints)]` on by default
2019-10-03T06:23:22.9812376Z 
2019-10-03T06:23:22.9812376Z 
2019-10-03T06:23:22.9812737Z warning: lint name `clippy_group` is deprecated and may not have an effect in the future. Also `cfg_attr(cargo-clippy)` won't be necessary anymore
2019-10-03T06:23:22.9813056Z    |
2019-10-03T06:23:22.9813109Z LL | #![deny(clippy_group)]
2019-10-03T06:23:22.9813109Z LL | #![deny(clippy_group)]
2019-10-03T06:23:22.9813159Z    |         ^^^^^^^^^^^^ help: change it to: `clippy::group`
2019-10-03T06:23:22.9813190Z 
2019-10-03T06:23:22.9813531Z warning: lint name `test_group` is deprecated and may not have an effect in the future. Also `cfg_attr(cargo-clippy)` won't be necessary anymore
2019-10-03T06:23:22.9813822Z    |
2019-10-03T06:23:22.9813822Z    |
2019-10-03T06:23:22.9813884Z LL | #[allow(test_group)]
2019-10-03T06:23:22.9813939Z    |         ^^^^^^^^^^ help: change it to: `clippy::test_group`
2019-10-03T06:23:22.9813972Z 
2019-10-03T06:23:22.9814035Z warning: unknown lint: `this_lint_does_not_exist`
2019-10-03T06:23:22.9814322Z    |
2019-10-03T06:23:22.9814322Z    |
2019-10-03T06:23:22.9814390Z LL | #[deny(this_lint_does_not_exist)] //~ WARNING unknown lint: `this_lint_does_not_exist`
2019-10-03T06:23:22.9814493Z    |
2019-10-03T06:23:22.9814539Z    = note: `#[warn(unknown_lints)]` on by default
2019-10-03T06:23:22.9814647Z 
2019-10-03T06:23:22.9814647Z 
2019-10-03T06:23:22.9815105Z warning: lint name `test_lint` is deprecated and may not have an effect in the future. Also `cfg_attr(cargo-clippy)` won't be necessary anymore
2019-10-03T06:23:22.9815795Z    |
2019-10-03T06:23:22.9815795Z    |
2019-10-03T06:23:22.9815839Z LL | #![cfg_attr(foo, warn(test_lint))]
2019-10-03T06:23:22.9815890Z    |                       ^^^^^^^^^ help: change it to: `clippy::test_lint`
2019-10-03T06:23:22.9815923Z 
2019-10-03T06:23:22.9816568Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9816898Z    |
2019-10-03T06:23:22.9816898Z    |
2019-10-03T06:23:22.9816942Z LL | #![plugin(lint_tool_test)]
2019-10-03T06:23:22.9817197Z    |
2019-10-03T06:23:22.9817243Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9817275Z 
2019-10-03T06:23:22.9817275Z 
2019-10-03T06:23:22.9817518Z error: item is named 'lintme'
2019-10-03T06:23:22.9817822Z    |
2019-10-03T06:23:22.9817822Z    |
2019-10-03T06:23:22.9818047Z LL | fn lintme() { } //~ ERROR item is named 'lintme'
2019-10-03T06:23:22.9818159Z    |
2019-10-03T06:23:22.9818201Z note: lint level defined here
2019-10-03T06:23:22.9818436Z   --> /checkout/src/test/ui-fulldeps/lint-tool-test.rs:11:9
2019-10-03T06:23:22.9818502Z    |
2019-10-03T06:23:22.9818502Z    |
2019-10-03T06:23:22.9818544Z LL | #![deny(clippy_group)]
2019-10-03T06:23:22.9818589Z    |         ^^^^^^^^^^^^
2019-10-03T06:23:22.9818656Z    = note: `#[deny(clippy::test_lint)]` implied by `#[deny(clippy::group)]`
2019-10-03T06:23:22.9818689Z 
2019-10-03T06:23:22.9818899Z error: item is named 'lintmetoo'
2019-10-03T06:23:22.9819211Z    |
2019-10-03T06:23:22.9819211Z    |
2019-10-03T06:23:22.9819447Z LL |     fn lintmetoo() { } //~ ERROR item is named 'lintmetoo'
2019-10-03T06:23:22.9819567Z    |
2019-10-03T06:23:22.9819610Z note: lint level defined here
2019-10-03T06:23:22.9819845Z   --> /checkout/src/test/ui-fulldeps/lint-tool-test.rs:11:9
2019-10-03T06:23:22.9819911Z    |
2019-10-03T06:23:22.9819911Z    |
2019-10-03T06:23:22.9819953Z LL | #![deny(clippy_group)]
2019-10-03T06:23:22.9819997Z    |         ^^^^^^^^^^^^
2019-10-03T06:23:22.9820047Z    = note: `#[deny(clippy::test_group)]` implied by `#[deny(clippy::group)]`
2019-10-03T06:23:22.9820142Z error: aborting due to 2 previous errors
2019-10-03T06:23:22.9820171Z 
2019-10-03T06:23:22.9820197Z 
2019-10-03T06:23:22.9820432Z ------------------------------------------
2019-10-03T06:23:22.9820432Z ------------------------------------------
2019-10-03T06:23:22.9820463Z 
2019-10-03T06:23:22.9820488Z 
2019-10-03T06:23:22.9820714Z ---- [ui] ui-fulldeps/lto-syntax-extension.rs stdout ----
2019-10-03T06:23:22.9820790Z normalized stderr:
2019-10-03T06:23:22.9821133Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9821431Z    |
2019-10-03T06:23:22.9821431Z    |
2019-10-03T06:23:22.9821478Z LL | #![plugin(lto_syntax_extension_plugin)]
2019-10-03T06:23:22.9821595Z    |
2019-10-03T06:23:22.9821640Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9821670Z 
2019-10-03T06:23:22.9821696Z 
2019-10-03T06:23:22.9821696Z 
2019-10-03T06:23:22.9821740Z 
2019-10-03T06:23:22.9821767Z 
2019-10-03T06:23:22.9822028Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9822385Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lto-syntax-extension/lto-syntax-extension.stderr
2019-10-03T06:23:22.9822656Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9822929Z To only update this specific test, also pass `--test-args lto-syntax-extension.rs`
2019-10-03T06:23:22.9823169Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9823226Z status: exit code: 0
2019-10-03T06:23:22.9823226Z status: exit code: 0
2019-10-03T06:23:22.9823964Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/lto-syntax-extension.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lto-syntax-extension/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-C" "lto" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/lto-syntax-extension/auxiliary"
2019-10-03T06:23:22.9824294Z ------------------------------------------
2019-10-03T06:23:22.9824431Z 
2019-10-03T06:23:22.9824693Z ------------------------------------------
2019-10-03T06:23:22.9824740Z stderr:
2019-10-03T06:23:22.9824740Z stderr:
2019-10-03T06:23:22.9824953Z ------------------------------------------
2019-10-03T06:23:22.9825320Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9825652Z    |
2019-10-03T06:23:22.9825652Z    |
2019-10-03T06:23:22.9825697Z LL | #![plugin(lto_syntax_extension_plugin)]
2019-10-03T06:23:22.9825813Z    |
2019-10-03T06:23:22.9825860Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9825890Z 
2019-10-03T06:23:22.9825918Z 
2019-10-03T06:23:22.9825918Z 
2019-10-03T06:23:22.9826137Z ------------------------------------------
2019-10-03T06:23:22.9826188Z 
2019-10-03T06:23:22.9826214Z 
2019-10-03T06:23:22.9826444Z ---- [ui] ui-fulldeps/outlive-expansion-phase.rs stdout ----
2019-10-03T06:23:22.9826503Z normalized stderr:
2019-10-03T06:23:22.9826844Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9827151Z    |
2019-10-03T06:23:22.9827151Z    |
2019-10-03T06:23:22.9827196Z LL | #![plugin(outlive_expansion_phase)]
2019-10-03T06:23:22.9827308Z    |
2019-10-03T06:23:22.9827354Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9827384Z 
2019-10-03T06:23:22.9827411Z 
2019-10-03T06:23:22.9827411Z 
2019-10-03T06:23:22.9827436Z 
2019-10-03T06:23:22.9827479Z 
2019-10-03T06:23:22.9827525Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9827847Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/outlive-expansion-phase/outlive-expansion-phase.stderr
2019-10-03T06:23:22.9828114Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9828408Z To only update this specific test, also pass `--test-args outlive-expansion-phase.rs`
2019-10-03T06:23:22.9828495Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9828570Z status: exit code: 0
2019-10-03T06:23:22.9828570Z status: exit code: 0
2019-10-03T06:23:22.9829321Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/outlive-expansion-phase.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/outlive-expansion-phase/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/outlive-expansion-phase/auxiliary"
2019-10-03T06:23:22.9829989Z ------------------------------------------
2019-10-03T06:23:22.9830019Z 
2019-10-03T06:23:22.9830406Z ------------------------------------------
2019-10-03T06:23:22.9830447Z stderr:
2019-10-03T06:23:22.9830447Z stderr:
2019-10-03T06:23:22.9830792Z ------------------------------------------
2019-10-03T06:23:22.9831168Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9831488Z    |
2019-10-03T06:23:22.9831488Z    |
2019-10-03T06:23:22.9831527Z LL | #![plugin(outlive_expansion_phase)]
2019-10-03T06:23:22.9831609Z    |
2019-10-03T06:23:22.9831665Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9831692Z 
2019-10-03T06:23:22.9831713Z 
2019-10-03T06:23:22.9831713Z 
2019-10-03T06:23:22.9832078Z ------------------------------------------
2019-10-03T06:23:22.9832124Z 
2019-10-03T06:23:22.9832147Z 
2019-10-03T06:23:22.9833002Z ---- [ui] ui-fulldeps/plugin-args-1.rs stdout ----
2019-10-03T06:23:22.9833059Z normalized stderr:
2019-10-03T06:23:22.9833612Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9833843Z   --> $DIR/plugin-args-1.rs:6:1
2019-10-03T06:23:22.9833923Z    |
2019-10-03T06:23:22.9833968Z LL | #![plugin(plugin_args)]
2019-10-03T06:23:22.9834060Z    |
2019-10-03T06:23:22.9834125Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9834156Z 
2019-10-03T06:23:22.9834182Z 
2019-10-03T06:23:22.9834182Z 
2019-10-03T06:23:22.9834207Z 
2019-10-03T06:23:22.9834232Z 
2019-10-03T06:23:22.9834295Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9834599Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-1/plugin-args-1.stderr
2019-10-03T06:23:22.9834842Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9835113Z To only update this specific test, also pass `--test-args plugin-args-1.rs`
2019-10-03T06:23:22.9835202Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9835264Z status: exit code: 0
2019-10-03T06:23:22.9835264Z status: exit code: 0
2019-10-03T06:23:22.9835980Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/plugin-args-1.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-1/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-1/auxiliary"
2019-10-03T06:23:22.9836307Z ------------------------------------------
2019-10-03T06:23:22.9836341Z 
2019-10-03T06:23:22.9836554Z ------------------------------------------
2019-10-03T06:23:22.9836620Z stderr:
2019-10-03T06:23:22.9836620Z stderr:
2019-10-03T06:23:22.9836832Z ------------------------------------------
2019-10-03T06:23:22.9837189Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9837450Z   --> /checkout/src/test/ui-fulldeps/plugin-args-1.rs:6:1
2019-10-03T06:23:22.9837502Z    |
2019-10-03T06:23:22.9837565Z LL | #![plugin(plugin_args)]
2019-10-03T06:23:22.9837658Z    |
2019-10-03T06:23:22.9837722Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9837753Z 
2019-10-03T06:23:22.9837779Z 
2019-10-03T06:23:22.9837779Z 
2019-10-03T06:23:22.9837999Z ------------------------------------------
2019-10-03T06:23:22.9838030Z 
2019-10-03T06:23:22.9838075Z 
2019-10-03T06:23:22.9838296Z ---- [ui] ui-fulldeps/plugin-args-2.rs stdout ----
2019-10-03T06:23:22.9838345Z normalized stderr:
2019-10-03T06:23:22.9838682Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9838904Z   --> $DIR/plugin-args-2.rs:6:1
2019-10-03T06:23:22.9838960Z    |
2019-10-03T06:23:22.9839023Z LL | #![plugin(plugin_args())]
2019-10-03T06:23:22.9839214Z    |
2019-10-03T06:23:22.9839267Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9839318Z 
2019-10-03T06:23:22.9839344Z 
2019-10-03T06:23:22.9839344Z 
2019-10-03T06:23:22.9839370Z 
2019-10-03T06:23:22.9839395Z 
2019-10-03T06:23:22.9839442Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9839784Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-2/plugin-args-2.stderr
2019-10-03T06:23:22.9840029Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9840297Z To only update this specific test, also pass `--test-args plugin-args-2.rs`
2019-10-03T06:23:22.9840378Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9840424Z status: exit code: 0
2019-10-03T06:23:22.9840424Z status: exit code: 0
2019-10-03T06:23:22.9841695Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/plugin-args-2.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-2/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-2/auxiliary"
2019-10-03T06:23:22.9842395Z ------------------------------------------
2019-10-03T06:23:22.9842436Z 
2019-10-03T06:23:22.9842656Z ------------------------------------------
2019-10-03T06:23:22.9842721Z stderr:
2019-10-03T06:23:22.9842721Z stderr:
2019-10-03T06:23:22.9842936Z ------------------------------------------
2019-10-03T06:23:22.9843276Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9843564Z   --> /checkout/src/test/ui-fulldeps/plugin-args-2.rs:6:1
2019-10-03T06:23:22.9843616Z    |
2019-10-03T06:23:22.9843661Z LL | #![plugin(plugin_args())]
2019-10-03T06:23:22.9843783Z    |
2019-10-03T06:23:22.9843829Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9843860Z 
2019-10-03T06:23:22.9843905Z 
2019-10-03T06:23:22.9843905Z 
2019-10-03T06:23:22.9844125Z ------------------------------------------
2019-10-03T06:23:22.9844157Z 
2019-10-03T06:23:22.9844182Z 
2019-10-03T06:23:22.9844435Z ---- [ui] ui-fulldeps/plugin-attr-register-deny.rs stdout ----
2019-10-03T06:23:22.9844485Z diff of stderr:
2019-10-03T06:23:22.9844513Z 
2019-10-03T06:23:22.9844856Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9845093Z +   --> $DIR/plugin-attr-register-deny.rs:5:1
2019-10-03T06:23:22.9845140Z +    |
2019-10-03T06:23:22.9845204Z + LL | #![plugin(attr_plugin_test)]
2019-10-03T06:23:22.9845310Z +    |
2019-10-03T06:23:22.9845363Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9845426Z + 
2019-10-03T06:23:22.9845470Z 1 error: unused attribute
2019-10-03T06:23:22.9845470Z 1 error: unused attribute
2019-10-03T06:23:22.9845703Z 2   --> $DIR/plugin-attr-register-deny.rs:14:5
2019-10-03T06:23:22.9845791Z 3    |
2019-10-03T06:23:22.9845818Z 
2019-10-03T06:23:22.9845844Z 
2019-10-03T06:23:22.9845889Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9846550Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-attr-register-deny/plugin-attr-register-deny.stderr
2019-10-03T06:23:22.9846801Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9847066Z To only update this specific test, also pass `--test-args plugin-attr-register-deny.rs`
2019-10-03T06:23:22.9847167Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9847221Z status: exit code: 1
2019-10-03T06:23:22.9847221Z status: exit code: 1
2019-10-03T06:23:22.9848756Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/plugin-attr-register-deny.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-attr-register-deny" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-attr-register-deny/auxiliary" "-A" "unused"
2019-10-03T06:23:22.9849288Z ------------------------------------------
2019-10-03T06:23:22.9849322Z 
2019-10-03T06:23:22.9849682Z ------------------------------------------
2019-10-03T06:23:22.9849725Z stderr:
2019-10-03T06:23:22.9849725Z stderr:
2019-10-03T06:23:22.9850167Z ------------------------------------------
2019-10-03T06:23:22.9850810Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9851135Z    |
2019-10-03T06:23:22.9851135Z    |
2019-10-03T06:23:22.9851176Z LL | #![plugin(attr_plugin_test)]
2019-10-03T06:23:22.9851284Z    |
2019-10-03T06:23:22.9851327Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9851355Z 
2019-10-03T06:23:22.9851413Z error: unused attribute
---
2019-10-03T06:23:22.9852848Z    |
2019-10-03T06:23:22.9852892Z LL | #![deny(unused_attributes)]
2019-10-03T06:23:22.9852960Z    |         ^^^^^^^^^^^^^^^^^
2019-10-03T06:23:22.9852989Z 
2019-10-03T06:23:22.9853268Z error: crate-level attribute should be an inner attribute: add an exclamation mark: `#![foo]`
2019-10-03T06:23:22.9853587Z    |
2019-10-03T06:23:22.9853629Z LL |     #[bar]
2019-10-03T06:23:22.9853671Z    |     ^^^^^^
2019-10-03T06:23:22.9853718Z 
---
2019-10-03T06:23:22.9854920Z 
2019-10-03T06:23:22.9854982Z 10 LL | pub use mac as reexport;
2019-10-03T06:23:22.9855027Z 11    |         ^^^^^^^^^^^^^^^
2019-10-03T06:23:22.9855070Z 12 
2019-10-03T06:23:22.9855427Z + warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9855657Z +   --> $DIR/plugin-reexport.rs:6:1
2019-10-03T06:23:22.9855704Z +    |
2019-10-03T06:23:22.9855768Z + LL | #![plugin(attr_plugin_test)]
2019-10-03T06:23:22.9855862Z +    |
2019-10-03T06:23:22.9855927Z +    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9855972Z + 
2019-10-03T06:23:22.9856018Z 13 error: aborting due to previous error
2019-10-03T06:23:22.9856018Z 13 error: aborting due to previous error
2019-10-03T06:23:22.9856089Z 14 
2019-10-03T06:23:22.9856342Z 15 For more information about this error, try `rustc --explain E0364`.
2019-10-03T06:23:22.9856377Z 
2019-10-03T06:23:22.9856404Z 
2019-10-03T06:23:22.9856577Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9856937Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-reexport/plugin-reexport.stderr
2019-10-03T06:23:22.9857181Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9857452Z To only update this specific test, also pass `--test-args plugin-reexport.rs`
2019-10-03T06:23:22.9857535Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9857581Z status: exit code: 1
2019-10-03T06:23:22.9857581Z status: exit code: 1
2019-10-03T06:23:22.9858350Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/plugin-reexport.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "--out-dir" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-reexport" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "--edition=2018" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-reexport/auxiliary" "-A" "unused"
2019-10-03T06:23:22.9858789Z ------------------------------------------
2019-10-03T06:23:22.9858823Z 
2019-10-03T06:23:22.9859041Z ------------------------------------------
2019-10-03T06:23:22.9859107Z stderr:
2019-10-03T06:23:22.9859107Z stderr:
2019-10-03T06:23:22.9859319Z ------------------------------------------
2019-10-03T06:23:22.9859733Z error[E0364]: `mac` is private, and cannot be re-exported
2019-10-03T06:23:22.9869022Z    |
2019-10-03T06:23:22.9869022Z    |
2019-10-03T06:23:22.9869642Z LL | pub use mac as reexport; //~ ERROR `mac` is private, and cannot be re-exported
2019-10-03T06:23:22.9869829Z    |
2019-10-03T06:23:22.9869829Z    |
2019-10-03T06:23:22.9869879Z note: consider marking `mac` as `pub` in the imported module
2019-10-03T06:23:22.9870231Z    |
2019-10-03T06:23:22.9870231Z    |
2019-10-03T06:23:22.9870489Z LL | pub use mac as reexport; //~ ERROR `mac` is private, and cannot be re-exported
2019-10-03T06:23:22.9870598Z 
2019-10-03T06:23:22.9870598Z 
2019-10-03T06:23:22.9870974Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9871305Z    |
2019-10-03T06:23:22.9871305Z    |
2019-10-03T06:23:22.9871350Z LL | #![plugin(attr_plugin_test)]
2019-10-03T06:23:22.9871465Z    |
2019-10-03T06:23:22.9871510Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9871553Z 
2019-10-03T06:23:22.9871597Z error: aborting due to previous error
---
2019-10-03T06:23:22.9872505Z 
2019-10-03T06:23:22.9872532Z 
2019-10-03T06:23:22.9872757Z ---- [ui] ui-fulldeps/plugin-args-3.rs stdout ----
2019-10-03T06:23:22.9872807Z normalized stderr:
2019-10-03T06:23:22.9873166Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9873395Z   --> $DIR/plugin-args-3.rs:6:1
2019-10-03T06:23:22.9873462Z    |
2019-10-03T06:23:22.9873511Z LL | #![plugin(plugin_args(hello(there), how(are="you")))]
2019-10-03T06:23:22.9873635Z    |
2019-10-03T06:23:22.9873680Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9873722Z 
2019-10-03T06:23:22.9873748Z 
2019-10-03T06:23:22.9873748Z 
2019-10-03T06:23:22.9873774Z 
2019-10-03T06:23:22.9873817Z 
2019-10-03T06:23:22.9874104Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9874468Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-3/plugin-args-3.stderr
2019-10-03T06:23:22.9874740Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9875042Z To only update this specific test, also pass `--test-args plugin-args-3.rs`
2019-10-03T06:23:22.9875134Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9875203Z status: exit code: 0
2019-10-03T06:23:22.9875203Z status: exit code: 0
2019-10-03T06:23:22.9875949Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/plugin-args-3.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-3/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/plugin-args-3/auxiliary"
2019-10-03T06:23:22.9876459Z ------------------------------------------
2019-10-03T06:23:22.9876657Z 
2019-10-03T06:23:22.9876888Z ------------------------------------------
2019-10-03T06:23:22.9876932Z stderr:
2019-10-03T06:23:22.9876932Z stderr:
2019-10-03T06:23:22.9877132Z ------------------------------------------
2019-10-03T06:23:22.9877663Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9877893Z   --> /checkout/src/test/ui-fulldeps/plugin-args-3.rs:6:1
2019-10-03T06:23:22.9877939Z    |
2019-10-03T06:23:22.9878000Z LL | #![plugin(plugin_args(hello(there), how(are="you")))]
2019-10-03T06:23:22.9878100Z    |
2019-10-03T06:23:22.9878159Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9878187Z 
2019-10-03T06:23:22.9878210Z 
2019-10-03T06:23:22.9878210Z 
2019-10-03T06:23:22.9878418Z ------------------------------------------
2019-10-03T06:23:22.9878466Z 
2019-10-03T06:23:22.9878489Z 
2019-10-03T06:23:22.9878885Z ---- [ui] ui-fulldeps/roman-numerals-macro.rs stdout ----
2019-10-03T06:23:22.9878933Z normalized stderr:
2019-10-03T06:23:22.9879267Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9879490Z   --> $DIR/roman-numerals-macro.rs:6:1
2019-10-03T06:23:22.9879555Z    |
2019-10-03T06:23:22.9879598Z LL | #![plugin(roman_numerals)]
2019-10-03T06:23:22.9879689Z    |
2019-10-03T06:23:22.9879751Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9879781Z 
2019-10-03T06:23:22.9879806Z 
2019-10-03T06:23:22.9879806Z 
2019-10-03T06:23:22.9879839Z 
2019-10-03T06:23:22.9879864Z 
2019-10-03T06:23:22.9879930Z The actual stderr differed from the expected stderr.
2019-10-03T06:23:22.9880407Z Actual stderr saved to /checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/roman-numerals-macro/roman-numerals-macro.stderr
2019-10-03T06:23:22.9880659Z To update references, rerun the tests and pass the `--bless` flag
2019-10-03T06:23:22.9880946Z To only update this specific test, also pass `--test-args roman-numerals-macro.rs`
2019-10-03T06:23:22.9881027Z error: 1 errors occurred comparing output.
2019-10-03T06:23:22.9881454Z status: exit code: 0
2019-10-03T06:23:22.9881454Z status: exit code: 0
2019-10-03T06:23:22.9882762Z command: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "/checkout/src/test/ui-fulldeps/roman-numerals-macro.rs" "-Zthreads=1" "--target=x86_64-unknown-linux-gnu" "--error-format" "json" "-Zui-testing" "-C" "prefer-dynamic" "-o" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/roman-numerals-macro/a" "-Crpath" "-O" "-Cdebuginfo=0" "-Zunstable-options" "-Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "-L" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps/roman-numerals-macro/auxiliary"
2019-10-03T06:23:22.9883171Z ------------------------------------------
2019-10-03T06:23:22.9883207Z 
2019-10-03T06:23:22.9883446Z ------------------------------------------
2019-10-03T06:23:22.9883493Z stderr:
2019-10-03T06:23:22.9883493Z stderr:
2019-10-03T06:23:22.9883706Z ------------------------------------------
2019-10-03T06:23:22.9884070Z warning: use of deprecated attribute `plugin`: compiler plugins are deprecated. See ***/issues/29597
2019-10-03T06:23:22.9884386Z    |
2019-10-03T06:23:22.9884386Z    |
2019-10-03T06:23:22.9884450Z LL | #![plugin(roman_numerals)]
2019-10-03T06:23:22.9884545Z    |
2019-10-03T06:23:22.9884609Z    = note: `#[warn(deprecated)]` on by default
2019-10-03T06:23:22.9884748Z 
2019-10-03T06:23:22.9884775Z 
---
2019-10-03T06:23:22.9890835Z test result: FAILED. 47 passed; 22 failed; 0 ignored; 0 measured; 0 filtered out
2019-10-03T06:23:22.9890868Z 
2019-10-03T06:23:22.9890911Z 
2019-10-03T06:23:22.9890934Z 
2019-10-03T06:23:22.9893152Z command did not execute successfully: "/checkout/obj/build/x86_64-unknown-linux-gnu/stage0-tools-bin/compiletest" "--compile-lib-path" "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/lib" "--run-lib-path" "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/lib/rustlib/x86_64-unknown-linux-gnu/lib" "--rustc-path" "/checkout/obj/build/x86_64-unknown-linux-gnu/stage2/bin/rustc" "--src-base" "/checkout/src/test/ui-fulldeps" "--build-base" "/checkout/obj/build/x86_64-unknown-linux-gnu/test/ui-fulldeps" "--stage-id" "stage2-x86_64-unknown-linux-gnu" "--mode" "ui" "--target" "x86_64-unknown-linux-gnu" "--host" "x86_64-unknown-linux-gnu" "--llvm-filecheck" "/usr/lib/llvm-6.0/bin/FileCheck" "--host-rustcflags" "-Crpath -O -Cdebuginfo=0 -Zunstable-options  -Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "--target-rustcflags" "-Crpath -O -Cdebuginfo=0 -Zunstable-options  -Lnative=/checkout/obj/build/x86_64-unknown-linux-gnu/native/rust-test-helpers" "--docck-python" "/usr/bin/python2.7" "--lldb-python" "/usr/bin/python2.7" "--gdb" "/usr/bin/gdb" "--quiet" "--llvm-version" "6.0.0\n" "--system-llvm" "--cc" "" "--cxx" "" "--cflags" "" "--llvm-components" "" "--llvm-cxxflags" "" "--adb-path" "adb" "--adb-test-dir" "/data/tmp/work" "--android-cross-path" "" "--color" "always"
2019-10-03T06:23:22.9893445Z 
2019-10-03T06:23:22.9893475Z 
2019-10-03T06:23:22.9893523Z failed to run: /checkout/obj/build/bootstrap/debug/bootstrap test
2019-10-03T06:23:22.9893595Z Build completed unsuccessfully in 1:11:57
2019-10-03T06:23:22.9893595Z Build completed unsuccessfully in 1:11:57
2019-10-03T06:23:22.9893713Z == clock drift check ==
2019-10-03T06:23:22.9893844Z   local time: Thu Oct  3 06:23:22 UTC 2019
2019-10-03T06:23:23.1194758Z   network time: Thu, 03 Oct 2019 06:23:23 GMT
2019-10-03T06:23:23.1195348Z == end clock drift check ==
2019-10-03T06:23:23.7378173Z ##[error]Bash exited with code '1'.
2019-10-03T06:23:23.7456405Z ##[section]Starting: Checkout
2019-10-03T06:23:23.7458712Z ==============================================================================
2019-10-03T06:23:23.7458775Z Task         : Get sources
2019-10-03T06:23:23.7458824Z Description  : Get sources from a repository. Supports Git, TfsVC, and SVN repositories.

I'm a bot! I can only do what humans tell me to, so if this was not helpful or you have suggestions for improvements, please ping or otherwise contact @TimNN. (Feature Requests)

@oli-obk

This comment has been minimized.

Copy link
Contributor

commented Oct 3, 2019

r=me with tests updated to pass ci

@Centril Centril removed the I-nominated label Oct 3, 2019
@Centril

This comment has been minimized.

Copy link
Member Author

commented Oct 3, 2019

@bors r=oli-obk

@bors

This comment has been minimized.

Copy link
Contributor

commented Oct 3, 2019

📌 Commit d1f95ef has been approved by oli-obk

Centril added a commit to Centril/rust that referenced this pull request Oct 3, 2019
Deprecate `#![plugin]` & `#[plugin_registrar]`

This PR deprecates `#![plugin]` and `#[plugin_registrar]`.

~A removal deadline is set: 1.44.0. This will be in 9 months from now and should give everyone who is still relying on the feature ample time to rid themselves of this dependency.~

cc rust-lang#29597

r? @Mark-Simulacrum
bors added a commit that referenced this pull request Oct 3, 2019
Rollup of 10 pull requests

Successful merges:

 - #61879 (Stabilize todo macro)
 - #64675 (Deprecate `#![plugin]` & `#[plugin_registrar]`)
 - #64706 (add regression test for #60218)
 - #64741 (Prevent rustdoc feature doctests)
 - #65004 (Replace mentions of IRC with Discord)
 - #65020 (Always mark rust and rust-call abi's as unwind)
 - #65026 (metadata: Some crate loading cleanup)
 - #65055 (Add long error explanation for E0556)
 - #65056 (Make visit projection iterative)
 - #65057 (typo: fix typo in E0392)

Failed merges:

r? @ghost
Centril added a commit to Centril/rust that referenced this pull request Oct 3, 2019
Deprecate `#![plugin]` & `#[plugin_registrar]`

This PR deprecates `#![plugin]` and `#[plugin_registrar]`.

~A removal deadline is set: 1.44.0. This will be in 9 months from now and should give everyone who is still relying on the feature ample time to rid themselves of this dependency.~

cc rust-lang#29597

r? @Mark-Simulacrum
bors added a commit that referenced this pull request Oct 3, 2019
Rollup of 11 pull requests

Successful merges:

 - #61879 (Stabilize todo macro)
 - #64675 (Deprecate `#![plugin]` & `#[plugin_registrar]`)
 - #64690 (proc_macro API: Expose `macro_rules` hygiene)
 - #64706 (add regression test for #60218)
 - #64741 (Prevent rustdoc feature doctests)
 - #64842 (Disallow Self in type param defaults of ADTs)
 - #65004 (Replace mentions of IRC with Discord)
 - #65020 (Always mark rust and rust-call abi's as unwind)
 - #65055 (Add long error explanation for E0556)
 - #65056 (Make visit projection iterative)
 - #65057 (typo: fix typo in E0392)

Failed merges:

r? @ghost
tmandry added a commit to tmandry/rust that referenced this pull request Oct 3, 2019
Deprecate `#![plugin]` & `#[plugin_registrar]`

This PR deprecates `#![plugin]` and `#[plugin_registrar]`.

~A removal deadline is set: 1.44.0. This will be in 9 months from now and should give everyone who is still relying on the feature ample time to rid themselves of this dependency.~

cc rust-lang#29597

r? @Mark-Simulacrum
bors added a commit that referenced this pull request Oct 3, 2019
Rollup of 12 pull requests

Successful merges:

 - #61879 (Stabilize todo macro)
 - #64675 (Deprecate `#![plugin]` & `#[plugin_registrar]`)
 - #64690 (proc_macro API: Expose `macro_rules` hygiene)
 - #64706 (add regression test for #60218)
 - #64741 (Prevent rustdoc feature doctests)
 - #64842 (Disallow Self in type param defaults of ADTs)
 - #65004 (Replace mentions of IRC with Discord)
 - #65018 (Set RUST_BACKTRACE=0 in tests that include a backtrace in stderr)
 - #65037 (`#[track_caller]` feature gate (RFC 2091))
 - #65055 (Add long error explanation for E0556)
 - #65056 (Make visit projection iterative)
 - #65057 (typo: fix typo in E0392)

Failed merges:

r? @ghost
tmandry added a commit to tmandry/rust that referenced this pull request Oct 3, 2019
Deprecate `#![plugin]` & `#[plugin_registrar]`

This PR deprecates `#![plugin]` and `#[plugin_registrar]`.

~A removal deadline is set: 1.44.0. This will be in 9 months from now and should give everyone who is still relying on the feature ample time to rid themselves of this dependency.~

cc rust-lang#29597

r? @Mark-Simulacrum
bors added a commit that referenced this pull request Oct 3, 2019
Rollup of 11 pull requests

Successful merges:

 - #61879 (Stabilize todo macro)
 - #64675 (Deprecate `#![plugin]` & `#[plugin_registrar]`)
 - #64690 (proc_macro API: Expose `macro_rules` hygiene)
 - #64706 (add regression test for #60218)
 - #64741 (Prevent rustdoc feature doctests)
 - #64842 (Disallow Self in type param defaults of ADTs)
 - #65004 (Replace mentions of IRC with Discord)
 - #65018 (Set RUST_BACKTRACE=0 in tests that include a backtrace in stderr)
 - #65055 (Add long error explanation for E0556)
 - #65056 (Make visit projection iterative)
 - #65057 (typo: fix typo in E0392)

Failed merges:

r? @ghost
@bors bors merged commit d1f95ef into rust-lang:master Oct 4, 2019
4 checks passed
4 checks passed
pr Build #20191003.32 succeeded
Details
pr (Linux mingw-check) Linux mingw-check succeeded
Details
pr (Linux x86_64-gnu-llvm-6.0) Linux x86_64-gnu-llvm-6.0 succeeded
Details
pr (LinuxTools) LinuxTools succeeded
Details
@Centril Centril deleted the Centril:deprecate-plugin branch Oct 4, 2019
@jplatte jplatte referenced this pull request Oct 12, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
You can’t perform that action at this time.