đź’» CLI to generate base project to start developing APIs with TypeScript.
JavaScript
Switch branches/tags
Nothing to show
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
media
src
.babelrc
.gitignore
.npmignore
LICENSE
README.md
package-lock.json
package.json
yarn.lock

README.md

create-typescript-api

CLI to generate a base project based on typescript-hapi-starter.

License: MIT npm version npm downloads

NPM NPM

Installation

YARN

yarn add create-typescript-api

NPM

npm install --save create-typescript-api

Usage

cli-usage

TODO

  • Install package.json dependencies
  • Enable check-list to get starter project from different branches: 'Mongoose', 'Sequelize', 'GraphQL'

Issues

If you found a bug, or you have an answer, or whatever. Please, open an issue. We will do our best to fix it.

Contributing

Of course, if you see something that you want to upgrade from this library, or a bug that needs to be solved, PRs are welcome!

License

Distributed under the MIT license. See LICENSE for more information.