Replies: 10 comments 17 replies
|
The menu entry on webif is missing when "rc.dnsmasq load" was not executed. This is done by multid wrapper very early. Maybe you have some not included webifs / addons? |
|
I have the same problem. What do I have to do? BTW: I've used a config that is working with DnsMasq and 7.56. but for 7.57 not. Thanks. |
|
7.56 and 7.57 have very few differences, which should not be related to dns. So you erroro repors dont make sense |
|
Same problem here with the exact same error (rc.dnsmasq start --> dnsmasq: failed to bind DHCP server socket: Address already in use). |
|
So somehow, "rc.dnsmasq load" is not or not correctly executed on our Boxes. Are there any logfiles where this execution can be tracked? In [/var/log/mod.log] or [/var/log/mod_load.log] I don't see anything related to dnsmasq. Edit: I found a forum post with the exact same error description "dnsmasq not loading/preset; dnsmasq Webif entry missing" from the 25th of august. Edit: the version from the forum post is "ng-22301-93bac00d5" |
|
Update: I did some testing with old commits. The problem first occured after the commits from august 21th. If you want to test it yourself: "git checkout 5874b50" dnsmasq is working (august 20th)) "git checkout f30b726" dnsmasq is not working (august 21th) There were changes on the multid wrapper at this time. |
|
I think I found the problem. In the patchfile "106-wrapper_avm.sh" there is a line which checks for the existence of a file (dsld, multid, rextd) under "build/modified/filesystem/usr/bin/wrapper/". But none of the files seem to be there at that time and the loop never continues for any of these. So the following steps won't execute and the "${FILESYSTEM_MOD_DIR}/lib/systemd/system/multid.service" file won't get patched. You can check it on your freetz box: "less /lib/systemd/system/multid.service" On a working system the line is: So if you remove the line in the "/patches/scripts/106-wrapper_avm.sh" file, everything should work again. I just flashed the newst build with the edited file and dnsmasq is working for me again. |
|
Thanks for your investigation, I think you write about 106aa7d |
Maybe you should read the logfile/syslog output |

Uh oh!
There was an error while loading. Please reload this page.
Hi,
I just updated my Freetz image to the newest build freetz-ng-22375MF-4542d10bb for the 7590 7.57 from my old 7.50 freetz build. I didn't change anything in the configuration but nevertheless rerun "make menuconfig".
Everything works fine and the same like in my previous build, except from dnsmasq. The dnsmasq configuration entry in the webinterface is missing and the dnsmasq service is not shown under services in the webif.
Under Mod-Info, dnsmasq is listed under Packages.
I tried to start the service manually via "rc.dnsmasq start" but get the error:
root@fritzbox:/etc/init.d# rc.dnsmasq start
Starting Dnsmasq ...
dnsmasq: failed to bind DHCP server socket: Address already in use
failed.
So it seems like there is a problem with the multid DNS/DHCP interfering with dnsmasq again in the new version. I selected "Disabled multid's DNS/DHCP" in "make menuconfig".
All reactions