New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Failed at the phantomjs@1.9.17 install script 'node install.js'. #344

Closed
polinac opened this Issue May 22, 2015 · 17 comments

Comments

Projects
None yet
7 participants
@polinac

polinac commented May 22, 2015

I run 'npm instal'l for https://github.com/linnovate/mean.git. I have Windows 8.1. I got error:


Failed at the phantomjs@1.9.17 install script 'node install.js'.
This is most likely a problem with the phantomjs package,

not with npm itself.

I can upload npm-debug.log where you can accept it.
Can you please help me to resolve this?
capture

@tomatau

This comment has been minimized.

Show comment
Hide comment
@tomatau

tomatau May 29, 2015

same error on jenkins just working from an npm install of phantomjs2

npm ERR! Linux 3.13.0-36-generic
npm ERR! argv "/var/lib/jenkins/.nvm/versions/node/v0.12.1/bin/node" "/var/lib/jenkins/.nvm/versions/node/v0.12.1/bin/npm" "install"
npm ERR! node v0.12.1
npm ERR! npm  v2.5.1
npm ERR! code ELIFECYCLE

npm ERR! phantomjs2@2.0.0 install: `node install.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the phantomjs2@2.0.0 install script 'node install.js'.
npm ERR! This is most likely a problem with the phantomjs2 package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node install.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls phantomjs2
npm ERR! There is likely additional logging output above.

tomatau commented May 29, 2015

same error on jenkins just working from an npm install of phantomjs2

npm ERR! Linux 3.13.0-36-generic
npm ERR! argv "/var/lib/jenkins/.nvm/versions/node/v0.12.1/bin/node" "/var/lib/jenkins/.nvm/versions/node/v0.12.1/bin/npm" "install"
npm ERR! node v0.12.1
npm ERR! npm  v2.5.1
npm ERR! code ELIFECYCLE

npm ERR! phantomjs2@2.0.0 install: `node install.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the phantomjs2@2.0.0 install script 'node install.js'.
npm ERR! This is most likely a problem with the phantomjs2 package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node install.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls phantomjs2
npm ERR! There is likely additional logging output above.
@nicks

This comment has been minimized.

Show comment
Hide comment
@nicks

nicks May 29, 2015

Contributor

this report does not include any meaningful logs or repro steps. if you want us to look into this, you'll have to include the logs.

Contributor

nicks commented May 29, 2015

this report does not include any meaningful logs or repro steps. if you want us to look into this, you'll have to include the logs.

@polinac

This comment has been minimized.

Show comment
Hide comment
@polinac

polinac May 29, 2015

Hm. Something changed in the opensource world. I just run npm install again and it completed without errors.

polinac commented May 29, 2015

Hm. Something changed in the opensource world. I just run npm install again and it completed without errors.

@nicks

This comment has been minimized.

Show comment
Hide comment
@nicks

nicks May 29, 2015

Contributor

probably a transient network error

Contributor

nicks commented May 29, 2015

probably a transient network error

@nicks nicks closed this May 29, 2015

@polinac

This comment has been minimized.

Show comment
Hide comment
@polinac

polinac May 29, 2015

Anyway, thank you for looking into this.

polinac commented May 29, 2015

Anyway, thank you for looking into this.

@sethburtonhall

This comment has been minimized.

Show comment
Hide comment
@sethburtonhall

sethburtonhall Jun 2, 2015

I am still having this error every time I run npm install

$ phantomjs -v
1.9.1

but it seems I need 1.9.17 but not sure how to upgrade to that version

> phantomjs@1.9.17 install /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-iconify/node_modules/gulp-svg2png/node_modules/svg2png/node_modules/phantomjs
> node install.js

PhantomJS detected, but wrong version 1.9.1 @ /opt/boxen/nodenv/versions/v0.10.5/bin/phantomjs.
Downloading https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-macosx.zip
Saving to /var/folders/81/jglkvkm16jdcw9494_lkvpr40000gn/T/phantomjs/phantomjs-1.9.8-macosx.zip
Using npmconf ca
Receiving...
|
Error making request.
Error: CERT_UNTRUSTED
    at SecurePair.<anonymous> (tls.js:1283:32)
    at SecurePair.EventEmitter.emit (events.js:92:17)
    at SecurePair.maybeInitFinished (tls.js:896:10)
    at CleartextStream.read [as _read] (tls.js:430:15)
    at CleartextStream.Readable.read (_stream_readable.js:304:10)
    at EncryptedStream.write [as _write] (tls.js:344:25)
    at doWrite (_stream_writable.js:211:10)
    at writeOrBuffer (_stream_writable.js:201:5)
    at EncryptedStream.Writable.write (_stream_writable.js:172:11)
    at write (_stream_readable.js:557:24)

Please report this full log at https://github.com/Medium/phantomjs

> node-sass@1.2.3 install /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-sass/node_modules/node-sass
> node scripts/install.js

Binary downloaded and installed at /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-sass/node_modules/node-sass/vendor/darwin-x64/binding.node

> node-sass@2.1.1 install /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-iconify/node_modules/gulp-sass/node_modules/node-sass
> node scripts/install.js


> node-sass@1.2.3 postinstall /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-sass/node_modules/node-sass
> node scripts/build.js

`darwin-x64` exists; testing
Binary is fine; exiting

> node-sass@2.1.1 postinstall /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-iconify/node_modules/gulp-sass/node_modules/node-sass
> node scripts/build.js

`darwin-x64-node-0.10` exists; testing
Binary is fine; exiting
npm ERR! Darwin 14.3.0
npm ERR! argv "node" "/opt/boxen/nodenv/versions/v0.10.5/bin/npm" "install"
npm ERR! node v0.10.5
npm ERR! npm  v2.11.0
npm ERR! code ELIFECYCLE

npm ERR! phantomjs@1.9.17 install: `node install.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the phantomjs@1.9.17 install script 'node install.js'.
npm ERR! This is most likely a problem with the phantomjs package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node install.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls phantomjs
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /Users/M8M/Sites/rollcall-pattern-library/npm-debug.log

sethburtonhall commented Jun 2, 2015

I am still having this error every time I run npm install

$ phantomjs -v
1.9.1

but it seems I need 1.9.17 but not sure how to upgrade to that version

> phantomjs@1.9.17 install /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-iconify/node_modules/gulp-svg2png/node_modules/svg2png/node_modules/phantomjs
> node install.js

PhantomJS detected, but wrong version 1.9.1 @ /opt/boxen/nodenv/versions/v0.10.5/bin/phantomjs.
Downloading https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-macosx.zip
Saving to /var/folders/81/jglkvkm16jdcw9494_lkvpr40000gn/T/phantomjs/phantomjs-1.9.8-macosx.zip
Using npmconf ca
Receiving...
|
Error making request.
Error: CERT_UNTRUSTED
    at SecurePair.<anonymous> (tls.js:1283:32)
    at SecurePair.EventEmitter.emit (events.js:92:17)
    at SecurePair.maybeInitFinished (tls.js:896:10)
    at CleartextStream.read [as _read] (tls.js:430:15)
    at CleartextStream.Readable.read (_stream_readable.js:304:10)
    at EncryptedStream.write [as _write] (tls.js:344:25)
    at doWrite (_stream_writable.js:211:10)
    at writeOrBuffer (_stream_writable.js:201:5)
    at EncryptedStream.Writable.write (_stream_writable.js:172:11)
    at write (_stream_readable.js:557:24)

Please report this full log at https://github.com/Medium/phantomjs

> node-sass@1.2.3 install /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-sass/node_modules/node-sass
> node scripts/install.js

Binary downloaded and installed at /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-sass/node_modules/node-sass/vendor/darwin-x64/binding.node

> node-sass@2.1.1 install /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-iconify/node_modules/gulp-sass/node_modules/node-sass
> node scripts/install.js


> node-sass@1.2.3 postinstall /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-sass/node_modules/node-sass
> node scripts/build.js

`darwin-x64` exists; testing
Binary is fine; exiting

> node-sass@2.1.1 postinstall /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-iconify/node_modules/gulp-sass/node_modules/node-sass
> node scripts/build.js

`darwin-x64-node-0.10` exists; testing
Binary is fine; exiting
npm ERR! Darwin 14.3.0
npm ERR! argv "node" "/opt/boxen/nodenv/versions/v0.10.5/bin/npm" "install"
npm ERR! node v0.10.5
npm ERR! npm  v2.11.0
npm ERR! code ELIFECYCLE

npm ERR! phantomjs@1.9.17 install: `node install.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the phantomjs@1.9.17 install script 'node install.js'.
npm ERR! This is most likely a problem with the phantomjs package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node install.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls phantomjs
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /Users/M8M/Sites/rollcall-pattern-library/npm-debug.log
@sethburtonhall

This comment has been minimized.

Show comment
Hide comment
@sethburtonhall

sethburtonhall Jun 2, 2015

tried npm set strict-ssl false

but ...

> phantomjs@1.9.17 install /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-iconify/node_modules/gulp-svg2png/node_modules/svg2png/node_modules/phantomjs
> node install.js

PhantomJS detected, but wrong version 1.9.1 @ /opt/boxen/nodenv/versions/v0.10.5/bin/phantomjs.
Downloading https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-macosx.zip
Saving to /var/folders/81/jglkvkm16jdcw9494_lkvpr40000gn/T/phantomjs/phantomjs-1.9.8-macosx.zip
Using npmconf ca
Receiving...

Error making request.
Error: 140735117423360:error:0906D06C:PEM routines:PEM_read_bio:no start line:../deps/openssl/openssl/crypto/pem/pem_lib.c:703:Expecting: CERTIFICATE

    at SlabBuffer.use (tls.js:232:18)
    at CleartextStream.read [as _read] (tls.js:417:29)
    at CleartextStream.Readable.read (_stream_readable.js:304:10)
    at tls.js:475:12
    at process._tickCallback (node.js:415:13)

Please report this full log at https://github.com/Medium/phantomjs
npm ERR! Darwin 14.3.0
npm ERR! argv "node" "/opt/boxen/nodenv/versions/v0.10.5/bin/npm" "install"
npm ERR! node v0.10.5
npm ERR! npm  v2.11.0
npm ERR! code ELIFECYCLE

npm ERR! phantomjs@1.9.17 install: `node install.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the phantomjs@1.9.17 install script 'node install.js'.
npm ERR! This is most likely a problem with the phantomjs package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node install.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls phantomjs
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /Users/M8M/Sites/rollcall-pattern-library/npm-debug.log

sethburtonhall commented Jun 2, 2015

tried npm set strict-ssl false

but ...

> phantomjs@1.9.17 install /Users/M8M/Sites/rollcall-pattern-library/node_modules/gulp-iconify/node_modules/gulp-svg2png/node_modules/svg2png/node_modules/phantomjs
> node install.js

PhantomJS detected, but wrong version 1.9.1 @ /opt/boxen/nodenv/versions/v0.10.5/bin/phantomjs.
Downloading https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-macosx.zip
Saving to /var/folders/81/jglkvkm16jdcw9494_lkvpr40000gn/T/phantomjs/phantomjs-1.9.8-macosx.zip
Using npmconf ca
Receiving...

Error making request.
Error: 140735117423360:error:0906D06C:PEM routines:PEM_read_bio:no start line:../deps/openssl/openssl/crypto/pem/pem_lib.c:703:Expecting: CERTIFICATE

    at SlabBuffer.use (tls.js:232:18)
    at CleartextStream.read [as _read] (tls.js:417:29)
    at CleartextStream.Readable.read (_stream_readable.js:304:10)
    at tls.js:475:12
    at process._tickCallback (node.js:415:13)

Please report this full log at https://github.com/Medium/phantomjs
npm ERR! Darwin 14.3.0
npm ERR! argv "node" "/opt/boxen/nodenv/versions/v0.10.5/bin/npm" "install"
npm ERR! node v0.10.5
npm ERR! npm  v2.11.0
npm ERR! code ELIFECYCLE

npm ERR! phantomjs@1.9.17 install: `node install.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the phantomjs@1.9.17 install script 'node install.js'.
npm ERR! This is most likely a problem with the phantomjs package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node install.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls phantomjs
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /Users/M8M/Sites/rollcall-pattern-library/npm-debug.log
@nicks

This comment has been minimized.

Show comment
Hide comment
@nicks

nicks Jun 2, 2015

Contributor

It looks like you have the CA settings in your npmconf misconfigured.

Contributor

nicks commented Jun 2, 2015

It looks like you have the CA settings in your npmconf misconfigured.

@sethburtonhall

This comment has been minimized.

Show comment
Hide comment
@sethburtonhall

sethburtonhall Jun 2, 2015

I am unfamiliar with that, looking into it.

The weird thing is that I have been developing and running npm install in this directory for a while. My co-worker added some gulp packages and I ran npm install to bring my local directory up to date, then ran into these problems. Wondering why?

sethburtonhall commented Jun 2, 2015

I am unfamiliar with that, looking into it.

The weird thing is that I have been developing and running npm install in this directory for a while. My co-worker added some gulp packages and I ran npm install to bring my local directory up to date, then ran into these problems. Wondering why?

@sethburtonhall

This comment has been minimized.

Show comment
Hide comment
@sethburtonhall

sethburtonhall Jun 2, 2015

any specific guidance would be appreciated.

sethburtonhall commented Jun 2, 2015

any specific guidance would be appreciated.

@sethburtonhall

This comment has been minimized.

Show comment
Hide comment
@sethburtonhall

sethburtonhall Jun 2, 2015

I am unsure of where the npmconf file is and unsure of what CA settings to add.

sethburtonhall commented Jun 2, 2015

I am unsure of where the npmconf file is and unsure of what CA settings to add.

@sraghavendra

This comment has been minimized.

Show comment
Hide comment
@sraghavendra

sraghavendra Jun 15, 2015

Got the same error while installing the phantomjs on node version 10.x

Upgraded to latest node (node version v0.12.4) and it is working fine now :)

sraghavendra commented Jun 15, 2015

Got the same error while installing the phantomjs on node version 10.x

Upgraded to latest node (node version v0.12.4) and it is working fine now :)

@NioTeX

This comment has been minimized.

Show comment
Hide comment
@NioTeX

NioTeX Jun 18, 2015

Was getting same error, updated to latest nodejs, and everything works now:

sudo npm cache clean -f
sudo npm install -g n
sudo n stable

NioTeX commented Jun 18, 2015

Was getting same error, updated to latest nodejs, and everything works now:

sudo npm cache clean -f
sudo npm install -g n
sudo n stable
@patrickmichalina

This comment has been minimized.

Show comment
Hide comment
@patrickmichalina

patrickmichalina Jun 19, 2015

👍 this blows up in azure...

  errno: -4058,
  code: 'ENOENT',
  path: 'D:\home\site\repository\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs\lib\phantom\ChangeLog' } Error: ENOENT, open 'D:\home\site\repository\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs\lib\phantom\ChangeLog'
    at Error (native)
npm ERR! Windows_NT 6.2.9200
npm ERR! argv "node" "D:\Program Files (x86)\npm\2.7.4\node_modules\npm\bin\npm-cli.js" "install"
npm ERR! node v0.12.2
npm ERR! npm  v2.7.4
npm ERR! code ELIFECYCLE

npm ERR! phantomjs@1.9.17 install: node install.js
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the phantomjs@1.9.17 install script 'node install.js'.
npm ERR! This is most likely a problem with the phantomjs package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node install.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls phantomjs
npm ERR! There is likely additional logging output above.```

patrickmichalina commented Jun 19, 2015

👍 this blows up in azure...

  errno: -4058,
  code: 'ENOENT',
  path: 'D:\home\site\repository\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs\lib\phantom\ChangeLog' } Error: ENOENT, open 'D:\home\site\repository\node_modules\gulp-uncss\node_modules\uncss\node_modules\phridge\node_modules\phantomjs\lib\phantom\ChangeLog'
    at Error (native)
npm ERR! Windows_NT 6.2.9200
npm ERR! argv "node" "D:\Program Files (x86)\npm\2.7.4\node_modules\npm\bin\npm-cli.js" "install"
npm ERR! node v0.12.2
npm ERR! npm  v2.7.4
npm ERR! code ELIFECYCLE

npm ERR! phantomjs@1.9.17 install: node install.js
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the phantomjs@1.9.17 install script 'node install.js'.
npm ERR! This is most likely a problem with the phantomjs package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node install.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls phantomjs
npm ERR! There is likely additional logging output above.```
@nicks

This comment has been minimized.

Show comment
Hide comment
@nicks

nicks Jun 23, 2015

Contributor

@patrickmichalina ENOENT usually means that you do not have node installed on PATH. See https://github.com/Medium/phantomjs#installation-fails-with-spawn-enoent

Contributor

nicks commented Jun 23, 2015

@patrickmichalina ENOENT usually means that you do not have node installed on PATH. See https://github.com/Medium/phantomjs#installation-fails-with-spawn-enoent

@nicks

This comment has been minimized.

Show comment
Hide comment
@nicks

nicks Jun 23, 2015

Contributor

I'm locking this issue, because it is becoming a dumping ground for lost souls complaining about unrelated issues.

Contributor

nicks commented Jun 23, 2015

I'm locking this issue, because it is becoming a dumping ground for lost souls complaining about unrelated issues.

@Medium Medium locked and limited conversation to collaborators Jun 23, 2015

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.