Skip to content
master
Go to file
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

README.md

Zesty

This is the WordPress base theme Zesty. Zesty is a powerful, yet simple, WordPress base theme with a responsive, mobile-first grid design. What that means is Zesty is a collection of best practices and patterns for maintainable, responsive WordPress themes.

You can use the child theme Zestful as a starting point for your new projects: https://github.com/cmwelsh/zestful

Please install Zesty and Zestful in the theme folder together and start transforming the Zestful child theme into your client's website!

Everyone has their own preferences. This isn't meant to be the best solution for everyone. It has opinions and conventions built-in. You can fork this base theme for even more customization - make this base theme your own!

Requirements

Zesty requires PHP 5.3 or greater.

Zesty has been tested and is compatible with WordPress 3.4.2 and greater.

Zesty requires Ruby 1.9+. Eventually we'll package the Sass tooling into a cross-platform application, but for now you must have Ruby and you must manually install the master branch versions of the following gems:

  • Compass 0.13 (alpha)
  • Susy 1.0.5 (alpha)

This will be nicer once the major versions for these Sass libraries are released.

Zesty highly recommends but does not require Advanced Custom Fields for creating custom WordPress meta boxes - use what works best for you: http://advancedcustomfields.com/

Change History

2012-11-22:

  • Initial release of Zestful child theme including Compass/Sass/Susy support

License

Copyright 2012 Chris M. Welsh

This theme is licensed under the GNU GPLv2 or later. The full license is here: http://www.gnu.org/licenses/gpl-2.0.html

About

Zesty is a powerful, yet simple, WordPress base theme with a responsive, mobile-first grid design.

Resources

Releases

No releases published

Languages

You can’t perform that action at this time.