Skip to content

Instructions in README.md for running unit tests is incorrect #4

Closed
ebryn opened this Issue May 26, 2011 · 3 comments

3 participants

@ebryn
Ember.js member
ebryn commented May 26, 2011

There is no amber directory.

Running spade update inside the repo root dir gives an error:

ejb-mbp2:sproutcore20 ebryn$ spade update
/Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/spade-0.0.7/lib/spade/bundle.rb:79:in read': Too many levels of symbolic links - /Users/ebryn/Dev/repos/sproutcore20/.spade/packages/handlebars/package.json (Errno::ELOOP)
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/spade-0.0.7/lib/spade/bundle.rb:79:in
gen_spade_boot'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/spade-0.0.7/lib/spade/bundle.rb:77:in map'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/spade-0.0.7/lib/spade/bundle.rb:77:in
gen_spade_boot'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/spade-0.0.7/lib/spade/bundle.rb:67:in update'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/spade-0.0.7/lib/spade/bundle.rb:66:in
open'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/spade-0.0.7/lib/spade/bundle.rb:66:in update'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/spade-0.0.7/lib/spade/cli/base.rb:120:in
update'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/thor-0.14.6/lib/thor/task.rb:22:in send'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/thor-0.14.6/lib/thor/task.rb:22:in
run'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/thor-0.14.6/lib/thor/invocation.rb:118:in invoke_task'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/thor-0.14.6/lib/thor.rb:263:in
dispatch'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/thor-0.14.6/lib/thor/base.rb:389:in start'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/gems/spade-0.0.7/bin/spade:7
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/bin/spade:19:in
load'
from /Users/ebryn/.rvm/gems/ree-1.8.7-2010.02/bin/spade:19

Running spade preview works from the repo root dir, but tests aren't running when navigating to the test URL. From the web inspector ot looks like spade-boot.js is empty. Tested with Chrome 12 and Safari 5.

@erichocean

I also had a problem installing spade. Created an issue here: https://github.com/strobecorp/spade/issues/5

@Gimi Gimi pushed a commit to Gimi/sproutcore20 that referenced this issue May 30, 2011
Gimi Liang Fix the 'How to Run Unit Tests' part in the README.md file. Fix issue #4
.
231f4b1
@wycats
Ember.js member
wycats commented Jun 1, 2011

This should be fixed in the latest README update/spade gem release.

@wycats wycats closed this Jun 1, 2011
@ebryn
Ember.js member
ebryn commented Jun 1, 2011

Yeah, I can confirm that.

@nickiaconis nickiaconis added a commit to nickiaconis/ember.js that referenced this issue Jun 1, 2016
@nickiaconis nickiaconis Unskip #4 1a9576e
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.