Managed Metadata fields not appearing as Crawled Properties. Is this a wider SharePoint search issue? #4946
Replies: 16 comments 19 replies
|
Yes, we are seeing the same across tenants. But not just limited to managed metadata fields. No custom properties are being picked up as crawled properties. We found SP1393483 that describes the same issue, but this is marked as resolved on Jul 30 2026. |
|
Yes, it seems to be a general problem, two of my tenants have that issue now. |
|
I have the same issue with one tenant to reproduce the issue. I have a support case open with Microsoft TrackingID#2608261420000493 |
|
We have 3 support tickets open across 3 different tenants in relation to this issue their Case Numbers are:
|
|
I'm getting some more IDs, but here is one to start with: TrackingID#2512020030000080 |
|
This might be related: For the past year we've been experiencing an issue where new SharePoint fields are no longer generating crawled properties. This is not limited to managed metadata fields. Microsoft is aware of the issue and is working on a fix. As a temporary workaround, Microsoft has manually created crawled properties for us and has provided the Add-PnPTenantSearchCrawledProperty cmdlet for scenarios where crawled properties are not automatically generated so we don't have to ask Microsoft to create them. https://pnp.github.io/powershell/cmdlets/Add-PnPTenantSearchCrawledProperty.html Please be careful with this. TrackingID#2512311420000511 |
|
My workaround was the following. Funny note: searching for "ows_oneWorld" or "ows_oneWorldDepartment" did not find any results. |
|
Fellow MVP Edine Olijve pointed me to the new PnP PowerShell cmd Add-PnPTenantSearchCrawledProperty and it works as a fine workaround, see script at https://www.linkedin.com/feed/update/urn:li:activity:7501012861113106432/ |
|
We are seeing this issue as well, we don't have managed metadata, but regular columns are not showing up as crawled properties. |
|
Another case number to share: #2609100040007752 |
|
I'm seeing this in one tenant as well. I don't have a support ticket to share but wanted to add my woes. My ISSUES are with both Managed Metadata and Date and Time columns. I'll be trying the PnP.PowerShell cmdlet as a workaround. Add-PnPTenantSearchCrawledProperty @IdsVibe said there was supposed to be a fix rolled out on Sept 15. Anyone seen a positive results yet? |
|
Hi, Wondered how everyone's experiences with the fixes are going? This week, I have been able to find my managed metadata columns as crawled properties, but they're appearing greyed out. I was able to enter the properties menu for one of my greyed out fields from the Crawled Properties and add attach a mapping to a RefinableString but got the error message SettingDoesNotExist error (see pic). When I attempt to go from the Managed properties menu and map via the RefinableString to a crawled property instead, the crawled property doesn't show up in the list of available properties. I guess my question is, is this case suitable for use of the Add-CrawledProperty cmdlet?
Many thanks for any advice. |
|
hi @ALL. |
|
Here is a consolidated list of the 10 Microsoft tracking IDs so far in this thread in case you want to provide them to Microsoft, including a new one from our client. 2609100040007752 |
|
None of my team have reported any improvements for the customers affected by this issue. Is there anything official communicated by Microsoft about the fix rollout? |
|
On some tenants, https://pnp.github.io/powershell/cmdlets/Add-PnPTenantSearchCrawledProperty.html failed with the error:
In our case, this occurred because no custom mappings were present in the search schema. We were able to resolve the issue by adding an existing crawled property to an unused RefinableString managed property. It took us a while to figure this out, so hopefully this saves someone else some time. |

Uh oh!
There was an error while loading. Please reload this page.
We are seeing Microsoft Search issues across multiple tenants where Managed Metadata fields are failing to appear as crawled properties, making them impossible to map to managed properties.
We've reproduced the issue across multiple sites and tenants, reindexed libraries and sites, created new content, recreated taxonomy columns, verified term sets are published, and confirmed the fields contain populated values. Despite this, the expected crawled properties never appear in the search schema.
What's particularly confusing is that the behaviour is inconsistent. In some tenants only certain Managed Metadata fields are affected while others continue to work normally. In other tenants we cannot reproduce the issue at all and search behaves as expected.
Has anyone else encountered this recently, or received any guidance from Microsoft?
All reactions