Caddy not supported in latest Shlink versions? (Cannot serve Shlink at all and add to app.shlink.io) #213
Unanswered
bonarae
asked this question in
Help wanted
Replies: 1 comment 2 replies
|
I have never used Caddy, so it's hard for me to help, but a few things I would try first.
I don't fully understand what you mean by this. |
2 replies
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Uh oh!
There was an error while loading. Please reload this page.
Shlink version
5.1.5
PHP version
8.5.9
How do you serve Shlink
Other (explain in summary)
Database engine
MySQL
Database version
8.0.46
Current behavior
Currently, I am configuring Shlink 5.1.5 to run on Caddy 2.11.4 and PHP 8.5.9. Up to the auto-config step on the CLI, it succeeds; however, once I get to serve Shlink from my functional Caddy server, it fails with either HTTP 500 (majority of the time, with php_fastcgi left as default values) or HTTP 404 (with the try_files and index directives copied from the Nginx section of Shlink documentation). I searched far and wide on possible causes, but I cannot find a root cause just yet. PHP-FPM is functioning well in my case (however, its sibling subdomains on Caddy run PHP 8.3, while this one runs PHP 8.5).
I cannot decouple the other functional websites (they all reside as different subdomains on one IP address and one domain) from Caddy, so I cannot use RoadRunner just for Shlink.
Expected behavior
Shlink is running on the server and can be added to app.shlink.io.
Minimum steps to reproduce
/var/www/html/etc/caddy/Caddyfilewith the defaultphp_fastcgiparametersConfiguration for the Shlink instance/subdomain from the functional Caddyfile:
All reactions