Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Vendor in requirementslib==2.0.0 & drop pip-shims & revert sysconfig patch w/ safer setuptools usage #5228

Merged
merged 14 commits into from
Aug 24, 2022

Conversation

matteius
Copy link
Member

@matteius matteius commented Aug 7, 2022

Vendor in requirementslib==2.0.0 and drop pip-shims entirely.

Some systems have patched sysconfig differently, and from this discussion (pypa/setuptools#3544) it would appear that importing setuptools packages is problematic

@matteius matteius added DO NOT MERGE Status: In Progress This item is in progress. labels Aug 7, 2022
@matteius matteius changed the title Look ahead at what dropping pip-shims is like. Vendor in requirementslib==2.0.0 and drop pip-shims Aug 24, 2022
@matteius matteius added PR: awaiting-review The PR related to this issue is awaiting review by a maintainer. and removed DO NOT MERGE Status: In Progress This item is in progress. labels Aug 24, 2022
@matteius matteius requested a review from oz123 August 24, 2022 13:52
@matteius matteius changed the title Vendor in requirementslib==2.0.0 and drop pip-shims Vendor in requirementslib==2.0.0 & drop pip-shims & revert sysconfig patch w/ safer setuptools usage Aug 24, 2022
@oz123
Copy link
Contributor

oz123 commented Aug 24, 2022

We still need to fix the merge conflicts @matteius

@matteius matteius merged commit e4cc8f2 into main Aug 24, 2022
@matteius matteius deleted the requirementslib-test branch August 24, 2022 18:09
@matteius
Copy link
Member Author

@oz123 I had merged main into this branch and resolved them, squash and merge did not show any conflicts so I went ahead and merged, thanks for your review!

yeisonvargasf pushed a commit to yeisonvargasf/pipenv that referenced this pull request Nov 19, 2022
…fig patch w/ safer setuptools usage (pypa#5228)

* Vendor in requirementslib 2.0.0

* Drop sysconfig default patch.

* Remove setuptools import usages in pipenv.

* Add news fragment.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
PR: awaiting-review The PR related to this issue is awaiting review by a maintainer.
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants