Replies: 4 comments 4 replies
|
Not that complicated. What about using a domain name that has both IPv4 and IPv4 servers? PS: Seems not to serve itself here. |
1 reply
|
Resolving a name requires working DNS, so that would be a dead lock. |
1 reply
|
It would be nice if we could add multiple probe addresses in case of censorship, this is something that could've been done a while ago. |
1 reply
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment

Uh oh!
There was an error while loading. Please reload this page.
Uh oh!
There was an error while loading. Please reload this page.
currently you can only use 1 value for
netprobe_addressthis causes issues if you want a configuration to support IPv6 and IPv4, if you setnetprobe_addressto9.9.9.9:53in the config then it will only work on IPv4 supported networks, and if you put[2620:fe::fe]:53then it will only work on IPv6 networksIPv6-only
from
970c500on master with an IPv6 only arch linux host, (IPv4 is disabled at the host level not the network level for this test):netprobe_address = '9.9.9.9:53':-> go run ./dnscrypt-proxy/ -config ./config.toml [2026-09-28 23:29:30] [NOTICE] dnscrypt-proxy 2.1.19 [2026-09-28 23:29:30] [NOTICE] Using default Weighted Power of Two (WP2) load balancing strategy [2026-09-28 23:29:30] [NOTICE] Network not available yet -- waiting...netprobe_address = '[2620:fe::fe]:53':-> go run ./dnscrypt-proxy/ -config ./config.toml [2026-09-28 23:29:57] [NOTICE] dnscrypt-proxy 2.1.19 [2026-09-28 23:29:57] [NOTICE] Using default Weighted Power of Two (WP2) load balancing strategy [2026-09-28 23:29:57] [NOTICE] Network connectivity detected [2026-09-28 23:29:57] [NOTICE] Now listening to [::1]:58003 [UDP] [2026-09-28 23:29:57] [NOTICE] Now listening to [::1]:58003 [TCP]IPv4-only
from the same host with IPv4 enabled, and a v4 only docker network
netprobe_address = '[2620:fe::fe]:53':netprobe_address = '9.9.9.9:53':All reactions