Repository navigation
Jaybird 5.0.11
What's new
This release is not fully compatible with the upcoming JDBC 4.5 Specification to be introduced with Java 26.
Future maintenance releases of Jaybird 5 may stop expanding Java support to include newly released Java versions. If you use Java 17 or higher, we recommend upgrading to Jaybird 6.
The following has been changed or fixed since Jaybird 5.0.10:
- Backported fatal error detection improvements for
FBPooledConnectionfrom Jaybird 6 (#899) - Fixed:
FBServiceManager.getAuthPlugins()reported thedbCryptConfigvalue (#902) - Fixed:
Statement.cancel()causes lockup (#904) - Fixed: Incomplete detection of fatal connection errors for deferred actions (#905)
- Dependency update: updated
net.java.dev.jna:jnafrom 5.17.0 to 5.18.1 (used by native and embedded protocols) (#911) - Fixed:
FBDatabaseMetaData.getJDBCMinorVersion()should report 4 (for JDBC 4.4) on Java 24 and higher (#914)
Jaybird 5 supports Firebird 2.5, Firebird 3.0, Firebird 4.0, and Firebird 6.0, on Java 8, Java 11, Java 17, Java 21, and Java 25 (support for Java 11 and higher using the Java 11 version of the driver).
Bug reports about undocumented changes in behavior are appreciated. Feedback can be sent to the Firebird-java Google Group or reported on the issue tracker https://github.com/FirebirdSQL/jaybird/issues.
See also the full Jaybird 5 release notes.
Maven
The release is also available on Maven(*):
<groupId>org.firebirdsql.jdbc</groupId>
<artifactId>jaybird</artifactId>
<version>5.0.11.java11</version>* The version depends on your target Java version: 5.0.11.java11 for Java 11 and higher, or 5.0.11.java8 for Java 8.