Repository navigation
v0.14.0
Minor changes
- Drop the
vite-pluspeer dependency so consumers no longer install vulnerablevite-plus0.1.x (Windows-only launch-editor advisories, fixed in vite-plus 1.1.0). (#47) obsidian-e2e/matchersnow extends theexpectfromvitest, the same runner theobsidian-e2e/vitestfixtures bind to, so the matchers work in plain Vitest projects. Its typings target Vitest 5. With Vite+ 1.1 or later,vite-plus/testre-exports Vitest, soexpectfrom either module has the matchers. Vite+ 0.1.x projects that use the matchers should upgrade to Vite+ 1.1 or later.- The
yamldependency now requires 2.8.3 or later (GHSA-48c2-rrv3-qjmp).
Upgrading
Bump obsidian-e2e to ^0.14.0 and reinstall. vite-plus drops out of the dependency tree for projects that don't depend on it themselves.