New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Website][Bug] Enterprise Support packages link returns a 404 resulting in the default not found slim #318

Closed
Downright-Development opened this Issue Nov 1, 2018 · 3 comments

Comments

Projects
None yet
3 participants
@Downright-Development

Downright-Development commented Nov 1, 2018

From the https://cucumber.io/support#slack page, the "Enterprise section" provides a link to the CucumberPaidSupportPlan.pdf. Currently when clicking that link (https://cucumber.io/CucumberPaidSupportPlans.pdf) leads to a 404 and the default not found slim.

It appears the functionality occurs on line 89 within https://github.com/cucumber/website/blob/master/apps/dynamic/views/support.slim with the appropriate PDF to be displayed at https://github.com/cucumber/website/blob/master/apps/static/public/CucumberPaidSupportPlans.pdf.

I attempted to work on a PR for this... but i'm not very familiar with web dev, nor could I see where the pdfs/assets were being pushed out.

This error was also reproduced standing up the site locally (in the dev environment). See attachment.
cucumbersupportpdferror

cucumbersupportpdfresults

@aslakhellesoy

This comment has been minimized.

Contributor

aslakhellesoy commented Nov 1, 2018

@mattwynne could you have a look at this please? I suppose it happened as part of the recent website changes. Either restore the doc, remove the link or update it.

@mattwynne

This comment has been minimized.

Member

mattwynne commented Nov 1, 2018

Thanks for reporting @Downright-Development. I've moved the support page over to the new squarespace site.

@mattwynne mattwynne closed this Nov 1, 2018

@aslakhellesoy

This comment has been minimized.

Contributor

aslakhellesoy commented Nov 2, 2018

Thanks @mattwynne. Minor niggle - Enterprise Support now links to Premium Support. Could you make that consistent please?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment