Replies: 2 comments 2 replies
|
@manuelbuil might have more insight, but off the top of my head, I see that you didn't include |
0 replies
I don't think this issue is unique to use of tailscale, is it? How are routes on your node set up to handle traffic to this address? 169.254.0.0/16 is meant to be only for link-local traffic, I wouldn't expect pods to be able to reach it. |
2 replies
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Uh oh!
There was an error while loading. Please reload this page.
Uh oh!
There was an error while loading. Please reload this page.
Honestly, I spent the last two days trying to make this function but to no avail.
I saw that k3s supports Distributed hybrid or multicloud cluster using Tailscale so I have been trying that to run on my OCI instance (control plane) and VM (agent), but neither (as server node) works.
For example, CoreDNS pod on OCI tries to connect to the OCI's DNS resolver (169.254.169.254:53) but timeout and keeps restarting:
[ERROR] plugin/errors: 2 4231284254469202388.2483753640335683092. HINFO: read udp 10.42.0.14:49386->169.254.169.254:53: i/o timeoutThe same error occurs on my homelab VM, unable to connect to the DNS resolver of my private network.
Here is my installation args:
curl -sfL https://get.k3s.io | INSTALL_K3S_EXEC="--tls-san <ip_address>" sh -s - --docker --vpn-auth="name=tailscale,joinKey=<tailscale_auth_key>" --cluster-initMy tailscale ACL:
This error does not appear if I don't add --vpn-auth args.
Note that I haven't even managed to connect an agent yet, just trying to make the server works with Tailscale.
Honestly, I don't really have to use Tailscale, but since I do not have a static public IP on my homelab VM, and I already have Tailscale, so I pick that option. If there is other option then I'll pick that one.
All reactions