New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

look into adding video streaming support to AVFoundationPlayer #1741

Closed
julapy opened this Issue Dec 10, 2012 · 14 comments

Comments

Projects
None yet
@julapy
Copy link
Member

julapy commented Dec 10, 2012

the initial forum topic is here,
http://forum.openframeworks.cc/index.php/topic,11497

@philworthy

This comment has been minimized.

Copy link

philworthy commented Jan 30, 2013

Hi @julapy - don't suppose you had any luck getting m3u8 streams working on AVFoundationVideoPlayer? :)

@julapy

This comment has been minimized.

Copy link
Member

julapy commented Jan 30, 2013

hey @philworthy,
no i haven't done anything on this since posting this issue.
pretty busy atm with projects but will look into for the 0.8.0 milestone.

@freber

This comment has been minimized.

Copy link

freber commented May 1, 2013

Any news? :) I would be very thankful if this was possible. :)

@pizthewiz pizthewiz added the macOS label Feb 5, 2015

@pizthewiz

This comment has been minimized.

Copy link
Member

pizthewiz commented Feb 5, 2015

Not sure if this fits in 0.9.0 still, regardless the iOS and OS X players will merge soon via #3590, so adding the macOS label here too.

@ofTheo

This comment has been minimized.

Copy link
Contributor

ofTheo commented Feb 6, 2015

can confirm this is still an issue and with the single AV player now for iOS and OSX.

@pizthewiz

This comment has been minimized.

Copy link
Member

pizthewiz commented Feb 6, 2015

I think @dantheman and @vade looked into this a bit during the dev jam weekend in early January. Snooping around I see a branch vade/openFrameworks/AVFoundation_HLS_Fix but I'm not sure if it bore fruit and of course we just swapped video players in #3590 so…

@vade

This comment has been minimized.

Copy link
Contributor

vade commented Feb 6, 2015

Oh - ha. Yea. Life and all that. This 'works' in as much as I can get a stream to 'play' in quotes, but something upstream in the texture uploading is fucking up royally because some checking / assertion about width/height and CVPIxelBuffer square pixel nonesense.

Basically, some streams aren't square pixel aspect ratio. The test stream isn't. Also the method you request width and height doesnt work until the video is rolling, so its kind of a setup catch 22.

I spoke with @danthemellowman about this a while back and then got annoyed with it and put it down.

BASICALLYICANTFINISHANYTHINGOK.

:P

Feel free to look at what I have and see if you can figure out whats what. if you fire off the apple HSL test stream you'll hear audio IIRC, but won't get video due to the above oddities in the texture upload pipeline.

@pizthewiz

This comment has been minimized.

Copy link
Member

pizthewiz commented Feb 6, 2015

Awesome, that is super helpful and provides some good intel to work from. It looks like the commit to scope out is 58843ff6. Not sure if the new new (hours old) AV Foundation video player has the same hangups, but we definitely have some specifics to investigate - thanks!

@vade

This comment has been minimized.

Copy link
Contributor

vade commented Feb 6, 2015

No worries. Glad I can be of some help. 👍

@jvcleave

This comment has been minimized.

Copy link
Member

jvcleave commented Aug 8, 2016

Hey all,

In trying to see what the issue is I started this project
https://github.com/jvcleave/AvFoundationPlayer

It is currently able to

  • read an HLS stream
  • play audio
  • get correct dimensions and current time of video playing
  • apparently reading pixels in the sense that it reports that they have changed

I figure once this works the next step would be to integrate it into the ofAvFoundation player. I'm not really familiar enough with CoreVideo/CoreMedia to know what I need to do to get it into ofPixels/ofTexture

edit: pixels/textures now working but only through ofImage

@jvcleave

This comment has been minimized.

Copy link
Member

jvcleave commented Aug 9, 2016

The above project now works with:

  • looping
  • corrected color
  • pixel/texture access (removed ofImage dependency)
  • seeking (only forward testing)
  • isFrameNew

It's currently fairly light at jvcleave/ofxAvFoundationHLSPlayer@1a26b07

I have to move on to finish a project not based on master but can look at it in a few weeks

@jeraman

This comment has been minimized.

Copy link

jeraman commented Apr 7, 2017

Would you have any news from this by any chance?

Just as a reference, I'm struggling to get a m3u8 HLS inside oF:
https://forum.openframeworks.cc/t/hls-m3u8-http-live-streaming-video/11927

@i-n-g-o

This comment has been minimized.

Copy link
Contributor

i-n-g-o commented Apr 8, 2017

here a PR tackling this issue:
#5530

should not have any side-effects...

arturoc added a commit that referenced this issue Apr 23, 2017

Merge pull request #5530 from i-n-g-o/#1741_ofAVFoundationPlayer_addi…
…ng_video_streaming

#1741 of av foundation player adding video streaming
@bakercp

This comment has been minimized.

Copy link
Member

bakercp commented May 20, 2017

Closed with #5530 if not, please reopen.

@bakercp bakercp closed this May 20, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment